summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomislav Ivek2018-10-19 17:23:52 +0200
committerTomislav Ivek2018-10-19 17:23:52 +0200
commit4a45051ef279facad85650124cb656233f09c031 (patch)
tree2eaf8a985fe886087dc1227bec469cbbbd320144
parentc2ad424c01d44735135b9bdb5f33a5076e36574e (diff)
downloadaur-4a45051ef279facad85650124cb656233f09c031.tar.gz
add dependency to python-tqdm
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--arch-reqs.patch30
3 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 657eb57c03e6..7d4904b9148c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = conan-git
pkgdesc = A distributed, open source, C/C++ package manager.
- pkgver = 1.7.2.r64.gd8e068f4
+ pkgver = 1.8.3.r69.gf9f8eca7
pkgrel = 1
url = https://conan.io
arch = any
@@ -22,12 +22,13 @@ pkgbase = conan-git
depends = python-pygments>=2.0
depends = python-astroid>=1.6.5
depends = python-deprecation>=2.0
+ depends = python-tqdm>=4.27
provides = conan
conflicts = conan
source = conan-git::git+https://github.com/conan-io/conan.git
source = arch-reqs.patch
md5sums = SKIP
- md5sums = 36fed60f527200d36d3c6565982568b9
+ md5sums = 00cd9b113e8fd00b0be6e5f0f85806a7
pkgname = conan-git
diff --git a/PKGBUILD b/PKGBUILD
index b800e3b5be0d..0d014e523b1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tomislav Ivek <tomislav.ivek@gmail.com>
pkgname=conan-git
-pkgver=1.7.2.r64.gd8e068f4
+pkgver=1.8.3.r69.gf9f8eca7
pkgrel=1
pkgdesc="A distributed, open source, C/C++ package manager."
arch=('any')
@@ -23,12 +23,13 @@ depends=('python-pyjwt>=1.4.0'
'python-future=0.16.0'
'python-pygments>=2.0'
'python-astroid>=1.6.5'
- 'python-deprecation>=2.0')
+ 'python-deprecation>=2.0'
+ 'python-tqdm>=4.27')
provides=('conan')
conflicts=('conan')
source=("conan-git::git+https://github.com/conan-io/conan.git" "arch-reqs.patch")
md5sums=('SKIP'
- '36fed60f527200d36d3c6565982568b9')
+ '00cd9b113e8fd00b0be6e5f0f85806a7')
pkgver() {
diff --git a/arch-reqs.patch b/arch-reqs.patch
index 8c3e10e3322a..2dad8edcd3bd 100644
--- a/arch-reqs.patch
+++ b/arch-reqs.patch
@@ -1,7 +1,17 @@
-diff -ura conan-1.7.0-pristine/conans/requirements.txt conan-1.7.0-new/conans/requirements.txt
---- conan-1.7.0-pristine/conans/requirements.txt 2018-08-29 09:50:03.000000000 +0200
-+++ conan-1.7.0-new/conans/requirements.txt 2018-08-29 20:46:21.124478890 +0200
-@@ -1,14 +1,14 @@
+diff -ura conan-git-pristine/conans/requirements_server.txt conan-git-new/conans/requirements_server.txt
+--- conan-git-pristine/conans/requirements_server.txt 2018-10-19 17:21:30.200162556 +0200
++++ conan-git-new/conans/requirements_server.txt 2018-10-19 17:21:59.830168824 +0200
+@@ -1,3 +1,3 @@
+ # Server
+-bottle>=0.12.8, < 0.13
+-pluginbase>=0.5, < 1.0
+\ No newline at end of file
++bottle>=0.12.8
++pluginbase>=0.5
+diff -ura conan-git-pristine/conans/requirements.txt conan-git-new/conans/requirements.txt
+--- conan-git-pristine/conans/requirements.txt 2018-10-19 17:21:30.210162558 +0200
++++ conan-git-new/conans/requirements.txt 2018-10-19 17:21:59.833502159 +0200
+@@ -1,15 +1,15 @@
-PyJWT>=1.4.0, <2.0.0
-requests>=2.7.0, <3.0.0
-colorama>=0.3.3, <0.4.0
@@ -23,14 +33,6 @@ diff -ura conan-1.7.0-pristine/conans/requirements.txt conan-1.7.0-new/conans/re
+pygments>=2.0
astroid>=1.6.5
-deprecation>=2.0, <2.1
+-tqdm-conan==4.27.0
+deprecation>=2.0
-diff -ura conan-1.7.0-pristine/conans/requirements_server.txt conan-1.7.0-new/conans/requirements_server.txt
---- conan-1.7.0-pristine/conans/requirements_server.txt 2018-08-29 09:50:03.000000000 +0200
-+++ conan-1.7.0-new/conans/requirements_server.txt 2018-08-29 20:46:48.419563288 +0200
-@@ -1,3 +1,3 @@
- # Server
--bottle>=0.12.8, < 0.13
--pluginbase>=0.5, < 1.0
-\ No newline at end of file
-+bottle>=0.12.8
-+pluginbase>=0.5
++tqdm>=4.27.0