summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornotdixon2022-08-22 14:17:12 +0100
committernotdixon2022-08-22 14:17:12 +0100
commit62d314a43019e23e2d9d6ce696d6b11decaf05c4 (patch)
treeac938ad7a4337d2b285c8a19b4cc2f40f3bc466f
downloadaur-62d314a43019e23e2d9d6ce696d6b11decaf05c4.tar.gz
Conceal Desktop v6.6.5
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d8195bfa48a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = conceal-desktop
+ pkgdesc = Conceal GUI (release version)
+ pkgver = 6.6.5
+ pkgrel = 1
+ url = https://github.com/ConcealNetwork/conceal-desktop
+ arch = any
+ license = MIT
+ makedepends = make
+ makedepends = gcc
+ makedepends = cmake
+ makedepends = python
+ makedepends = boost
+ makedepends = boost-libs
+ makedepends = qt5-base
+ depends = boost
+ depends = boost-libs
+ depends = qt5-base
+ source = https://github.com/ConcealNetwork/conceal-desktop/archive/refs/tags/6.6.5.tar.gz
+ source = https://patch-diff.githubusercontent.com/raw/ConcealNetwork/conceal-core/pull/303.diff
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = conceal-desktop
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7727bfaed1af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: notdixon <notdixon at gmx dot com>
+
+pkgname=conceal-desktop
+pkgver=6.6.5
+pkgrel=1
+pkgdesc="Conceal GUI (release version)"
+arch=('any')
+url="https://github.com/ConcealNetwork/conceal-desktop"
+license=('MIT')
+depends=('boost' 'boost-libs' 'qt5-base')
+makedepends=('make' 'gcc' 'cmake' 'python' 'boost' 'boost-libs' 'qt5-base')
+source=("https://github.com/ConcealNetwork/$pkgname/archive/refs/tags/$pkgver.tar.gz"
+ "https://patch-diff.githubusercontent.com/raw/ConcealNetwork/conceal-core/pull/303.diff")
+sha256sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ rm -rf cryptonote
+ git clone https://github.com/ConcealNetwork/conceal-core cryptonote
+ cd cryptonote
+
+ git checkout 6.6.5
+ patch --forward --strip=1 --input="${srcdir}/303.diff"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make build-release
+}
+
+package() {
+ mkdir -p $pkgdir/usr/local/bin
+ cp "$srcdir/$pkgname-$pkgver/build/release/conceal-desktop" "$pkgdir/usr/local/bin/"
+}