summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBram Swenson2017-03-08 00:55:14 -0800
committerBram Swenson2017-03-08 00:55:14 -0800
commitaff8a0cfa673077b102dffe931ba40d8ee462f47 (patch)
treeef38ebe198017ef428c88003f7c32233f6225218
downloadaur-aff8a0cfa673077b102dffe931ba40d8ee462f47.tar.gz
concourse v2.7.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD18
-rwxr-xr-xbuild19
4 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e61e58c60f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = concourse
+ pkgdesc = Concourse is a pipeline-based CI system written in Go.
+ pkgver = v2.7.0
+ pkgrel = 1
+ url = https://concourse.ci/introduction.html
+ arch = x86_64
+ license = Apache
+ provides = concourse
+ source = https://github.com/concourse/concourse/releases/download/v2.7.0/concourse_linux_amd64
+ sha512sums = fdbe5a9aa980a097b33f49456a32b66b6148767070fefc1ee0e9c3cd7d8414bdb8d8a154633999c44369e1c550490fcb6fd4a261100ba83b1b56b99840fe6f4b
+
+pkgname = concourse
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..239e8ac3deba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/pkg/
+/zcash/
+/src/
+/*.tar.gz
+/*.xz
+/concourse_linux_amd64
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f38b41427a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Bram Swenson <bram@amplified.work>
+
+pkgname='concourse'
+pkgver=v2.7.0
+pkgrel=1
+pkgdesc="Concourse is a pipeline-based CI system written in Go."
+arch=(x86_64)
+url="https://concourse.ci/introduction.html"
+license=('Apache')
+source=(https://github.com/concourse/concourse/releases/download/${pkgver}/concourse_linux_amd64)
+sha512sums=('fdbe5a9aa980a097b33f49456a32b66b6148767070fefc1ee0e9c3cd7d8414bdb8d8a154633999c44369e1c550490fcb6fd4a261100ba83b1b56b99840fe6f4b')
+provides=('concourse')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ cp "concourse_linux_amd64" "$pkgdir/usr/bin/concourse"
+ chmod ugo+x "$pkgdir/usr/bin/concourse"
+}
diff --git a/build b/build
new file mode 100755
index 000000000000..0418a091d314
--- /dev/null
+++ b/build
@@ -0,0 +1,19 @@
+#!/usr/bin/env bash
+
+make_srcinfo () {
+ makepkg --printsrcinfo > .SRCINFO
+}
+
+build () {
+ makepkg -s
+}
+
+clean () {
+ rm -rf *.pkg.tar.xz *.tar.gz ; rm -rf ./pkg ./src ; true
+}
+
+main () {
+ clean && build && make_srcinfo
+}
+
+main "$@"