summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2017-10-01 08:17:28 +0200
committerpancho horrillo2017-10-01 08:17:28 +0200
commitbc9933d5a6c15d89b2dc99d36630b5bfc3fe89bf (patch)
tree50cd7d2826a666460b0558d53299a7c3062be451
parent500c453ebf070c03be8f940c9ab8691da69793dd (diff)
downloadaur-bc9933d5a6c15d89b2dc99d36630b5bfc3fe89bf.tar.gz
Move 'linuxns' to 'optdepends', minor tweaks
I've moved 'linuxns' to 'optdepends', in order to let the user choose which kernel to use ('linux-zen' is an alternative, that lives in @extra, so it is prebuilt, or the user might choose to built their own kernel with USER_NS enabled). It is not ideal, because it declares it as optional, while it is not, but unfortunately 'depends' cannot handle alternate dependencies. And the build time of the linuxns package is too big to ignore. By adding a 'replaces' array, we allow for smooth transition for the users who had installed the previous version, named simply 'concourse'. Also, I've made liberal use of vars to reduce redundancy.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d15f49d64afd..103a06822175 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Oct 1 06:15:42 UTC 2017
pkgbase = concourse-bin
pkgdesc = Concourse is a pipeline-based CI system written in Go.
pkgver = v3.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://concourse.ci/introduction.html
arch = x86_64
license = Apache
- depends = linux-userns
+ optdepends = linux-userns: user namespaces support (AUR, long build time)
+ optdepends = linux-zen: user namespaces support (extra, prebuilt)
provides = concourse
+ replaces = concourse
source = concourse-v3.5.0::https://github.com/concourse/concourse/releases/download/v3.5.0/concourse_linux_amd64
sha512sums = 2fa82213e009dea8f0369aea4a330c33a955c1c27421926211c9d43c8f69dab024014174b534b9d494f5eaad48dce3621dee99ce1f887c7a12de36fb905d5b3e
diff --git a/PKGBUILD b/PKGBUILD
index c5b4bbdca18a..8f8334648cf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
-# Maintainer: Bram Swenson <bram@amplified.work>
+# Maintainer: Bram Swenson <bram at amplified dot work>
+# Maintainer: pancho horrillo <pancho at pancho dot name>
-pkgname_base='concourse'
-pkgname="${pkgname_base}-bin"
+_pkgname='concourse'
+pkgname="${_pkgname}-bin"
pkgver=v3.5.0
-pkgrel=1
-pkgdesc="Concourse is a pipeline-based CI system written in Go."
+pkgrel=2
+pkgdesc='Concourse is a pipeline-based CI system written in Go.'
arch=(x86_64)
-url="https://concourse.ci/introduction.html"
+url='https://concourse.ci/introduction.html'
license=('Apache')
-source=(concourse-${pkgver}::https://github.com/concourse/concourse/releases/download/${pkgver}/concourse_linux_amd64)
+provides=("${_pkgname}")
+replaces=("${_pkgname}")
+optdepends=(
+ 'linux-userns: user namespaces support (AUR, long build time)'
+ 'linux-zen: user namespaces support (extra, prebuilt)'
+)
+source=("${_pkgname}-${pkgver}::https://github.com/concourse/concourse/releases/download/${pkgver}/concourse_linux_amd64")
sha512sums=('2fa82213e009dea8f0369aea4a330c33a955c1c27421926211c9d43c8f69dab024014174b534b9d494f5eaad48dce3621dee99ce1f887c7a12de36fb905d5b3e')
-provides=('concourse')
-depends=('linux-userns')
package() {
- install -Dm755 "concourse-${pkgver}" "$pkgdir/usr/bin/concourse"
+ install -Dm755 "${_pkgname}-${pkgver}" "$pkgdir/usr/bin/concourse"
}