summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2018-11-25 21:30:36 +0100
committerJulien Nicoulaud2018-11-25 21:30:36 +0100
commitd270bc43aa9dcfa411e23339f955f717e8086b04 (patch)
tree12752fc59ca008d94320efaf70c07d06f86a9f2f
parent1854696c55df7eba30a981e3d596fb33990c1e1d (diff)
downloadaur-d270bc43aa9dcfa411e23339f955f717e8086b04.tar.gz
4.2.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rwxr-xr-xbuild19
3 files changed, 8 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43e2af4963fe..e76d2a2563f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = concourse-bin
pkgdesc = Concourse is a pipeline-based CI system written in Go.
- pkgver = v3.14.1
- pkgrel = 2
+ pkgver = v4.2.1
+ pkgrel = 1
url = https://concourse-ci.org
arch = x86_64
license = Apache
provides = concourse
replaces = concourse
- source = concourse-v3.14.1::https://github.com/concourse/concourse/releases/download/v3.14.1/concourse_linux_amd64
- sha512sums = 3eb7790ae5c086e0c091a31ad569d50a0aa9e858555a92842c47384a9a4ff94689a7d6ce4c7a9e9359d0d53df65a896a59f456de3de19c4bf3790fd4ab7161fc
+ source = concourse-v4.2.1::https://github.com/concourse/concourse/releases/download/v4.2.1/concourse_linux_amd64
+ sha512sums = f883a0f6c748647ae18868dbdb8a769d050b8955994ead271b65eb46201f38b2b3d3231ac2fc6c5ac45b6457b3db79d20ae162b78be06ebb85741f1a90c8a0eb
pkgname = concourse-bin
diff --git a/PKGBUILD b/PKGBUILD
index e632078274a5..297aaef44c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Bram Swenson <bram at amplified dot work>
# Maintainer: pancho horrillo <pancho at pancho dot name>
+# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
_pkgname='concourse'
pkgname="${_pkgname}-bin"
-pkgver=v3.14.1
-pkgrel=2
+pkgver=v4.2.1
+pkgrel=1
pkgdesc='Concourse is a pipeline-based CI system written in Go.'
arch=(x86_64)
url='https://concourse-ci.org'
@@ -12,7 +13,7 @@ license=('Apache')
provides=("${_pkgname}")
replaces=("${_pkgname}")
source=("${_pkgname}-${pkgver}::https://github.com/concourse/concourse/releases/download/${pkgver}/concourse_linux_amd64")
-sha512sums=('3eb7790ae5c086e0c091a31ad569d50a0aa9e858555a92842c47384a9a4ff94689a7d6ce4c7a9e9359d0d53df65a896a59f456de3de19c4bf3790fd4ab7161fc')
+sha512sums=('f883a0f6c748647ae18868dbdb8a769d050b8955994ead271b65eb46201f38b2b3d3231ac2fc6c5ac45b6457b3db79d20ae162b78be06ebb85741f1a90c8a0eb')
package() {
install -Dm755 "${_pkgname}-${pkgver}" "$pkgdir/usr/bin/concourse"
diff --git a/build b/build
deleted file mode 100755
index 754cc80e5c60..000000000000
--- a/build
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env bash
-
-make_srcinfo () {
- makepkg --printsrcinfo > .SRCINFO
-}
-
-build () {
- updpkgsums && makepkg -s "${@}"
-}
-
-clean () {
- rm -rf *.pkg.tar.xz *.tar.gz ; rm -rf ./pkg ./src ; true
-}
-
-main () {
- clean && build "${@}" && make_srcinfo
-}
-
-main "$@"