summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Valecillos2019-10-14 16:20:41 +0200
committerJose Valecillos2019-10-14 16:20:41 +0200
commit379295343d8145d1ab36312471c3ca6b810e37aa (patch)
tree3c2a02bc9053e519157ebf285a15fcc66614251a
parentd5d5c97968bd2d57101a3a9f31f0a498f756d586 (diff)
downloadaur-379295343d8145d1ab36312471c3ca6b810e37aa.tar.gz
Adjusted .SRCINFO
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8761b946f0a..6fa21e6a8221 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = concourse-fly
pkgdesc = A command line interface that runs a build in a container with ATC.
- pkgver = 4.2.3
- pkgrel = 1
+ pkgver = 5.6.0
+ pkgrel = 2
url = https://concourse-ci.org/fly.html
arch = x86_64
license = Apache
makedepends = go-pie
makedepends = git
provides = concourse-fly
+ conflicts = concourse-fly
conflicts = concourse-fly-bin
conflicts = concourse-fly-git
- source = git+https://github.com/concourse/concourse.git#tag=v4.2.3
+ source = git+https://github.com/concourse/concourse.git#tag=v5.6.0
sha512sums = SKIP
pkgname = concourse-fly
diff --git a/PKGBUILD b/PKGBUILD
index 8b932996e77d..edcd70768bb5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,19 @@
# Contributor: Bram Swenson <bram at amplified dot work>
# Contributor: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
-_pkgname="concourse-fly"
-pkgname=$_pkgname-git
-pkgver=5.6.0.r90.gcb8a08f02
-pkgrel=1
+pkgname="concourse-fly"
+pkgver=5.6.0
+pkgrel=2
pkgdesc="A command line interface that runs a build in a container with ATC."
arch=('x86_64')
url="https://concourse-ci.org/fly.html"
license=('Apache')
makedepends=('go-pie' 'git')
-provides=("${_pkgname}")
-conflicts=("${_pkgname}" "${_pkgname}-bin")
-source=("git+https://github.com/concourse/concourse.git")
+provides=("${pkgname}")
+conflicts=("${pkgname}" "${pkgname}-bin" "${pkgname}-git")
+source=("git+https://github.com/concourse/concourse.git#tag=v${pkgver}")
sha512sums=('SKIP')
-pkgver() {
- cd $srcdir/concourse/
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
prepare() {
mkdir -p gopath/src/github.com/concourse
ln -rTsf $srcdir/concourse/ gopath/src/github.com/concourse/concourse