summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBram Swenson2017-06-02 08:52:33 -0700
committerBram Swenson2017-06-02 08:52:33 -0700
commit6af8c59dd27a7ba772988016a345708c338409a2 (patch)
tree6d9e4234e401a8aa15447c16dee6fc52851ee201
parent219b2782ca3aa1d30ebe671de93cff67bb79439c (diff)
downloadaur-6af8c59dd27a7ba772988016a345708c338409a2.tar.gz
concourse fly v3.1.1
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD10
-rwxr-xr-xbuild2
4 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9aa3c89aa08..d9622fcc1247 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = concourse-fly
pkgdesc = A command line interface that runs a build in a container with ATC.
- pkgver = v3.0.1
- pkgrel = 2
+ pkgver = v3.1.1
+ pkgrel = 1
url = https://concourse.ci/fly-cli.html
arch = x86_64
license = Apache
provides = fly
- source = https://github.com/concourse/concourse/releases/download/v3.0.1/fly_linux_amd64
- sha512sums = bf63d30a0601b987bdaf5bac4fc6b866f0c6ac3fb826704e81c1f9dfc265a8d57e205d771daa297f46071609b60c4ed58f62f7d9abaa7442bc91647e023d3c2d
+ source = concourse-fly-v3.1.1::https://github.com/concourse/concourse/releases/download/v3.1.1/fly_linux_amd64
+ sha512sums = e9562a163327b74c7d8bba7a68e2d90adb7a01ee0b5e149718fca823338a1a13dfcf502377a912a588a9bc9e09fe9da19e2eec22c5ba72ae36ee5f2c5bf14844
pkgname = concourse-fly
diff --git a/.gitignore b/.gitignore
index a748193bb084..1df0161ef408 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,5 +3,5 @@
/src/
/*.tar.gz
/*.xz
-/fly_linux_amd64
/*.swp
+/concourse-fly-v*
diff --git a/PKGBUILD b/PKGBUILD
index f3e42b0905c1..fea1dabcaa9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Bram Swenson <bram@amplified.work>
pkgname='concourse-fly'
-pkgver=v3.0.1
-pkgrel=2
+pkgver=v3.1.1
+pkgrel=1
pkgdesc="A command line interface that runs a build in a container with ATC."
arch=(x86_64)
url="https://concourse.ci/fly-cli.html"
license=('Apache')
-source=(https://github.com/concourse/concourse/releases/download/${pkgver}/fly_linux_amd64)
-sha512sums=('bf63d30a0601b987bdaf5bac4fc6b866f0c6ac3fb826704e81c1f9dfc265a8d57e205d771daa297f46071609b60c4ed58f62f7d9abaa7442bc91647e023d3c2d')
+source=(concourse-fly-${pkgver}::https://github.com/concourse/concourse/releases/download/${pkgver}/fly_linux_amd64)
+sha512sums=('e9562a163327b74c7d8bba7a68e2d90adb7a01ee0b5e149718fca823338a1a13dfcf502377a912a588a9bc9e09fe9da19e2eec22c5ba72ae36ee5f2c5bf14844')
provides=('fly')
package() {
- install -Dm755 "fly_linux_amd64" "$pkgdir/usr/bin/fly"
+ install -Dm755 "concourse-fly-${pkgver}" "$pkgdir/usr/bin/fly"
}
diff --git a/build b/build
index 273b12b38892..72a9a9308c6e 100755
--- a/build
+++ b/build
@@ -9,7 +9,7 @@ build () {
}
clean () {
- rm -rf *.pkg.tar.xz *.tar.gz ; rm -rf ./pkg ./src ; true
+ rm -rf *.pkg.tar.xz *.tar.gz concourse-fly-v* ; rm -rf ./pkg ./src ; true
}
main () {