summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2018-11-25 21:50:26 +0100
committerJulien Nicoulaud2018-11-25 21:50:26 +0100
commitf57cf7b1983eb74fcf6d54e58c633b09e058bd5f (patch)
treef1154984cfdb72371f05be7ebbdc3c6e37043468
parent925b0106e7e53940aa6b1405784b145d43e67a69 (diff)
downloadaur-f57cf7b1983eb74fcf6d54e58c633b09e058bd5f.tar.gz
update from 4.2.1, build from source
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD34
-rwxr-xr-xbuild19
4 files changed, 35 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1be8d9c4fc4..e087d8000ea8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = concourse-fly
pkgdesc = A command line interface that runs a build in a container with ATC.
- pkgver = v3.13.0
- pkgrel = 3
+ pkgver = v4.2.1
+ pkgrel = 1
url = https://concourse-ci.org/fly.html
arch = x86_64
license = Apache
+ makedepends = go
provides = fly
- source = concourse-fly-v3.13.0::https://github.com/concourse/concourse/releases/download/v3.13.0/fly_linux_amd64
- sha512sums = 394695a16a38f228a784d74777f211a98d3c531c33c3260d4c2155f920c0145ae02ad18e433abffe6b36138e33b19dc4ab46e245468b3da2f935bb307b593fca
+ source = git+https://github.com/concourse/concourse.git#tag=v4.2.1
+ sha512sums = SKIP
pkgname = concourse-fly
diff --git a/.gitignore b/.gitignore
index 1df0161ef408..242dac9164b6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,4 +4,4 @@
/*.tar.gz
/*.xz
/*.swp
-/concourse-fly-v*
+/concourse*
diff --git a/PKGBUILD b/PKGBUILD
index 9ec7bb13022a..ffdfbacdd764 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,41 @@
# Maintainer: pancho horrillo <pancho at pancho dot name>
# Contributor: Bram Swenson <bram at amplified dot work>
+# Maintainer: Julien Nicoulaud <julien dot nicoulaud at gmail dot com>
pkgname='concourse-fly'
-pkgver=v3.13.0
-pkgrel=3
+pkgver=v4.2.1
+pkgrel=1
pkgdesc="A command line interface that runs a build in a container with ATC."
arch=(x86_64)
url="https://concourse-ci.org/fly.html"
license=('Apache')
-source=(concourse-fly-${pkgver}::https://github.com/concourse/concourse/releases/download/${pkgver}/fly_linux_amd64)
-sha512sums=('394695a16a38f228a784d74777f211a98d3c531c33c3260d4c2155f920c0145ae02ad18e433abffe6b36138e33b19dc4ab46e245468b3da2f935bb307b593fca')
+makedepends=('go')
+source=("git+https://github.com/concourse/concourse.git#tag=${pkgver}")
+sha512sums=('SKIP')
provides=('fly')
+prepare() {
+ cd "${srcdir}/concourse"
+ git submodule update --init --recursive --jobs $(nproc) --recommend-shallow
+ export GOPATH="$PWD"
+ go get github.com/onsi/ginkgo/ginkgo
+}
+
+build() {
+ cd "${srcdir}/concourse"
+ export GOPATH="$PWD"
+ cd src/github.com/concourse/fly
+ go build
+}
+
+check() {
+ cd "${srcdir}/concourse"
+ export GOPATH="$PWD"
+ cd src/github.com/concourse/fly
+ "$GOPATH"/bin/ginkgo -r
+}
+
package() {
- install -Dm755 "concourse-fly-${pkgver}" "$pkgdir/usr/bin/fly"
+ cd "${srcdir}/concourse"
+ install -m 755 -D src/github.com/concourse/fly/fly "$pkgdir"/usr/bin/fly
}
diff --git a/build b/build
deleted file mode 100755
index 72a9a9308c6e..000000000000
--- a/build
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env bash
-
-make_srcinfo () {
- makepkg --printsrcinfo > .SRCINFO
-}
-
-build () {
- makepkg -s "${@}"
-}
-
-clean () {
- rm -rf *.pkg.tar.xz *.tar.gz concourse-fly-v* ; rm -rf ./pkg ./src ; true
-}
-
-main () {
- clean && build "${@}" && make_srcinfo
-}
-
-main "$@"