summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpancho horrillo2017-10-01 00:23:37 +0200
committerpancho horrillo2017-10-01 00:23:37 +0200
commita0fbcc1cce3bdea475861f0f38f41d5beb4344b5 (patch)
treeb50a83400ede9b7d330523fc49d87fd7c6979d74
parent9e4c100d5a812bcd3d6058677a27815d59ea49e2 (diff)
downloadaur-a0fbcc1cce3bdea475861f0f38f41d5beb4344b5.tar.gz
Prevent conflict with 'fly' package, minor tweaks
By providing provides=('fly'), we provided a faux dependency for pre-existing package 'fly'¹. I've selected the non-conflicting name 'concourse-fly' as the one to be the one this package provides. The 'conflicts' array will inform the package manager that this package cannot be installed alongside 'concourse-fly-git'. By adding a 'replaces' array, we allow for smooth transition for the users who had installed the previous version, named simply 'concourse-fly'. Also, I've made liberal use of vars to reduce redundancy. ¹: https://aur.archlinux.org/packages/fly/
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6699bdd464d5..7fa46d6ef533 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,15 @@
+# Generated by mksrcinfo v8
+# Sat Sep 30 22:16:39 UTC 2017
pkgbase = concourse-fly-bin
pkgdesc = A command line interface that runs a build in a container with ATC.
pkgver = v3.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://concourse.ci/fly-cli.html
arch = x86_64
license = Apache
- provides = fly
+ provides = concourse-fly
+ conflicts = concourse-fly
+ replaces = concourse-fly
source = concourse-fly-bin-v3.5.0::https://github.com/concourse/concourse/releases/download/v3.5.0/fly_linux_amd64
sha512sums = 12aaeb0e8065b66b055ad8be9014334cfcf7d24f84a0bf6ecd1544f52a3e891ff7bc492dd57e36a78100b64610a9cf066bd3470dccef01888ec538a95715cc24
diff --git a/PKGBUILD b/PKGBUILD
index 3b6c5a6d3688..bc5f8c34a40b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
-# Maintainer: Bram Swenson <bram@amplified.work>
+# Maintainer: Bram Swenson <bram at amplified dot work>
+# Maintainer: pancho horrillo <pancho at pancho dot name>
-pkgname_base='concourse-fly'
-pkgname="${pkgname_base}-bin"
+_pkgname='concourse-fly'
+pkgname="${_pkgname}-bin"
pkgver=v3.5.0
-pkgrel=1
-pkgdesc="A command line interface that runs a build in a container with ATC."
+pkgrel=2
+pkgdesc='A command line interface that runs a build in a container with ATC.'
arch=(x86_64)
-url="https://concourse.ci/fly-cli.html"
+url='https://concourse.ci/fly-cli.html'
license=('Apache')
-source=(concourse-fly-bin-${pkgver}::https://github.com/concourse/concourse/releases/download/${pkgver}/fly_linux_amd64)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+replaces=("${_pkgname}")
+source=("${pkgname}-${pkgver}::https://github.com/concourse/concourse/releases/download/${pkgver}/fly_linux_amd64")
sha512sums=('12aaeb0e8065b66b055ad8be9014334cfcf7d24f84a0bf6ecd1544f52a3e891ff7bc492dd57e36a78100b64610a9cf066bd3470dccef01888ec538a95715cc24')
-provides=('fly')
package() {
- install -Dm755 "concourse-fly-bin-${pkgver}" "$pkgdir/usr/bin/fly"
+ install -Dm755 "${pkgname}-${pkgver}" "$pkgdir/usr/bin/fly"
}