summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-03-06 19:59:43 +0100
committerJulien Nicoulaud2019-03-06 19:59:43 +0100
commiteddb1a7827e479265e6d93267d52fb4dedd38ea3 (patch)
treeab9f126026adb08940c74e916ac05278b69fcba1
parent7efb8b7c552d513bef05cc0fcadb3b50b422a6f9 (diff)
downloadaur-eddb1a7827e479265e6d93267d52fb4dedd38ea3.tar.gz
5.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD9
-rwxr-xr-xbuild19
4 files changed, 9 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd9208bf28e5..c7d2b3b0a65f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = concourse-fly-bin
pkgdesc = A command line interface that runs a build in a container with ATC.
- pkgver = 4.2.3
+ pkgver = 5.0.0
pkgrel = 1
url = https://concourse-ci.org/fly.html
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = concourse-fly-bin
conflicts = concourse-fly
conflicts = concourse-fly-git
replaces = concourse-fly
- source = concourse-fly-bin-4.2.3::https://github.com/concourse/concourse/releases/download/v4.2.3/fly_linux_amd64
- sha512sums = 190adeefe0a18be8b7f7d09b107a369cace7e170705a566ca5226dc43d1ccfe29c7979ee382aa5dde03be67360f2ea33f4e04cb2ca5b9e241dcba3d6f63cd3e2
+ source = https://github.com/concourse/concourse/releases/download/v5.0.0/fly-linux-amd64.tgz
+ sha512sums = cc3cc327881469e62f03b10ecf4369740e180f6b505967c793b11a6e2d0e924fdacb58eb0e6e834e6401a03d3e2b6cfadc4bfe134f88bc0ec0df13dad9926482
pkgname = concourse-fly-bin
diff --git a/.gitignore b/.gitignore
index 2e771c8e2107..d45bb3653710 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,7 @@
/zcash/
/src/
/*.tar.gz
+/*.tgz
/*.xz
/*.swp
/concourse-fly*
diff --git a/PKGBUILD b/PKGBUILD
index f1652157e0f8..c0fb400711a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname='concourse-fly'
pkgname="${_pkgname}-bin"
-pkgver=4.2.3
+pkgver=5.0.0
pkgrel=1
pkgdesc='A command line interface that runs a build in a container with ATC.'
arch=(x86_64)
@@ -13,9 +13,10 @@ license=('Apache')
provides=("${_pkgname}")
replaces=("${_pkgname}")
conflicts=("${_pkgname}" "${_pkgname}-git")
-source=("${pkgname}-${pkgver}::https://github.com/concourse/concourse/releases/download/v${pkgver}/fly_linux_amd64")
-sha512sums=('190adeefe0a18be8b7f7d09b107a369cace7e170705a566ca5226dc43d1ccfe29c7979ee382aa5dde03be67360f2ea33f4e04cb2ca5b9e241dcba3d6f63cd3e2')
+source=("https://github.com/concourse/concourse/releases/download/v${pkgver}/fly-linux-amd64.tgz")
+sha512sums=('cc3cc327881469e62f03b10ecf4369740e180f6b505967c793b11a6e2d0e924fdacb58eb0e6e834e6401a03d3e2b6cfadc4bfe134f88bc0ec0df13dad9926482')
package() {
- install -Dm755 "${pkgname}-${pkgver}" "$pkgdir/usr/bin/fly"
+ install -Dm755 "${srcdir}/fly" "${pkgdir}/usr/bin/fly"
}
+
diff --git a/build b/build
deleted file mode 100755
index 754cc80e5c60..000000000000
--- a/build
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/usr/bin/env bash
-
-make_srcinfo () {
- makepkg --printsrcinfo > .SRCINFO
-}
-
-build () {
- updpkgsums && makepkg -s "${@}"
-}
-
-clean () {
- rm -rf *.pkg.tar.xz *.tar.gz ; rm -rf ./pkg ./src ; true
-}
-
-main () {
- clean && build "${@}" && make_srcinfo
-}
-
-main "$@"