summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2017-02-02 20:06:13 +0100
committerfelics@felics-tablet2017-02-02 20:06:13 +0100
commitb42d44630c0464e4f76b5df0e8220b8b8fd52c79 (patch)
tree96ed0f8070c86ac105ca66a8beec9ad2d2574fd8
downloadaur-b42d44630c0464e4f76b5df0e8220b8b8fd52c79.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD56
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b41d8f7847ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = confclerk-git
+ pkgdesc = QT4 application to make conference schedules offline. Able to import schedules in XML format created by the ​PentaBarf (or ​frab) used by ​FOSDEM, ​DebConf, ​Grazer Linuxtage, ​CCC congresses, ​FrOSCon, and ​many others.
+ pkgver = 0.6.2_1+g860fc82
+ pkgrel = 1
+ url = http://www.toastfreeware.priv.at/confclerk
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ makedepends = git
+ depends = qt4
+ provides = confclerk=0.6.2_1+g860fc82
+ conflicts = confclerk
+ source = confclerk::git+git://git.toastfreeware.priv.at/toast/confclerk.git
+ source = confclerk.1.gz::http://manpages.ubuntu.com/manpages.gz/zesty/man1/confclerk.1.gz
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = confclerk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e14bc45d86cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: dreieck
+
+_pkgname=confclerk
+pkgname="${_pkgname}-git"
+_pkgver=0.6.2
+pkgver=0.6.2_1+g860fc82
+pkgrel=1
+pkgdesc='QT4 application to make conference schedules offline. Able to import schedules in XML format created by the ​PentaBarf (or ​frab) used by ​FOSDEM, ​DebConf, ​Grazer Linuxtage, ​CCC congresses, ​FrOSCon, and ​many others.'
+arch=('i686' 'x86_64')
+url="http://www.toastfreeware.priv.at/confclerk"
+license=('GPLv2')
+depends=(
+ 'qt4'
+)
+optdepends=()
+makedepends=('git')
+provides=(
+ "${_pkgname}=${pkgver}"
+)
+conflicts=("${_pkgname}")
+options=()
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe | awk -F '-' '{print $1"_"$2"+"$3}'
+}
+
+source=(
+ "${_pkgname}::git+git://git.toastfreeware.priv.at/toast/confclerk.git"
+ "${_pkgname}.1.gz::http://manpages.ubuntu.com/manpages.gz/zesty/man1/confclerk.1.gz"
+)
+
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+)
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ ### I found no way to specify a custom installation directory. So we install manually ...
+ install -v -D -m755 src/bin/confclerk "${pkgdir}/usr/bin/${_pkgname}"
+ install -v -D -m644 data/confclerk.desktop "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -v -D -m644 data/confclerk.svg "${pkgdir}/usr/share/pixmaps/${_pkgname}.svg"
+ install -v -D -m644 "${srcdir}/${_pkgname}.1.gz" "${pkgdir}/usr/share/man/man1/${_pkgname}.1.gz"
+
+ install -v -d -m755 "${pkgdir}/usr/share/doc/${_pkgname}/${_pkgname}" # Yes, we have an _additional_ ${_pkgname}-subdirectory, since we also have historic documentation from the time when this software was named fosdem-schedule.
+ cp -rv docs/* "${pkgdir}/usr/share/doc/${_pkgname}/"
+ install -v -m644 AUTHORS BUGS COPYING INSTALL NEWS README "${pkgdir}/usr/share/doc/${_pkgname}/${_pkgname}"
+}