summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPZetter2021-01-11 17:35:57 +0000
committerPZetter2021-01-11 17:35:57 +0000
commit361c58c7edddc1bcde580b922500eddfa059fffd (patch)
treee96328e0661b3e8a0b26908d9ea45dab6b8f4313
parent10b0f5d087a2d82dff3bf432a935a06f6e0af4d2 (diff)
downloadaur-361c58c7edddc1bcde580b922500eddfa059fffd.tar.gz
Adding pyinstaller to makedepends.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a142f8c0426..d521ca5d62c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = confedi-git-bin
arch = any
license = GPL
makedepends = git
+ makedepends = pyinstaller
depends = python3
source = git+https://bitbucket.org/masterofhoppips/configuration-editor.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0e6d2587b305..8ced215be473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,18 @@ pkgdesc="Confedi is designed to help with changing configuration files with one
arch=(any)
license=('GPL')
depends=(python3)
-makedepends=(git)
+makedepends=(git pyinstaller)
url="https://bitbucket.org/masterofhoppips/configuration-editor.git"
source=("git+$url")
md5sums=('SKIP')
build(){
+ cd configuraton-editor
pyinstaller program.py -F
+ cd ..
}
package() {
- mkdir -p "$pkgdir"/usr/bin
- cp configuration-editor/src/dist/program "$pkgdir"/usr/bin/$pkgname
+ mkdir -p "$pkgdir"/usr/bin
+ cp configuration-editor/src/dist/program "$pkgdir"/usr/bin/$pkgname
}