summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfabrixxm2021-03-11 13:46:30 +0100
committerfabrixxm2021-03-11 13:46:30 +0100
commitbbd32060c10b0487667d523eecc73a0d202e6fe1 (patch)
tree2bcd630602f070d46e1441f745996b4f79923f12
downloadaur-bbd32060c10b0487667d523eecc73a0d202e6fe1.tar.gz
Confy 0.5.4
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD29
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f33c7b9c17dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = confy
+ pkgdesc = Conferences schedule viewer for GNOME
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = https://confy.kirgroup.net/
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ makedepends = meson
+ makedepends = ninja
+ makedepends = gobject-introspection
+ makedepends = git
+ depends = python
+ depends = gtk3
+ depends = libhandy
+ depends = python-gobject
+ depends = python-icalendar
+ depends = libnotify
+ provides = confy
+ source = https://git.sr.ht/~fabrixxm/confy/archive/0.5.4.tar.gz
+ md5sums = 7971ee5f29817cb09de6e96bb5232f8e
+
+pkgname = confy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d53d19106dd9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0356c9864fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
+pkgname=confy
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Conferences schedule viewer for GNOME"
+arch=('x86_64' 'aarch64')
+url="https://confy.kirgroup.net/"
+license=(GPL3)
+depends=('python' 'gtk3' 'libhandy' 'python-gobject' 'python-icalendar' 'libnotify')
+makedepends=('meson' 'ninja' 'gobject-introspection' 'git')
+provides=(confy)
+source=("https://git.sr.ht/~fabrixxm/confy/archive/$pkgver.tar.gz")
+md5sums=('7971ee5f29817cb09de6e96bb5232f8e')
+
+
+build() {
+ arch-meson build "$pkgname-$pkgver"
+ ninja -C build
+}
+
+check() {
+ cd "${srcdir}/build"
+ ninja test
+}
+
+package() {
+ cd "${srcdir}/build"
+ DESTDIR="${pkgdir}" ninja install
+}