summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwebmeister2015-07-05 18:00:19 +0200
committerwebmeister2015-07-05 18:00:19 +0200
commitb37af734edf6d6659d9f0c6645e07009fd110705 (patch)
treef9c90ca1d080ef5b2ff7907f730a6305196348f0
downloadaur-b37af734edf6d6659d9f0c6645e07009fd110705.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--congruity.install11
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..241d788381a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = congruity
+ pkgdesc = A GUI application for programming Logitech(R) Harmony(TM) remote controls.
+ pkgver = 18
+ pkgrel = 2
+ url = http://congruity.sourceforge.net/
+ install = congruity.install
+ arch = any
+ license = GPL3
+ depends = desktop-file-utils
+ depends = python2-suds
+ depends = python-libconcord>=1.1
+ depends = wxpython2.8
+ source = http://downloads.sourceforge.net/project/congruity/congruity/18/congruity-18.tar.bz2
+ sha256sums = 16cee522b3e0b2c76ae4527110cb517af015aa8d56b1e72b7cbfa9df06739878
+
+pkgname = congruity
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f149721d3954
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Andreas Baumann <abaumann@yahoo.com>
+# Contributor: Guillaume DUMOULIN <guillaume.dumoulin@gmail.com>
+# Contributor: elsixdiab
+
+pkgname=congruity
+pkgver=18
+pkgrel=2
+pkgdesc='A GUI application for programming Logitech(R) Harmony(TM) remote controls.'
+arch=('any')
+url='http://congruity.sourceforge.net/'
+license=('GPL3')
+depends=('desktop-file-utils' 'python2-suds' 'python-libconcord>=1.1' 'wxpython2.8')
+install="$pkgname.install"
+source=("http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2")
+sha256sums=('16cee522b3e0b2c76ae4527110cb517af015aa8d56b1e72b7cbfa9df06739878')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ sed -i 's@wxversion.ensureMinimal@wxversion.select@g' congruity mhgui
+ sed -i 's@#!/usr/bin/env python@#!/usr/bin/env python2@g' congruity mhgui
+ sed -i 's@#!/usr/bin/python@#!/usr/bin/env python2@g' mhmanager.py
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/congruity.install b/congruity.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/congruity.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}