summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2017-11-17 03:01:39 +0100
committerhaawda2017-11-17 03:01:39 +0100
commit2b388a6a23d4562e9cdc87528bdb78c880e16f09 (patch)
tree80106f745f8e1a2e124e0d8cb4ea190e64473d2c
parentcb6c17a2793f4632efdd575d35c004863f78a899 (diff)
downloadaur-2b388a6a23d4562e9cdc87528bdb78c880e16f09.tar.gz
fallback to xulrunner
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--conkeror.sh8
3 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d8d93bb023e..37349be80cc1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Nov 17 02:01:15 UTC 2017
pkgbase = conkeror
pkgdesc = A highly programmable web browser based on Mozilla XULRunner
pkgver = 1.0.3
- pkgrel = 1
+ pkgrel = 2
url = http://conkeror.org/
arch = i686
arch = x86_64
license = MPL
license = GPL
license = LGPL
- depends = firefox
+ depends = xulrunner
source = conkeror-1.0.3.tar.gz::http://repo.or.cz/conkeror.git/snapshot/1.0.3.tar.gz
+ source = conkeror.sh
md5sums = c496c836c1b5b5ea573329f1115bda34
+ md5sums = 2c3fa4ba393c936cfde90f1614e12ba6
pkgname = conkeror
diff --git a/PKGBUILD b/PKGBUILD
index 813bd3c72448..aede03daed2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,23 @@
pkgname=conkeror
pkgver=1.0.3
-pkgrel=1
+pkgrel=2
pkgdesc='A highly programmable web browser based on Mozilla XULRunner'
arch=('i686' 'x86_64')
url='http://conkeror.org/'
license=('MPL' 'GPL' 'LGPL')
-depends=('firefox')
-source=("$pkgname-$pkgver.tar.gz::http://repo.or.cz/conkeror.git/snapshot/$pkgver.tar.gz")
-md5sums=('c496c836c1b5b5ea573329f1115bda34')
+depends=('xulrunner')
+source=("$pkgname-$pkgver.tar.gz::http://repo.or.cz/conkeror.git/snapshot/$pkgver.tar.gz" conkeror.sh)
+md5sums=('c496c836c1b5b5ea573329f1115bda34'
+ '2c3fa4ba393c936cfde90f1614e12ba6')
build() {
- cd $pkgname-$pkgver*/
- make PREFIX=/usr
+ cd $pkgname-$pkgver*/
+ make PREFIX=/usr
}
package() {
- cd $pkgname-$pkgver*/
- make DESTDIR="$pkgdir" PREFIX=/usr install
+ cd $pkgname-$pkgver*/
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm755 "$srcdir"/$pkgname.sh "$pkgdir"/usr/bin/$pkgname
}
diff --git a/conkeror.sh b/conkeror.sh
new file mode 100644
index 000000000000..a026621a5a21
--- /dev/null
+++ b/conkeror.sh
@@ -0,0 +1,8 @@
+ #!/bin/sh
+
+# (C) Copyright 2015-2016 Ivy F. Foster
+#
+# Use, modification, and distribution are subject to the
+# terms specified in the COPYING file.
+
+XUL_APP_FILE="/usr/share/conkeror/application.ini" exec xulrunner "$@"