summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2016-07-31 19:37:35 +0200
committerBalló György2016-07-31 19:37:35 +0200
commit74d2e09bc7f095975aba7fba48bc193da230429c (patch)
tree48e199b62fe3d331a0619392879770c51b98179a
downloadaur-74d2e09bc7f095975aba7fba48bc193da230429c.tar.gz
Add conkeror
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d8d93bb023e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = conkeror
+ pkgdesc = A highly programmable web browser based on Mozilla XULRunner
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = http://conkeror.org/
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = firefox
+ source = conkeror-1.0.3.tar.gz::http://repo.or.cz/conkeror.git/snapshot/1.0.3.tar.gz
+ md5sums = c496c836c1b5b5ea573329f1115bda34
+
+pkgname = conkeror
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15166b8d6e2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Ivy Foster <joyfulgirl@archlinux.us>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Heeru Kiyura <M8R-p9i5nh@mailinator.com>
+
+pkgname=conkeror
+pkgver=1.0.3
+pkgrel=1
+pkgdesc='A highly programmable web browser based on Mozilla XULRunner'
+arch=('i686' 'x86_64')
+url='http://conkeror.org/'
+license=('MPL' 'GPL' 'LGPL')
+depends=('firefox')
+source=("$pkgname-$pkgver.tar.gz::http://repo.or.cz/conkeror.git/snapshot/$pkgver.tar.gz")
+md5sums=('c496c836c1b5b5ea573329f1115bda34')
+
+build() {
+ cd $pkgname-$pkgver*
+ make PREFIX=/usr
+}
+
+package() {
+ cd $pkgname-$pkgver*
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}