summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Robin2015-06-11 19:26:54 +0200
committerBenjamin Robin2015-06-11 19:38:59 +0200
commit13188151cdeae592152fa0072910313798b29cda (patch)
treefd36a5042477f76e8ea0f42faa7effd8baaee62b
downloadaur-13188151cdeae592152fa0072910313798b29cda.tar.gz
Copy from AUR
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD47
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0b1a2f26b0f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = conky-audacious
+ pkgdesc = Lightweight system monitor for X
+ pkgver = 1.9.0
+ pkgrel = 4
+ url = http://conky.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = GPL
+ makedepends = docbook2x
+ depends = glib2
+ depends = curl
+ depends = lua
+ depends = wireless_tools
+ depends = libxml2
+ depends = libxft
+ depends = libxdamage
+ depends = imlib2
+ depends = audacious
+ depends = libaudclient
+ provides = conky
+ conflicts = conky
+ options = !emptydirs
+ backup = etc/conky/conky.conf
+ backup = etc/conky/conky_no_x11.conf
+ source = http://downloads.sourceforge.net/project/conky/conky/1.9.0/conky-1.9.0.tar.gz
+ sha1sums = a8d26d002370c9b877ae77ad3a3bbd2566b38e5d
+
+pkgname = conky-audacious
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a9e1217dd75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# $Id: PKGBUILD 205494 2014-02-06 05:24:01Z bisson $
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: James Rayner <james@archlinux.org>
+# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
+
+pkgname=conky-audacious
+_pkgname=conky
+pkgver=1.9.0
+pkgrel=4
+pkgdesc='Lightweight system monitor for X'
+url='http://conky.sourceforge.net/'
+license=('BSD' 'GPL')
+arch=('i686' 'x86_64')
+makedepends=('docbook2x')
+provides=('conky')
+conflicts=('conky')
+depends=('glib2' 'curl' 'lua' 'wireless_tools' 'libxml2' 'libxft' 'libxdamage' 'imlib2' 'audacious' 'libaudclient')
+source=("http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha1sums=('a8d26d002370c9b877ae77ad3a3bbd2566b38e5d')
+
+backup=('etc/conky/'conky{,_no_x11}.conf)
+options=('!emptydirs')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ CPPFLAGS="${CXXFLAGS}" LIBS="${LDFLAGS}" ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-ibm \
+ --enable-curl \
+ --enable-rss \
+ --enable-weather-xoap \
+ --enable-imlib2 \
+ --enable-wlan \
+ --enable-audacious
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
+ install -Dm644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
+}