summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParamvir Likhari2018-08-13 12:52:59 +0530
committerParamvir Likhari2018-08-13 12:52:59 +0530
commit7ca8f7551a91ad6fd5555c2153be95f088899580 (patch)
tree8c51c37a1e6fdbe6afc6f8d64a870c2f31e78737
parent899285a25c800f43fb7638e6e3665a7eee43285a (diff)
downloadaur-7ca8f7551a91ad6fd5555c2153be95f088899580.tar.gz
update 1.10.8 rel 1
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 5 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c911707e8c75..21e23df4961c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = conky-cairo
- pkgdesc = conky - built for nvidia n (tolua++_5.3 in AUR) - See this PKGBUILD source - Just change one variable to build the git version - defaults to release version.
+ pkgdesc = conky - built for tolua++_5.3 in AUR - See this PKGBUILD source - Just change one variable to build the git version - defaults to release version.
pkgver = 1.10.8
pkgrel = 1
url = https://github.com/brndnmtthws/conky
@@ -20,7 +20,6 @@ pkgbase = conky-cairo
depends = libxdamage
depends = imlib2
depends = lua
- depends = libxnvctrl
depends = libxinerama
depends = tolua++_5.3
provides = conky
diff --git a/PKGBUILD b/PKGBUILD
index 2b15ea228785..554cdfdcd6fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,6 @@
# This PKGBUILD creates conky for tolua++_5.3 lua + cairo + imlib2 + nvidia
-# to create NON NVIDIA package - remove following
-# in makedepends 'libxnvctrl'
-# in build section remove line containing -D BUILD_NVIDIA=ON \
-# For non-cairo conky - install stock version from Arch repos
-
# the covert.lua utility is also put in the /usr/bin folder
# as an executable conky-convert.lua - so can be called anywhere.
# I prefer to give the new files a .lua extension - easier to edit.
@@ -24,7 +19,7 @@
pkgname=conky-cairo
pkgver=1.10.8
pkgrel=1
-pkgdesc='conky - built for nvidia n (tolua++_5.3 in AUR) - See this PKGBUILD source - Just change one variable to build the git version - defaults to release version.'
+pkgdesc='conky - built for tolua++_5.3 in AUR - See this PKGBUILD source - Just change one variable to build the git version - defaults to release version.'
url='https://github.com/brndnmtthws/conky'
license=('GPL3' 'BSD')
arch=('i686' 'x86_64')
@@ -33,7 +28,7 @@ replaces=('torsmo' 'conky')
conflicts=('conky')
provides=('conky')
-depends=( 'alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools' 'libxft' 'librsvg' 'glib2' 'libxdamage' 'imlib2' 'lua' 'libxnvctrl' 'libxinerama' 'tolua++_5.3' )
+depends=( 'alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools' 'libxft' 'librsvg' 'glib2' 'libxdamage' 'imlib2' 'lua' 'libxinerama' 'tolua++_5.3' )
makedepends=( 'cmake' 'git' )
@@ -76,9 +71,6 @@ build() {
-e 's|\(NOT LUA_VERSION VERSION_LESS\) 5.2.0|\1 5.4.0|' \
cmake/ConkyPlatformChecks.cmake
- sed -i \
- -e 's|#include <string>|#include <string>\n#include <functional>|' \
- src/luamm.hh
################################################################
cmake \
@@ -91,12 +83,11 @@ build() {
-D BUILD_XSHAPE=ON \
-D BUILD_IMLIB2=ON \
-D BUILD_ICONV=ON \
- -D BUILD_WEATHER_METAR=ON \
- -D BUILD_WEATHER_XOAP=ON \
+ -D BUILD_WEATHER_METAR=OFF \
+ -D BUILD_WEATHER_XOAP=OFF \
-D BUILD_LUA_CAIRO=ON \
-D BUILD_LUA_IMLIB2=ON \
-D BUILD_LUA_RSVG=ON \
- -D BUILD_NVIDIA=ON \
.
make