summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArcher7772015-12-01 19:28:19 +0500
committerArcher7772015-12-01 19:28:19 +0500
commita1e761650b7879c89830bc947525059c00fd47a1 (patch)
tree123eb8d1d11bc4ddf97ad62e81e594bba69b9d8a
parentaea871d5ae160f836e3faa0bf703fd9e0f2a0d37 (diff)
downloadaur-a1e761650b7879c89830bc947525059c00fd47a1.tar.gz
1.10.1-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
-rw-r--r--ascii.patch12
-rw-r--r--curl.patch14
-rw-r--r--ipv6.patch28
5 files changed, 15 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8fd94e5240bf..0b7eb3bedd37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = conky-cli
pkgdesc = Lightweight system monitor for X, without X11 dependencies
- pkgver = 1.10.0
- pkgrel = 3
- url = http://conky.sourceforge.net/
+ pkgver = 1.10.1
+ pkgrel = 1
+ url = https://github.com/brndnmtthws/conky
arch = i686
arch = x86_64
license = BSD
@@ -10,24 +10,18 @@ pkgbase = conky-cli
makedepends = cmake
makedepends = docbook2x
makedepends = docbook-xml
- makedepends = docbook-xsl
makedepends = man-db
+ makedepends = git
depends = curl
depends = lua
depends = wireless_tools
depends = libxml2
provides = conky
conflicts = conky
- source = https://github.com/brndnmtthws/conky/archive/v1.10.0.tar.gz
- source = ascii.patch
+ source = https://github.com/brndnmtthws/conky/archive/v1.10.1.tar.gz
source = lua53.patch
- source = ipv6.patch
- source = curl.patch
- md5sums = cdc0298e5f257829d574ae8114170d9b
- md5sums = d5b765cb7400d2fdca88b6c86aa8eec1
- md5sums = 44cdadfe92266e99698e5424b7c6e265
- md5sums = 702650dfaaacb4e778f3d3c6a296df0b
- md5sums = 8236606ca3d39b9d00a59022d4f953ac
+ sha1sums = 97b59ec1daf54126b30516e8663a9cf1f218d8ae
+ sha1sums = a3a74542b6524e5663ad37aaba292b48e8bea3b1
pkgname = conky-cli
diff --git a/PKGBUILD b/PKGBUILD
index 39b707cfe5c6..771b648eadc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,25 @@
_pkgname=conky
pkgname=conky-cli
-pkgver=1.10.0
-pkgrel=3
+pkgver=1.10.1
+pkgrel=1
pkgdesc="Lightweight system monitor for X, without X11 dependencies"
-url='http://conky.sourceforge.net/'
+url='https://github.com/brndnmtthws/conky'
license=('BSD' 'GPL')
arch=('i686' 'x86_64')
provides=('conky')
conflicts=('conky')
-makedepends=('cmake' 'docbook2x' 'docbook-xml' 'docbook-xsl' 'man-db')
+makedepends=('cmake' 'docbook2x' 'docbook-xml' 'man-db' 'git')
depends=('curl' 'lua' 'wireless_tools' 'libxml2')
source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
- 'ascii.patch'
- 'lua53.patch'
- 'ipv6.patch'
- 'curl.patch')
-md5sums=('cdc0298e5f257829d574ae8114170d9b'
- 'd5b765cb7400d2fdca88b6c86aa8eec1'
- '44cdadfe92266e99698e5424b7c6e265'
- '702650dfaaacb4e778f3d3c6a296df0b'
- '8236606ca3d39b9d00a59022d4f953ac')
+ 'lua53.patch')
+
+sha1sums=('97b59ec1daf54126b30516e8663a9cf1f218d8ae'
+ 'a3a74542b6524e5663ad37aaba292b48e8bea3b1')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -p1 -i ../ascii.patch # db2x_manxml fails on non-ascii chars
patch -p1 -i ../lua53.patch # lua_gettable returns an int in lua-5.3
- patch -p1 -i ../ipv6.patch # https://bugs.archlinux.org/task/45626
- patch -p1 -i ../curl.patch # https://github.com/bagder/curl/issues/342
}
build() {
diff --git a/ascii.patch b/ascii.patch
deleted file mode 100644
index f04603f7d6c1..000000000000
--- a/ascii.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur old/doc/config_settings.xml new/doc/config_settings.xml
---- old/doc/config_settings.xml 2015-06-21 14:49:06.000000000 -1000
-+++ new/doc/config_settings.xml 2015-06-29 10:05:00.147318479 -1000
-@@ -80,7 +80,7 @@
- </term>
- <listitem>A comma-separated list of strings to use as the bars of a graph output
- to console/shell. The first list item is used for the minimum bar height and the
-- last item is used for the maximum. Example: " ,_,▁,▂,▃,▄,▅,▆,▇,█".
-+ last item is used for the maximum.
- <para /></listitem>
- </varlistentry>
- <varlistentry>
diff --git a/curl.patch b/curl.patch
deleted file mode 100644
index f5aad6532075..000000000000
--- a/curl.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur old/src/ccurl_thread.cc new/src/ccurl_thread.cc
---- old/src/ccurl_thread.cc 2015-06-21 14:49:06.000000000 -1000
-+++ new/src/ccurl_thread.cc 2015-07-11 09:11:49.053040998 -1000
-@@ -119,9 +119,7 @@
- headers.h = curl_slist_append(headers.h, ("If-None-Match: " + etag).c_str());
- etag.clear();
- }
-- if (headers.h) {
-- curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
-- }
-+ curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
-
- res = curl_easy_perform(curl);
- if (res == CURLE_OK) {
diff --git a/ipv6.patch b/ipv6.patch
deleted file mode 100644
index 7135ae708308..000000000000
--- a/ipv6.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ee08a9e1b045e8d2f4f13a0e60c2f603b66b0d69 Mon Sep 17 00:00:00 2001
-From: Marc Payne <marc321@gmail.com>
-Date: Mon, 6 Jul 2015 02:51:43 -0600
-Subject: [PATCH] Close file only if it was successfully opened
-
-If BUILD_IPV6=ON (default), but the user has disabled ipv6 support
-in the kernel using the parameter ipv6.disable=1, then conky fails
-to open /proc/net/if_inet6. This leads to a segfault when conky
-calls fclose(file) regardless. This fix simply moves the fclose call
-into the preceding if statement.
----
- src/linux.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/linux.cc b/src/linux.cc
-index 847acac..7977fee 100644
---- a/src/linux.cc
-+++ b/src/linux.cc
-@@ -643,8 +643,8 @@ int update_net_stats(void)
- }
- lastv6->next = NULL;
- }
-+ fclose(file);
- }
-- fclose(file);
- #endif /* BUILD_IPV6 */
-
- first = 0;