summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-09-10 18:32:56 -0400
committerKevin MacMartin2015-09-10 18:32:56 -0400
commit75ea5d4b41d3f038dc0fb3d914ee9c948b492d5c (patch)
tree99e926a556a211b4c529c04cef6315461f98772f
downloadaur-75ea5d4b41d3f038dc0fb3d914ee9c948b492d5c.tar.gz
Initial creation on version 20150806.r148.3980575
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
-rw-r--r--conky-colors-git.install6
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0f1b1fe5f75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = conky-colors-git
+ pkgdesc = An easier way to configure Conky
+ pkgver = 20150806.r148.3980575
+ pkgrel = 1
+ url = https://github.com/helmuthdu/conky_colors
+ install = conky-colors-git.install
+ arch = armv6h
+ arch = armv7h
+ arch = arm
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = python
+ depends = conky
+ depends = pystatgrab
+ depends = python2-keyring
+ depends = ttf-ubuntu-font-family
+ depends = hddtemp
+ depends = curl
+ depends = lm_sensors
+ provides = conky-colors
+ conflicts = conky-colors
+ source = git+https://github.com/helmuthdu/conky_colors.git
+ sha512sums = SKIP
+
+pkgname = conky-colors-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..190372471c6b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.pkg.tar.xz
+pkg
+src
+conky_colors
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95983aa59988
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
+
+_pkgname=conky-colors
+pkgname=$_pkgname-git
+pkgver=20150806.r148.3980575
+pkgrel=1
+pkgdesc='An easier way to configure Conky'
+url='https://github.com/helmuthdu/conky_colors'
+license=('GPL3')
+arch=('armv6h' 'armv7h' 'arm' 'i686' 'x86_64')
+depends=('python' 'conky' 'pystatgrab' 'python2-keyring' 'ttf-ubuntu-font-family' 'hddtemp' 'curl' 'lm_sensors')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+sha512sums=('SKIP')
+install=$pkgname.install
+
+pkgver() {
+ cd ${_pkgname/-/_}
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${_pkgname/-/_}
+ sed -i 's|\(ln -[^ ]* \)\$(DESTDIR)|\1/usr|;s|\$(DESTDIR)/bin|\$(DESTDIR)/usr/bin|' Makefile
+}
+
+build() {
+ cd ${_pkgname/-/_}
+ make
+}
+
+package() {
+ cd ${_pkgname/-/_}
+ install -dm755 "$pkgdir"/usr/bin
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/conky-colors-git.install b/conky-colors-git.install
new file mode 100644
index 000000000000..7122833a2e09
--- /dev/null
+++ b/conky-colors-git.install
@@ -0,0 +1,6 @@
+post_install() {
+ printf '%s\n %s\n %s\n' \
+ 'To prepare your system to use conky-colors-git, run the following as root:' \
+ '$ chmod u+s /usr/bin/hddtemp' \
+ '$ sensors-detect # answer yes to all questions'
+}