summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrdotx2023-03-24 14:32:38 +0100
committermrdotx2023-03-24 14:32:38 +0100
commit613af484636ea5a3682a92f4c7ac08c88f31745b (patch)
treeb6880174a705fcfea388fa14501b0e3eee00508f
parent59b17dde6e5ea59057946746c1c092be3e2e543a (diff)
downloadaur-conky-git.tar.gz
minor structural changes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD30
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be09185a1858..13f494f92426 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-git
pkgdesc = Lightweight system monitor for X
pkgver = 1.18.3.r14.ga9cecaf9
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/brndnmtthws/conky
arch = x86_64
license = BSD
@@ -36,7 +36,7 @@ pkgbase = conky-git
depends = libcurl.so
provides = conky
conflicts = conky
- source = conky-git::git+https://github.com/brndnmtthws/conky.git
+ source = git+https://github.com/brndnmtthws/conky.git
sha256sums = SKIP
pkgname = conky-git
diff --git a/PKGBUILD b/PKGBUILD
index c60e517138b5..6b83837b0ac1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,9 @@
_pkgname=conky
pkgname=conky-git
pkgver=1.18.3.r14.ga9cecaf9
-pkgrel=2
-pkgdesc="Lightweight system monitor for X"
-url="https://github.com/brndnmtthws/conky"
+pkgrel=3
+pkgdesc='Lightweight system monitor for X'
+url='https://github.com/brndnmtthws/conky'
license=('BSD' 'GPL')
arch=('x86_64')
makedepends=(
@@ -42,24 +42,24 @@ depends=(
'systemd-libs'
'ncurses'
'curl'
- libncursesw.so
- libXNVCtrl.so
- libsystemd.so
- libpulse.so
- libcurl.so
+ 'libncursesw.so'
+ 'libXNVCtrl.so'
+ 'libsystemd.so'
+ 'libpulse.so'
+ 'libcurl.so'
)
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("$pkgname::git+https://github.com/brndnmtthws/conky.git")
+provides=('conky')
+conflicts=('conky')
+source=('git+https://github.com/brndnmtthws/conky.git')
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
+ cd "$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$pkgname"
+ cd "$_pkgname"
# Unbundle catch2 to fix build with glibc 2.35
rm -r tests/catch2
@@ -67,7 +67,7 @@ prepare() {
}
build() {
- cd "$pkgname"
+ cd "$_pkgname"
cmake \
-B build \
@@ -93,7 +93,7 @@ build() {
}
package() {
- cd "$pkgname"
+ cd "$_pkgname"
make -C build DESTDIR="$pkgdir" install
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$_pkgname"
install -Dm644 extras/vim/syntax/conkyrc.vim.j2 -t \