summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrdotx2023-03-24 13:29:30 +0100
committermrdotx2023-03-24 13:29:30 +0100
commit59b17dde6e5ea59057946746c1c092be3e2e543a (patch)
treec47d74a620712db64cdb72bdafbfcd203252be9e
parentf8914321c7803f7fa5bee9bfbcc64cf458a77c6b (diff)
downloadaur-59b17dde6e5ea59057946746c1c092be3e2e543a.tar.gz
srcdir removed
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3fe0fa4add9..be09185a1858 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-git
pkgdesc = Lightweight system monitor for X
pkgver = 1.18.3.r14.ga9cecaf9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/brndnmtthws/conky
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index f0b9e139c0fe..c60e517138b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
_pkgname=conky
pkgname=conky-git
pkgver=1.18.3.r14.ga9cecaf9
-pkgrel=1
+pkgrel=2
pkgdesc="Lightweight system monitor for X"
url="https://github.com/brndnmtthws/conky"
license=('BSD' 'GPL')
@@ -54,12 +54,12 @@ source=("$pkgname::git+https://github.com/brndnmtthws/conky.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
# Unbundle catch2 to fix build with glibc 2.35
rm -r tests/catch2
@@ -67,7 +67,7 @@ prepare() {
}
build() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
cmake \
-B build \
@@ -93,7 +93,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname"
+ cd "$pkgname"
make -C build DESTDIR="$pkgdir" install
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$_pkgname"
install -Dm644 extras/vim/syntax/conkyrc.vim.j2 -t \