summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Landauer2018-12-04 19:03:41 +0100
committerBernhard Landauer2018-12-04 19:03:41 +0100
commitb519d73360446116a53be3a8d5ffff2d6cf25219 (patch)
tree9fc5ce9dcbcaf91f85ac58ce0d4b55cbfdab58e6
parent18c07857db495cc92049930fe952c2dcbd4604bf (diff)
downloadaur-b519d73360446116a53be3a8d5ffff2d6cf25219.tar.gz
v1.11.0
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD13
-rw-r--r--include_functional.patch10
4 files changed, 11 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28e85b5b0ea5..2ed2078e9494 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Jun 1 07:49:08 UTC 2017
+# Tue Dec 4 17:54:29 UTC 2018
pkgbase = conky-lua
pkgdesc = Lightweight system monitor for X, with Lua support enabled
- pkgver = 1.10.6
+ pkgver = 1.11.0
pkgrel = 1
url = http://github.com/brndnmtthws/conky
arch = i686
@@ -29,15 +29,13 @@ pkgbase = conky-lua
depends = lua51
depends = tolua++
depends = wireless_tools
- provides = conky=1.10.6
+ provides = conky=1.11.0
conflicts = conky
options = !emptydirs
backup = etc/conky/conky.conf
backup = etc/conky/conky_no_x11.conf
- source = https://github.com/brndnmtthws/conky/archive/v1.10.6.tar.gz
- source = include_functional.patch
- sha1sums = 54cb3322dc3a969f1fda03383012c61d57261345
- sha1sums = 5111076229ddfa778d60af15a8a13d3f703567ba
+ source = https://github.com/brndnmtthws/conky/archive/v1.11.0.tar.gz
+ sha1sums = 6c23fff734714cc5ca8907bba0e482e0d21eba02
pkgname = conky-lua
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5cc43b06a180
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/*
+src/*
+v*
diff --git a/PKGBUILD b/PKGBUILD
index df225eed962e..b97e5e9d2271 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=conky-lua
_pkgname=conky
-pkgver=1.10.6
+pkgver=1.11.0
pkgrel=1
pkgdesc='Lightweight system monitor for X, with Lua support enabled'
url='http://github.com/brndnmtthws/conky'
@@ -33,15 +33,8 @@ depends=('alsa-lib'
provides=("conky=$pkgver")
conflicts=('conky')
backup=('etc/conky/conky.conf' 'etc/conky/conky_no_x11.conf')
-source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
- 'include_functional.patch')
-sha1sums=('54cb3322dc3a969f1fda03383012c61d57261345'
- '5111076229ddfa778d60af15a8a13d3f703567ba')
-
-prepare() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- patch -p1 -i $srcdir/include_functional.patch
-}
+source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha1sums=('6c23fff734714cc5ca8907bba0e482e0d21eba02')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
diff --git a/include_functional.patch b/include_functional.patch
deleted file mode 100644
index 5010b3cb35fd..000000000000
--- a/include_functional.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -bur conky-1.10.6-orig/src/luamm.hh conky-1.10.6/src/luamm.hh
---- conky-1.10.6-orig/src/luamm.hh 2016-12-04 17:13:57.000000000 +0200
-+++ conky-1.10.6/src/luamm.hh 2017-05-31 20:05:59.000000000 +0300
-@@ -28,6 +28,7 @@
- #include <exception>
- #include <stdexcept>
- #include <string>
-+#include <functional>
-
- #include <lua.hpp>