summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn A Ginis2016-08-09 10:49:28 +0300
committerJohn A Ginis2016-08-09 10:49:28 +0300
commit0f82bbfa13afc84d03e85f603dbe9df5761ab6eb (patch)
tree9d15302a0a00eea955d07fb76a3f6b55de03de4a
parent1611837ad30c184d033dedaae02d1ab10e89ea4d (diff)
downloadaur-0f82bbfa13afc84d03e85f603dbe9df5761ab6eb.tar.gz
Includes patch to convert non-ascii chars to ascii.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--asciime.patch12
3 files changed, 28 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cf47aa1afb8..435703b930d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-lua-archers
pkgdesc = A free, light-weight system monitor for X with lua enabled for Arch based distros
pkgver = 1.10.4
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/brndnmtthws/conky
arch = i686
arch = x86_64
@@ -11,7 +11,9 @@ pkgbase = conky-lua-archers
makedepends = docbook2x
makedepends = docbook-xml
makedepends = docbook-xsl
+ makedepends = man-db
makedepends = perl-xml-libxml
+ makedepends = perl-xml-sax-expat
depends = alsa-lib
depends = cairo
depends = curl
@@ -37,7 +39,9 @@ pkgbase = conky-lua-archers
options = !strip
options = debug
source = https://github.com/brndnmtthws/conky/archive/v1.10.4.tar.gz
+ source = asciime.patch
sha1sums = f2da0e3b8e6ff8ebc42b35f710f822e228616993
+ sha1sums = b07407c2be11cee7bd50e046024b89cf2579c448
pkgname = conky-lua-archers
diff --git a/PKGBUILD b/PKGBUILD
index 56f5b1cbf5b6..7c5f8dac2b99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer : Yiannis A Ginis <drxspace[at]gmail[dot]com>
# Contributor : Spyros Stathopoulos <foucault.online[at]gmail[dot]com>
+# Contributor : Chris Sakalis <chrissakalis[at]gmail[dot]com>
pkgname=conky-lua-archers
_pkgname=conky
pkgver=1.10.4
-pkgrel=2
+pkgrel=3
pkgdesc="A free, light-weight system monitor for X with lua enabled for Arch based distros"
arch=('i686' 'x86_64')
url="https://github.com/brndnmtthws/conky"
license=('GPL3' 'BSD')
replaces=('torsmo' 'conky')
-conflicts=('conky' 'conky-lua' 'conky-lua-arch' 'conky-lua-nv' 'conky-lua-archers-git')
provides=('conky=1.10.4_pre')
+conflicts=('conky' 'conky-lua' 'conky-lua-arch' 'conky-lua-nv' 'conky-lua-archers-git')
depends=(
'alsa-lib'
'cairo'
@@ -33,15 +34,19 @@ makedepends=(
'docbook2x'
'docbook-xml'
'docbook-xsl'
+ 'man-db'
'perl-xml-libxml'
+ 'perl-xml-sax-expat'
)
-source=(https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz)
-sha1sums=('f2da0e3b8e6ff8ebc42b35f710f822e228616993')
+source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
+ 'asciime.patch')
+sha1sums=('f2da0e3b8e6ff8ebc42b35f710f822e228616993'
+ 'b07407c2be11cee7bd50e046024b89cf2579c448')
options=('!strip' 'debug')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- cd cmake
+ patch -p1 -i ../asciime.patch # db2x_manxml fails on non-ascii chars
}
build() {
@@ -82,7 +87,7 @@ build() {
package() {
cd ${srcdir}/${_pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
- install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -D -m644 LICENSE.GPL ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.GPL
install -D -m644 LICENSE.BSD ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.BSD
install -D -m644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
install -D -m644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
diff --git a/asciime.patch b/asciime.patch
new file mode 100644
index 000000000000..57725e153a9d
--- /dev/null
+++ b/asciime.patch
@@ -0,0 +1,12 @@
+diff -aur old/doc/config_settings.xml new/doc/config_settings.xml
+--- unicode/doc/config_settings.xml 2016-07-20 19:53:48.000000000 +0300
++++ ascii/doc/config_settings-new.xml 2016-08-09 10:05:46.094287298 +0300
+@@ -80,7 +80,7 @@
+ </term>
+ <listitem>A comma-separated list of strings to use as the bars of a graph output
+ to console/shell. The first list item is used for the minimum bar height and the
+- last item is used for the maximum. Example: " ,_,▁,▂,▃,▄,▅,▆,▇,█".
++ last item is used for the maximum.
+ <para /></listitem>
+ </varlistentry>
+ <varlistentry>