summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn A Ginis2017-06-05 13:59:00 +0300
committerJohn A Ginis2017-06-05 13:59:00 +0300
commit9a7476c226d6b7bb4bbc19a8de0feb26f3008a65 (patch)
treee691ae95ee4337486c9b412721a0a3e6948f6239
parentb74beace35c9f927f6e774ba19b21a90a150b1ea (diff)
downloadaur-9a7476c226d6b7bb4bbc19a8de0feb26f3008a65.tar.gz
New package commit
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--include.patch11
-rwxr-xr-xprepare4uploadpkg.sh10
4 files changed, 30 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb35d941940a..cd5cd048ac7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-lua-archers
pkgdesc = A free, light-weight system monitor for X with lua enabled for Arch based distros
pkgver = 1.10.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/brndnmtthws/conky
arch = i686
arch = x86_64
@@ -39,8 +39,10 @@ pkgbase = conky-lua-archers
options = !debug
source = https://github.com/brndnmtthws/conky/archive/v1.10.6.tar.gz
source = asciime.patch
+ source = include.patch
sha1sums = 54cb3322dc3a969f1fda03383012c61d57261345
sha1sums = b07407c2be11cee7bd50e046024b89cf2579c448
+ sha1sums = 0efe24eab88c48cc1fef0dae001ce935f743c131
pkgname = conky-lua-archers
diff --git a/PKGBUILD b/PKGBUILD
index 8df73f3523d1..b438f3cbe603 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=conky-lua-archers
_pkgname=conky
pkgver=1.10.6
-pkgrel=2
+pkgrel=3
pkgdesc="A free, light-weight system monitor for X with lua enabled for Arch based distros"
arch=('i686' 'x86_64')
url="https://github.com/brndnmtthws/conky"
@@ -38,14 +38,17 @@ makedepends=(
'perl-xml-sax-expat'
)
source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
- 'asciime.patch')
+ 'asciime.patch'
+ 'include.patch')
sha1sums=('54cb3322dc3a969f1fda03383012c61d57261345'
- 'b07407c2be11cee7bd50e046024b89cf2579c448')
+ 'b07407c2be11cee7bd50e046024b89cf2579c448'
+ '0efe24eab88c48cc1fef0dae001ce935f743c131')
options=('strip' '!debug')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -p1 -i ../asciime.patch # db2x_manxml fails on non-ascii chars
+ patch -p1 -i ../include.patch # Build fails with gcc7 due to missing include
}
build() {
diff --git a/include.patch b/include.patch
new file mode 100644
index 000000000000..fd3afb89004c
--- /dev/null
+++ b/include.patch
@@ -0,0 +1,11 @@
+
+diff -bur conky-1.10.6-orig/src/luamm.hh conky-1.10.6/src/luamm.hh
+--- conky-1.10.6-orig/src/luamm.hh 2016-12-04 17:13:57.000000000 +0200
++++ conky-1.10.6/src/luamm.hh 2017-05-31 20:05:59.000000000 +0300
+@@ -28,6 +28,7 @@
+ #include <exception>
+ #include <stdexcept>
+ #include <string>
++#include <functional>
+
+ #include <lua.hpp>
diff --git a/prepare4uploadpkg.sh b/prepare4uploadpkg.sh
new file mode 100755
index 000000000000..934309fc5e6d
--- /dev/null
+++ b/prepare4uploadpkg.sh
@@ -0,0 +1,10 @@
+#!/usr/bin/env bash
+
+namcap PKGBUILD && makepkg --printsrcinfo > .SRCINFO || exit 1
+git add . || exit 1 # PKGBUILD prepare4uploadpkg.sh .SRCINFO
+git commit -am "New package commit" || exit 1
+git push --set-upstream origin master || exit 1
+
+read -p "Press [Enter] key to exit..."
+
+exit $?