summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2015-07-20 20:36:36 +0300
committerSpyros Stathopoulos2015-07-20 20:36:36 +0300
commit53e78854b2163c0223f306f809c02860ab7a9967 (patch)
tree51d4956f98e98fe0274d999af7d12b79e823d833
parent2db1acd811ed74d205283b6d9a37e5a711100acb (diff)
downloadaur-53e78854b2163c0223f306f809c02860ab7a9967.tar.gz
Update to v1.10
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD67
-rw-r--r--ascii.patch12
-rw-r--r--curl.patch14
-rw-r--r--ipv6.patch28
-rw-r--r--lua53.patch46
6 files changed, 161 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de86e1e128df..126cf80ec575 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-lua-nv
pkgdesc = An advanced system monitor for X based on torsmo with lua and nvidia enabled
- pkgver = 1.9.0
- pkgrel = 7
+ pkgver = 1.10.0
+ pkgrel = 3
url = http://conky.sourceforge.net/
install = conky-lua-nv.install
arch = i686
@@ -11,6 +11,8 @@ pkgbase = conky-lua-nv
makedepends = libxnvctrl
makedepends = tolua++
makedepends = perl-xml-libxml
+ makedepends = docbook-xml
+ makedepends = docbook-xsl
depends = alsa-lib
depends = libxml2
depends = curl
@@ -20,7 +22,7 @@ pkgbase = conky-lua-nv
depends = glib2
depends = libxdamage
depends = imlib2
- depends = lua51
+ depends = lua
optdepends = nvidia: for GT4xx and newer GPUs,
optdepends = nvidia-340xx: for G8x, G9x, GT2xx GPUS,
optdepends = nvidia-304xx: for GeForce 6/7 GPUs
@@ -29,10 +31,18 @@ pkgbase = conky-lua-nv
conflicts = conky
replaces = torsmo
replaces = conky
- backup = etc/conky/conky.conf
- backup = etc/conky/conky_no_x11.conf
- source = http://downloads.sourceforge.net/project/conky/conky/1.9.0/conky-1.9.0.tar.bz2
- md5sums = d3de615f43aadc98d555e05ad9e902c2
+ options = !strip
+ options = debug
+ source = https://github.com/brndnmtthws/conky/archive/v1.10.0.tar.gz
+ source = ascii.patch
+ source = lua53.patch
+ source = ipv6.patch
+ source = curl.patch
+ sha1sums = d5863420150150002947180d0ee96c9ef56c43b1
+ sha1sums = 96cdbc38e8706c8a3120601983df5c7265716128
+ sha1sums = a3a74542b6524e5663ad37aaba292b48e8bea3b1
+ sha1sums = a0899973483d0ad664b60e58b3ba899ba88712af
+ sha1sums = 1c066b439a1e7166d733fb710faa9bf08b81ce4c
pkgname = conky-lua-nv
diff --git a/PKGBUILD b/PKGBUILD
index a223605e25af..e2afaa92791c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
pkgname=conky-lua-nv
_pkgname=conky
-pkgver=1.9.0
-pkgrel=7
+pkgver=1.10.0
+pkgrel=3
pkgdesc="An advanced system monitor for X based on torsmo with lua and nvidia enabled"
arch=('i686' 'x86_64')
url="http://conky.sourceforge.net/"
@@ -16,34 +16,55 @@ license=('custom')
replaces=('torsmo' 'conky')
conflicts=('conky')
provides=('conky' 'conky-lua')
-depends=('alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools' 'libxft' 'glib2' 'libxdamage' 'imlib2' 'lua51' )
-makedepends=('docbook2x' 'libxnvctrl' 'tolua++' 'perl-xml-libxml')
+depends=('alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools' 'libxft' 'glib2' 'libxdamage' 'imlib2' 'lua' )
+makedepends=('docbook2x' 'libxnvctrl' 'tolua++' 'perl-xml-libxml' 'docbook-xml' 'docbook-xsl')
optdepends=('nvidia: for GT4xx and newer GPUs',
'nvidia-340xx: for G8x, G9x, GT2xx GPUS',
'nvidia-304xx: for GeForce 6/7 GPUs')
-backup=(etc/conky/conky.conf etc/conky/conky_no_x11.conf)
-source=(http://downloads.sourceforge.net/project/${_pkgname}/${_pkgname}/${pkgver}/${_pkgname}-${pkgver}.tar.bz2)
- md5sums=('d3de615f43aadc98d555e05ad9e902c2')
-install="conky-lua-nv.install"
+source=(https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz
+ ascii.patch
+ lua53.patch
+ ipv6.patch
+ curl.patch)
+sha1sums=('d5863420150150002947180d0ee96c9ef56c43b1'
+ '96cdbc38e8706c8a3120601983df5c7265716128'
+ 'a3a74542b6524e5663ad37aaba292b48e8bea3b1'
+ 'a0899973483d0ad664b60e58b3ba899ba88712af'
+ '1c066b439a1e7166d733fb710faa9bf08b81ce4c')
+options=('!strip' 'debug')
+install=('conky-lua-nv.install')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ patch -p1 -i ../ascii.patch
+ patch -p1 -i ../lua53.patch
+ patch -p1 -i ../ipv6.patch
+ patch -p1 -i ../curl.patch
+
+ cd cmake
+ # -lXext must come *after* -lXNVCtrl
+ sed -i -e \
+ 's/set(conky_libs ${conky_libs} ${XNVCtrl_LIB})/set(conky_libs ${XNVCtrl_LIB} ${conky_libs})/' \
+ ConkyPlatformChecks.cmake
+}
build() {
cd ${srcdir}/${_pkgname}-${pkgver}
- LUA51_LIBS='-llua5.1 -lm' LUA51_CFLAGS='-I/usr/include/lua5.1' \
- LUA_LIBS='-llua5.1 -lm' LUA_CFLAGS="-I/usr/include/lua5.1" \
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --enable-wlan \
- --enable-curl \
- --enable-rss \
- --enable-ibm \
- --enable-imlib2 \
- --enable-lua \
- --enable-lua-cairo \
- --enable-lua-imlib2 \
- --enable-ibm \
- --enable-weather-xoap \
- --enable-nvidia
+ cmake \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D MAINTAINER_MODE=ON \
+ -D BUILD_CURL=ON \
+ -D BUILD_IMLIB2=ON \
+ -D BUILD_RSS=ON \
+ -D BUILD_WEATHER_METAR=ON \
+ -D BUILD_WEATHER_XOAP=ON \
+ -D BUILD_WLAN=ON \
+ -D BUILD_NVIDIA=ON \
+ -D BUILD_XDBE=ON \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ .
+
make
}
diff --git a/ascii.patch b/ascii.patch
new file mode 100644
index 000000000000..f04603f7d6c1
--- /dev/null
+++ b/ascii.patch
@@ -0,0 +1,12 @@
+diff -aur old/doc/config_settings.xml new/doc/config_settings.xml
+--- old/doc/config_settings.xml 2015-06-21 14:49:06.000000000 -1000
++++ new/doc/config_settings.xml 2015-06-29 10:05:00.147318479 -1000
+@@ -80,7 +80,7 @@
+ </term>
+ <listitem>A comma-separated list of strings to use as the bars of a graph output
+ to console/shell. The first list item is used for the minimum bar height and the
+- last item is used for the maximum. Example: " ,_,▁,▂,▃,▄,▅,▆,▇,█".
++ last item is used for the maximum.
+ <para /></listitem>
+ </varlistentry>
+ <varlistentry>
diff --git a/curl.patch b/curl.patch
new file mode 100644
index 000000000000..f5aad6532075
--- /dev/null
+++ b/curl.patch
@@ -0,0 +1,14 @@
+diff -Naur old/src/ccurl_thread.cc new/src/ccurl_thread.cc
+--- old/src/ccurl_thread.cc 2015-06-21 14:49:06.000000000 -1000
++++ new/src/ccurl_thread.cc 2015-07-11 09:11:49.053040998 -1000
+@@ -119,9 +119,7 @@
+ headers.h = curl_slist_append(headers.h, ("If-None-Match: " + etag).c_str());
+ etag.clear();
+ }
+- if (headers.h) {
+- curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
+- }
++ curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
+
+ res = curl_easy_perform(curl);
+ if (res == CURLE_OK) {
diff --git a/ipv6.patch b/ipv6.patch
new file mode 100644
index 000000000000..7135ae708308
--- /dev/null
+++ b/ipv6.patch
@@ -0,0 +1,28 @@
+From ee08a9e1b045e8d2f4f13a0e60c2f603b66b0d69 Mon Sep 17 00:00:00 2001
+From: Marc Payne <marc321@gmail.com>
+Date: Mon, 6 Jul 2015 02:51:43 -0600
+Subject: [PATCH] Close file only if it was successfully opened
+
+If BUILD_IPV6=ON (default), but the user has disabled ipv6 support
+in the kernel using the parameter ipv6.disable=1, then conky fails
+to open /proc/net/if_inet6. This leads to a segfault when conky
+calls fclose(file) regardless. This fix simply moves the fclose call
+into the preceding if statement.
+---
+ src/linux.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/linux.cc b/src/linux.cc
+index 847acac..7977fee 100644
+--- a/src/linux.cc
++++ b/src/linux.cc
+@@ -643,8 +643,8 @@ int update_net_stats(void)
+ }
+ lastv6->next = NULL;
+ }
++ fclose(file);
+ }
+- fclose(file);
+ #endif /* BUILD_IPV6 */
+
+ first = 0;
diff --git a/lua53.patch b/lua53.patch
new file mode 100644
index 000000000000..daab1264649d
--- /dev/null
+++ b/lua53.patch
@@ -0,0 +1,46 @@
+diff -aur old/src/luamm.cc new/src/luamm.cc
+--- old/src/luamm.cc 2015-06-28 16:38:47.793615922 -1000
++++ new/src/luamm.cc 2015-06-29 09:05:44.646667638 -1000
+@@ -165,7 +165,14 @@
+ }
+
+ template<void (*misc)(lua_State *, int), int nresults>
+- int safe_misc_trampoline(lua_State *l)
++ int safe_misc_trampoline_set(lua_State *l)
++ {
++ misc(l, 1);
++ return nresults;
++ }
++
++ template<int (*misc)(lua_State *, int), int nresults>
++ int safe_misc_trampoline_get(lua_State *l)
+ {
+ misc(l, 1);
+ return nresults;
+@@ -326,7 +333,7 @@
+ if( rawequal(index1, index2) )
+ return true;
+
+- return safe_compare(&safe_compare_trampoline<lua_equal>, index1, index2);
++ return safe_compare(&safe_compare_trampoline<&lua_equal>, index1, index2);
+ }
+
+ int state::gc(int what, int data)
+@@ -367,7 +374,7 @@
+ checkstack(2);
+ pushvalue(index);
+ insert(-2);
+- lua_pushcfunction(cobj.get(), (&safe_misc_trampoline<&lua_gettable, 1>));
++ lua_pushcfunction(cobj.get(), (&safe_misc_trampoline_get<&lua_gettable, 1>));
+ insert(-3);
+ call(2, 1, 0);
+ }
+@@ -492,7 +499,7 @@
+ checkstack(2);
+ pushvalue(index);
+ insert(-3);
+- lua_pushcfunction(cobj.get(), (&safe_misc_trampoline<&lua_settable, 0>));
++ lua_pushcfunction(cobj.get(), (&safe_misc_trampoline_set<&lua_settable, 0>));
+ insert(-4);
+ call(3, 0, 0);
+ }