summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2018-12-07 16:06:30 +0000
committerSpyros Stathopoulos2018-12-07 16:06:30 +0000
commitabd67a43ff4104ec637b338a134ff7e6e2634011 (patch)
tree4c7a28fbd3444575f5391a88b6a799c548cc3853
parent6bef4570300a187aff563b21508433e036d0f733 (diff)
downloadaur-abd67a43ff4104ec637b338a134ff7e6e2634011.tar.gz
Update to 1.11.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--ascii.patch12
-rw-r--r--fix_build.patch11
-rw-r--r--gcc7.patch10
-rw-r--r--nvidia.patch16
6 files changed, 28 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17e4e0ba2631..da3ab9cc44f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = conky-lua-nv
pkgdesc = An advanced system monitor for X based on torsmo with lua and nvidia enabled
- pkgver = 1.10.8
+ pkgver = 1.11.0
pkgrel = 1
url = https://github.com/brndnmtthws/conky
install = conky-lua-nv.install
@@ -37,10 +37,10 @@ pkgbase = conky-lua-nv
replaces = conky
options = !strip
options = debug
- source = https://github.com/brndnmtthws/conky/archive/v1.10.8.tar.gz
- source = gcc7.patch
- sha1sums = 8dea9614cf39cce8df8b7080c1cef6741d112887
- sha1sums = 5111076229ddfa778d60af15a8a13d3f703567ba
+ source = https://github.com/brndnmtthws/conky/archive/v1.11.0.tar.gz
+ source = nvidia.patch
+ sha1sums = 6c23fff734714cc5ca8907bba0e482e0d21eba02
+ sha1sums = 446f20dfa900ec42ee842932dcf4c3d6dc2111dc
pkgname = conky-lua-nv
diff --git a/PKGBUILD b/PKGBUILD
index b26d5f69824c..07d932138d09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=conky-lua-nv
_pkgname=conky
-pkgver=1.10.8
+pkgver=1.11.0
pkgrel=1
pkgdesc="An advanced system monitor for X based on torsmo with lua and nvidia enabled"
arch=('i686' 'x86_64')
@@ -24,17 +24,16 @@ makedepends=('docbook2x' 'perl-xml-libxml' 'docbook-xml'
optdepends=('nvidia: for GT4xx and newer GPUs',
'nvidia-340xx: for G8x, G9x, GT2xx GPUS',
'nvidia-304xx: for GeForce 6/7 GPUs')
-source=(https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz
- gcc7.patch)
-sha1sums=('8dea9614cf39cce8df8b7080c1cef6741d112887'
- '5111076229ddfa778d60af15a8a13d3f703567ba')
+source=("https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz"
+ "nvidia.patch")
+sha1sums=('6c23fff734714cc5ca8907bba0e482e0d21eba02'
+ '446f20dfa900ec42ee842932dcf4c3d6dc2111dc')
options=('!strip' 'debug')
install='conky-lua-nv.install'
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
-
- cd cmake
+ patch -p1 < '../nvidia.patch'
}
build() {
@@ -57,6 +56,7 @@ build() {
-D CMAKE_INSTALL_PREFIX=/usr \
.
+
make
}
diff --git a/ascii.patch b/ascii.patch
deleted file mode 100644
index f04603f7d6c1..000000000000
--- a/ascii.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur old/doc/config_settings.xml new/doc/config_settings.xml
---- old/doc/config_settings.xml 2015-06-21 14:49:06.000000000 -1000
-+++ new/doc/config_settings.xml 2015-06-29 10:05:00.147318479 -1000
-@@ -80,7 +80,7 @@
- </term>
- <listitem>A comma-separated list of strings to use as the bars of a graph output
- to console/shell. The first list item is used for the minimum bar height and the
-- last item is used for the maximum. Example: " ,_,▁,▂,▃,▄,▅,▆,▇,█".
-+ last item is used for the maximum.
- <para /></listitem>
- </varlistentry>
- <varlistentry>
diff --git a/fix_build.patch b/fix_build.patch
deleted file mode 100644
index 7f1257a2e451..000000000000
--- a/fix_build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- orig/cmake/ConkyPlatformChecks.cmake 2015-12-03 12:52:37.391221762 +0200
-+++ new/cmake/ConkyPlatformChecks.cmake 2015-12-03 12:53:30.102200472 +0200
-@@ -332,7 +332,7 @@
- find_library(XNVCtrl_LIB NAMES XNVCtrl)
- if(XNVCtrl_INCLUDE_PATH AND XNVCtrl_LIB)
- set(XNVCtrl_FOUND true)
-- set(conky_libs ${conky_libs} ${XNVCtrl_LIB})
-+ set(conky_libs ${XNVCtrl_LIB} ${conky_libs})
- set(conky_includes ${conky_includes} ${XNVCtrl_INCLUDE_PATH})
- else(XNVCtrl_INCLUDE_PATH AND XNVCtrl_LIB)
- message(FATAL_ERROR "Unable to find XNVCtrl library")
diff --git a/gcc7.patch b/gcc7.patch
deleted file mode 100644
index 5010b3cb35fd..000000000000
--- a/gcc7.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -bur conky-1.10.6-orig/src/luamm.hh conky-1.10.6/src/luamm.hh
---- conky-1.10.6-orig/src/luamm.hh 2016-12-04 17:13:57.000000000 +0200
-+++ conky-1.10.6/src/luamm.hh 2017-05-31 20:05:59.000000000 +0300
-@@ -28,6 +28,7 @@
- #include <exception>
- #include <stdexcept>
- #include <string>
-+#include <functional>
-
- #include <lua.hpp>
diff --git a/nvidia.patch b/nvidia.patch
new file mode 100644
index 000000000000..94dd12fc4c32
--- /dev/null
+++ b/nvidia.patch
@@ -0,0 +1,16 @@
+diff --git a/src/nvidia.cc b/src/nvidia.cc
+index 16e76646..a2cfc043 100644
+--- a/src/nvidia.cc
++++ b/src/nvidia.cc
+@@ -91,7 +91,9 @@
+ */
+
+ #include "nvidia.h"
+-#include <NVCtrl/NVCtrlLib.h>
++#include <X11/Xlib.h>
++#include "NVCtrl/NVCtrl.h"
++#include "NVCtrl/NVCtrlLib.h"
+ #include "conky.h"
+ #include "logging.h"
+ #include "temphelper.h"
+