summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2015-12-03 13:10:41 +0200
committerSpyros Stathopoulos2015-12-03 13:10:41 +0200
commitb32fc96b395048b0dba7cc058b5a36a179c3ab11 (patch)
treefdf84decca09ff6505254a15cf237f938b950cb8
parenta1b2ac8699022652ab90ff3e90328b1738304f38 (diff)
downloadaur-b32fc96b395048b0dba7cc058b5a36a179c3ab11.tar.gz
Fix toluapp issues
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD30
-rw-r--r--cpu_count.patch32
-rw-r--r--curl.patch14
-rw-r--r--fix_build.patch34
-rw-r--r--ipv6.patch28
-rw-r--r--lua53.patch46
7 files changed, 50 insertions, 140 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1295d72031bb..7471bdefb033 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = conky-lua-nv
pkgdesc = An advanced system monitor for X based on torsmo with lua and nvidia enabled
pkgver = 1.10.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/brndnmtthws/conky
install = conky-lua-nv.install
arch = i686
@@ -10,7 +10,6 @@ pkgbase = conky-lua-nv
license = BSD
makedepends = docbook2x
makedepends = libxnvctrl
- makedepends = tolua++
makedepends = perl-xml-libxml
makedepends = docbook-xml
makedepends = docbook-xsl
@@ -26,6 +25,7 @@ pkgbase = conky-lua-nv
depends = imlib2
depends = lua51
depends = librsvg
+ depends = tolua++
optdepends = nvidia: for GT4xx and newer GPUs,
optdepends = nvidia-340xx: for G8x, G9x, GT2xx GPUS,
optdepends = nvidia-304xx: for GeForce 6/7 GPUs
@@ -38,8 +38,10 @@ pkgbase = conky-lua-nv
options = debug
source = https://github.com/brndnmtthws/conky/archive/v1.10.1.tar.gz
source = ascii.patch
+ source = fix_build.patch
sha1sums = 97b59ec1daf54126b30516e8663a9cf1f218d8ae
sha1sums = 96cdbc38e8706c8a3120601983df5c7265716128
+ sha1sums = 3ef0f96772410f975e815087509db9537edcd6e2
pkgname = conky-lua-nv
diff --git a/PKGBUILD b/PKGBUILD
index ae63cdc1d058..b3ad72472699 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Maintainer: Jon Wilson <bugs@pandorica.net>
-# Contributor: Spyros Stathopoulos <foucault.online[at]gmail[dot]com>
+# Maintainer: Spyros Stathopoulos <foucault.online[at]gmail[dot]com>
+# Contributor: Jon Wilson <bugs@pandorica.net>
# Contributor: Andrwe Lord Weber <lord-weber-andrwe [at] andrwe [dot] org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: James Rayner <james@archlinux.org>
@@ -8,7 +8,7 @@
pkgname=conky-lua-nv
_pkgname=conky
pkgver=1.10.1
-pkgrel=1
+pkgrel=2
pkgdesc="An advanced system monitor for X based on torsmo with lua and nvidia enabled"
arch=('i686' 'x86_64')
url="https://github.com/brndnmtthws/conky"
@@ -16,34 +16,28 @@ license=('GPL3' 'BSD')
replaces=('torsmo' 'conky')
conflicts=('conky')
provides=('conky' 'conky-lua')
-depends=('alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools' 'libxft' 'glib2' 'libxdamage' 'imlib2' 'lua51' 'librsvg')
-makedepends=('docbook2x' 'libxnvctrl' 'tolua++' 'perl-xml-libxml' 'docbook-xml' 'docbook-xsl' 'cmake')
+depends=('alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools'
+ 'libxft' 'glib2' 'libxdamage' 'imlib2' 'lua51' 'librsvg' 'tolua++')
+makedepends=('docbook2x' 'libxnvctrl' 'perl-xml-libxml'
+ 'docbook-xml' 'docbook-xsl' 'cmake')
optdepends=('nvidia: for GT4xx and newer GPUs',
'nvidia-340xx: for G8x, G9x, GT2xx GPUS',
'nvidia-304xx: for GeForce 6/7 GPUs')
source=(https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz
- ascii.patch)
+ ascii.patch
+ fix_build.patch)
sha1sums=('97b59ec1daf54126b30516e8663a9cf1f218d8ae'
- '96cdbc38e8706c8a3120601983df5c7265716128')
+ '96cdbc38e8706c8a3120601983df5c7265716128'
+ '3ef0f96772410f975e815087509db9537edcd6e2')
options=('!strip' 'debug')
install=('conky-lua-nv.install')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -p1 -i ../ascii.patch
+ patch -p1 -i ../fix_build.patch
cd cmake
- # -lXext must come *after* -lXNVCtrl
- sed -i -e \
- 's/set(conky_libs ${conky_libs} ${XNVCtrl_LIB})/set(conky_libs ${XNVCtrl_LIB} ${conky_libs})/' \
- ConkyPlatformChecks.cmake
- sed -i -e \
- 's/pkg_search_module(LUA REQUIRED lua5.2 lua-5.2 lua>=5.1 lua5.1 lua-5.1)/pkg_search_module(LUA REQUIRED lua=5.1 lua5.1 lua-5.1)/' \
- ConkyPlatformChecks.cmake
- sed -i -e \
- 's/include(CheckIncludeFile)/include(CheckIncludeFiles)/' \
- ConkyPlatformChecks.cmake
-
}
build() {
diff --git a/cpu_count.patch b/cpu_count.patch
deleted file mode 100644
index f4993cc48bf5..000000000000
--- a/cpu_count.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff --git a/src/core.cc b/src/core.cc
-index e39eefd..56eb820 100644
---- a/src/core.cc
-+++ b/src/core.cc
-@@ -571,23 +571,27 @@ struct text_object *construct_text_object(char *s, const char *arg,
- __var = 0; \
- }
- END OBJ(cpu, &update_cpu_usage)
-+ get_cpu_count();
- SCAN_CPU(arg, obj->data.i);
- obj->callbacks.percentage = &cpu_percentage;
- DBGP2("Adding $cpu for CPU %d", obj->data.i);
- #ifdef BUILD_X11
- END OBJ(cpugauge, &update_cpu_usage)
-+ get_cpu_count();
- SCAN_CPU(arg, obj->data.i);
- scan_gauge(obj, arg, 1);
- obj->callbacks.gaugeval = &cpu_barval;
- DBGP2("Adding $cpugauge for CPU %d", obj->data.i);
- #endif
- END OBJ(cpubar, &update_cpu_usage)
-+ get_cpu_count();
- SCAN_CPU(arg, obj->data.i);
- scan_bar(obj, arg, 1);
- obj->callbacks.barval = &cpu_barval;
- DBGP2("Adding $cpubar for CPU %d", obj->data.i);
- #ifdef BUILD_X11
- END OBJ(cpugraph, &update_cpu_usage)
-+ get_cpu_count();
- char *buf = 0;
- SCAN_CPU(arg, obj->data.i);
- buf = scan_graph(obj, arg, 1);
diff --git a/curl.patch b/curl.patch
deleted file mode 100644
index f5aad6532075..000000000000
--- a/curl.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur old/src/ccurl_thread.cc new/src/ccurl_thread.cc
---- old/src/ccurl_thread.cc 2015-06-21 14:49:06.000000000 -1000
-+++ new/src/ccurl_thread.cc 2015-07-11 09:11:49.053040998 -1000
-@@ -119,9 +119,7 @@
- headers.h = curl_slist_append(headers.h, ("If-None-Match: " + etag).c_str());
- etag.clear();
- }
-- if (headers.h) {
-- curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
-- }
-+ curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
-
- res = curl_easy_perform(curl);
- if (res == CURLE_OK) {
diff --git a/fix_build.patch b/fix_build.patch
new file mode 100644
index 000000000000..d7d9c5ea6b43
--- /dev/null
+++ b/fix_build.patch
@@ -0,0 +1,34 @@
+--- orig/cmake/ConkyPlatformChecks.cmake 2015-12-03 12:52:37.391221762 +0200
++++ new/cmake/ConkyPlatformChecks.cmake 2015-12-03 12:53:30.102200472 +0200
+@@ -249,7 +249,7 @@
+ endif(X11_FOUND)
+ endif(BUILD_X11)
+
+-pkg_search_module(LUA REQUIRED lua5.2 lua-5.2 lua>=5.1 lua5.1 lua-5.1)
++pkg_search_module(LUA REQUIRED lua=5.1 lua5.1 lua-5.1)
+ set(conky_libs ${conky_libs} ${LUA_LIBRARIES})
+ set(conky_includes ${conky_includes} ${LUA_INCLUDE_DIRS})
+ link_directories(${LUA_LIBRARY_DIRS})
+@@ -332,7 +332,7 @@
+ find_library(XNVCtrl_LIB NAMES XNVCtrl)
+ if(XNVCtrl_INCLUDE_PATH AND XNVCtrl_LIB)
+ set(XNVCtrl_FOUND true)
+- set(conky_libs ${conky_libs} ${XNVCtrl_LIB})
++ set(conky_libs ${XNVCtrl_LIB} ${conky_libs})
+ set(conky_includes ${conky_includes} ${XNVCtrl_INCLUDE_PATH})
+ else(XNVCtrl_INCLUDE_PATH AND XNVCtrl_LIB)
+ message(FATAL_ERROR "Unable to find XNVCtrl library")
+@@ -365,11 +365,11 @@
+ endif(WANT_LIBXML2)
+
+ if(WANT_TOLUA)
+- find_program(APP_TOLUA NAMES tolua++ tolua++5.1 tolua++-5.1)
++ find_program(APP_TOLUA NAMES toluapp tolua++ tolua++5.1 tolua++-5.1)
+ if(NOT APP_TOLUA)
+ message(FATAL_ERROR "Unable to find program 'tolua++'")
+ endif(NOT APP_TOLUA)
+- find_library(TOLUA_LIBS NAMES tolua++ tolua++5.1 tolua++-5.1)
++ find_library(TOLUA_LIBS NAMES toluapp tolua++ tolua++5.1 tolua++-5.1)
+ find_path(TOLUA_INCLUDE_PATH tolua++.h ${INCLUDE_SEARCH_PATH})
+ if(TOLUA_INCLUDE_PATH AND TOLUA_LIBS)
+ set(TOLUA_FOUND true)
diff --git a/ipv6.patch b/ipv6.patch
deleted file mode 100644
index 7135ae708308..000000000000
--- a/ipv6.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ee08a9e1b045e8d2f4f13a0e60c2f603b66b0d69 Mon Sep 17 00:00:00 2001
-From: Marc Payne <marc321@gmail.com>
-Date: Mon, 6 Jul 2015 02:51:43 -0600
-Subject: [PATCH] Close file only if it was successfully opened
-
-If BUILD_IPV6=ON (default), but the user has disabled ipv6 support
-in the kernel using the parameter ipv6.disable=1, then conky fails
-to open /proc/net/if_inet6. This leads to a segfault when conky
-calls fclose(file) regardless. This fix simply moves the fclose call
-into the preceding if statement.
----
- src/linux.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/linux.cc b/src/linux.cc
-index 847acac..7977fee 100644
---- a/src/linux.cc
-+++ b/src/linux.cc
-@@ -643,8 +643,8 @@ int update_net_stats(void)
- }
- lastv6->next = NULL;
- }
-+ fclose(file);
- }
-- fclose(file);
- #endif /* BUILD_IPV6 */
-
- first = 0;
diff --git a/lua53.patch b/lua53.patch
deleted file mode 100644
index daab1264649d..000000000000
--- a/lua53.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -aur old/src/luamm.cc new/src/luamm.cc
---- old/src/luamm.cc 2015-06-28 16:38:47.793615922 -1000
-+++ new/src/luamm.cc 2015-06-29 09:05:44.646667638 -1000
-@@ -165,7 +165,14 @@
- }
-
- template<void (*misc)(lua_State *, int), int nresults>
-- int safe_misc_trampoline(lua_State *l)
-+ int safe_misc_trampoline_set(lua_State *l)
-+ {
-+ misc(l, 1);
-+ return nresults;
-+ }
-+
-+ template<int (*misc)(lua_State *, int), int nresults>
-+ int safe_misc_trampoline_get(lua_State *l)
- {
- misc(l, 1);
- return nresults;
-@@ -326,7 +333,7 @@
- if( rawequal(index1, index2) )
- return true;
-
-- return safe_compare(&safe_compare_trampoline<lua_equal>, index1, index2);
-+ return safe_compare(&safe_compare_trampoline<&lua_equal>, index1, index2);
- }
-
- int state::gc(int what, int data)
-@@ -367,7 +374,7 @@
- checkstack(2);
- pushvalue(index);
- insert(-2);
-- lua_pushcfunction(cobj.get(), (&safe_misc_trampoline<&lua_gettable, 1>));
-+ lua_pushcfunction(cobj.get(), (&safe_misc_trampoline_get<&lua_gettable, 1>));
- insert(-3);
- call(2, 1, 0);
- }
-@@ -492,7 +499,7 @@
- checkstack(2);
- pushvalue(index);
- insert(-3);
-- lua_pushcfunction(cobj.get(), (&safe_misc_trampoline<&lua_settable, 0>));
-+ lua_pushcfunction(cobj.get(), (&safe_misc_trampoline_set<&lua_settable, 0>));
- insert(-4);
- call(3, 0, 0);
- }