summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2016-05-05 12:38:08 +0300
committerSpyros Stathopoulos2016-05-05 12:38:08 +0300
commitbb6c273108ec3c156ef526c7608b5263ea07b8d4 (patch)
treeeb8fb600e93711edba83fc2cfa5fb65e50e6b5c8
parent07b1cb8682d3f1cf6786d096577c0d699727f274 (diff)
downloadaur-bb6c273108ec3c156ef526c7608b5263ea07b8d4.tar.gz
Update to 1.10.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--fix_build.patch23
3 files changed, 11 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 926cdd14b207..17569e098cc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Tue Feb 9 23:16:46 UTC 2016
+# Thu May 5 09:35:25 UTC 2016
pkgbase = conky-lua-nv
pkgdesc = An advanced system monitor for X based on torsmo with lua and nvidia enabled
- pkgver = 1.10.1
- pkgrel = 3
+ pkgver = 1.10.2
+ pkgrel = 1
url = https://github.com/brndnmtthws/conky
install = conky-lua-nv.install
arch = i686
@@ -38,12 +38,12 @@ pkgbase = conky-lua-nv
replaces = conky
options = !strip
options = debug
- source = https://github.com/brndnmtthws/conky/archive/v1.10.1.tar.gz
+ source = https://github.com/brndnmtthws/conky/archive/v1.10.2.tar.gz
source = ascii.patch
source = fix_build.patch
- sha1sums = 97b59ec1daf54126b30516e8663a9cf1f218d8ae
+ sha1sums = 7392523d2eb9e2044faae8d44cbd006b387d0a85
sha1sums = 96cdbc38e8706c8a3120601983df5c7265716128
- sha1sums = 3ef0f96772410f975e815087509db9537edcd6e2
+ sha1sums = 6e53bb6e94b80b19f64451e34606c5d5e9c7a666
pkgname = conky-lua-nv
diff --git a/PKGBUILD b/PKGBUILD
index 7de4a1c4b93c..14f8e5af31ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
pkgname=conky-lua-nv
_pkgname=conky
-pkgver=1.10.1
-pkgrel=3
+pkgver=1.10.2
+pkgrel=1
pkgdesc="An advanced system monitor for X based on torsmo with lua and nvidia enabled"
arch=('i686' 'x86_64')
url="https://github.com/brndnmtthws/conky"
@@ -26,16 +26,16 @@ optdepends=('nvidia: for GT4xx and newer GPUs',
source=(https://github.com/brndnmtthws/${_pkgname}/archive/v${pkgver}.tar.gz
ascii.patch
fix_build.patch)
-sha1sums=('97b59ec1daf54126b30516e8663a9cf1f218d8ae'
+sha1sums=('7392523d2eb9e2044faae8d44cbd006b387d0a85'
'96cdbc38e8706c8a3120601983df5c7265716128'
- '3ef0f96772410f975e815087509db9537edcd6e2')
+ '6e53bb6e94b80b19f64451e34606c5d5e9c7a666')
options=('!strip' 'debug')
install='conky-lua-nv.install'
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
patch -p1 -i ../ascii.patch
- patch -p1 -i ../fix_build.patch
+ #patch -p1 -i ../fix_build.patch
cd cmake
}
diff --git a/fix_build.patch b/fix_build.patch
index d7d9c5ea6b43..7f1257a2e451 100644
--- a/fix_build.patch
+++ b/fix_build.patch
@@ -1,14 +1,5 @@
--- orig/cmake/ConkyPlatformChecks.cmake 2015-12-03 12:52:37.391221762 +0200
+++ new/cmake/ConkyPlatformChecks.cmake 2015-12-03 12:53:30.102200472 +0200
-@@ -249,7 +249,7 @@
- endif(X11_FOUND)
- endif(BUILD_X11)
-
--pkg_search_module(LUA REQUIRED lua5.2 lua-5.2 lua>=5.1 lua5.1 lua-5.1)
-+pkg_search_module(LUA REQUIRED lua=5.1 lua5.1 lua-5.1)
- set(conky_libs ${conky_libs} ${LUA_LIBRARIES})
- set(conky_includes ${conky_includes} ${LUA_INCLUDE_DIRS})
- link_directories(${LUA_LIBRARY_DIRS})
@@ -332,7 +332,7 @@
find_library(XNVCtrl_LIB NAMES XNVCtrl)
if(XNVCtrl_INCLUDE_PATH AND XNVCtrl_LIB)
@@ -18,17 +9,3 @@
set(conky_includes ${conky_includes} ${XNVCtrl_INCLUDE_PATH})
else(XNVCtrl_INCLUDE_PATH AND XNVCtrl_LIB)
message(FATAL_ERROR "Unable to find XNVCtrl library")
-@@ -365,11 +365,11 @@
- endif(WANT_LIBXML2)
-
- if(WANT_TOLUA)
-- find_program(APP_TOLUA NAMES tolua++ tolua++5.1 tolua++-5.1)
-+ find_program(APP_TOLUA NAMES toluapp tolua++ tolua++5.1 tolua++-5.1)
- if(NOT APP_TOLUA)
- message(FATAL_ERROR "Unable to find program 'tolua++'")
- endif(NOT APP_TOLUA)
-- find_library(TOLUA_LIBS NAMES tolua++ tolua++5.1 tolua++-5.1)
-+ find_library(TOLUA_LIBS NAMES toluapp tolua++ tolua++5.1 tolua++-5.1)
- find_path(TOLUA_INCLUDE_PATH tolua++.h ${INCLUDE_SEARCH_PATH})
- if(TOLUA_INCLUDE_PATH AND TOLUA_LIBS)
- set(TOLUA_FOUND true)