summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Korop2016-09-26 13:55:02 +0300
committerAlexey Korop2016-09-26 13:55:02 +0300
commit0653a3ddecd2143758fb48883dc08e74c720fa6a (patch)
tree394faa3b51da3212f6d770cf6e95d2a69ba4a743
parent8ef5497575c863e3c57d3bb540db0834c60af332 (diff)
downloadaur-0653a3ddecd2143758fb48883dc08e74c720fa6a.tar.gz
Update to conky 1.10.4 sources
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--conky-mt.patch28
-rw-r--r--execgraph.patch13
-rw-r--r--xshape.patch6
5 files changed, 12 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1191864f75cb..b112f6eb9ef4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = conky-mt
pkgdesc = Lightweight system monitor for X
- pkgver = 1.10.1
+ pkgver = 1.10.4
pkgrel = 1
url = https://github.com/brndnmtthws/conky
arch = i686
@@ -24,14 +24,12 @@ pkgbase = conky-mt
conflicts = conky
options = !strip
options = debug
- source = https://github.com/brndnmtthws/conky/archive/v1.10.1.tar.gz
+ source = https://github.com/brndnmtthws/conky/archive/v1.10.4.tar.gz
source = lua53.patch
source = xshape.patch
- source = execgraph.patch
- sha1sums = 97b59ec1daf54126b30516e8663a9cf1f218d8ae
+ sha1sums = f2da0e3b8e6ff8ebc42b35f710f822e228616993
sha1sums = a3a74542b6524e5663ad37aaba292b48e8bea3b1
- sha1sums = 930f9d0313b7e32b895b75aa92be2cb128f957ed
- sha1sums = 7615818bc255032dc4f5eeba9a2e009b9a7c177c
+ sha1sums = 4bb3ac31b61f46e57abb451df549186f455f8f8b
pkgname = conky-mt
diff --git a/PKGBUILD b/PKGBUILD
index 5e7c9c3c536f..258450111133 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
pkgname=conky-mt
-pkgver=1.10.1
+pkgver=1.10.4
pkgrel=1
pkgdesc='Lightweight system monitor for X'
url='https://github.com/brndnmtthws/conky'
@@ -20,11 +20,11 @@ provides=('conky')
source=("https://github.com/brndnmtthws/conky/archive/v${pkgver}.tar.gz"
'lua53.patch'
'xshape.patch'
- 'execgraph.patch')
-sha1sums=('97b59ec1daf54126b30516e8663a9cf1f218d8ae'
+ )
+sha1sums=('f2da0e3b8e6ff8ebc42b35f710f822e228616993'
'a3a74542b6524e5663ad37aaba292b48e8bea3b1'
- '930f9d0313b7e32b895b75aa92be2cb128f957ed'
- '7615818bc255032dc4f5eeba9a2e009b9a7c177c')
+ '4bb3ac31b61f46e57abb451df549186f455f8f8b'
+ )
options=('!strip' 'debug')
@@ -33,7 +33,6 @@ prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -p1 -i ../lua53.patch # lua_gettable returns an int in lua-5.3
patch -p1 -i ../xshape.patch # https://github.com/brndnmtthws/conky/issues/158
- patch -p1 -i ../execgraph.patch # https://github.com/brndnmtthws/conky/issues/153
}
build() {
diff --git a/conky-mt.patch b/conky-mt.patch
deleted file mode 100644
index 1fe9cb296201..000000000000
--- a/conky-mt.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/src/conky.c 2012-05-04 00:22:21.000000000 +0300
-+++ b/src/conky.c 2015-01-24 22:57:05.018893944 +0200
-@@ -137,6 +137,8 @@
- #include "conf_cookie.h"
- #endif
-
-+#include <X11/extensions/shape.h>
-+
- #ifndef S_ISSOCK
- #define S_ISSOCK(x) ((x & S_IFMT) == S_IFSOCK)
- #endif
-@@ -3492,6 +3494,16 @@
- last_update_time = 0.0;
- next_update_time = get_time();
- info.looped = 0;
-+
-+ if (own_window &&
-+ (( window.type != TYPE_NORMAL ||
-+ (TEST_HINT(window.hints, HINT_UNDECORATED))) &&
-+ window.type != TYPE_DESKTOP)) {
-+ /* set the empty input shape, i.e. make the window "mouse-through" */
-+ XShapeCombineRectangles(display, window.window, ShapeInput, 0, 0,
-+ NULL, 0, ShapeSet, Unsorted);
-+ }
-+
- while (terminate == 0 && (total_run_times == 0 || info.looped < total_run_times)) {
- if(update_interval_bat != NOBATTERY && update_interval_bat != update_interval_old) {
- char buf[max_user_text];
diff --git a/execgraph.patch b/execgraph.patch
deleted file mode 100644
index 375fa6679575..000000000000
--- a/execgraph.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/exec.cc b/src/exec.cc
-index 10f47d8..2eaf6fd 100644
---- a/src/exec.cc
-+++ b/src/exec.cc
-@@ -220,7 +220,7 @@ void scan_execi_gauge_arg(struct text_object *obj, const char *arg)
- return;
- }
- ed->cmd = buf;
-- obj->data.opaque = ed;
-+ obj->data.s = strndup(arg ? arg : "", text_buffer_size.get(*state));
- }
- #endif /* BUILD_X11 */
-
diff --git a/xshape.patch b/xshape.patch
index 990c32046642..f84b5247d885 100644
--- a/xshape.patch
+++ b/xshape.patch
@@ -52,9 +52,9 @@ index 48f5197..15db872 100644
-#include <X11/extensions/shape.h>
-#include <X11/extensions/shapeconst.h>
-#endif
-
- #ifdef BUILD_ARGB
- bool have_argb_visual;
+ #ifdef BUILD_XINERAMA
+ #include <X11/extensions/Xinerama.h>
+ #endif
@@ -716,26 +712,6 @@ static void init_window(lua::state &l __attribute__((unused)), bool own)
wmHint.flags = InputHint | StateHint;