summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Korop2020-03-14 08:53:02 +0200
committerAlexey Korop2020-03-14 08:53:02 +0200
commit257cf9820c35cf71b77e35d46929064de6cda8b2 (patch)
tree5272c7c0c218c9e0eee1e3a4f35b3caba8078fb4
parenta1361b58f491c295e0ce164997952517146c0f66 (diff)
downloadaur-257cf9820c35cf71b77e35d46929064de6cda8b2.tar.gz
Adaptation to the 1.11.5.2 version of the 'extra/conky' package
-rw-r--r--.SRCINFO25
-rwxr-xr-x[-rw-r--r--]PKGBUILD38
-rw-r--r--button_mask.patch12
-rw-r--r--lua53.patch46
-rw-r--r--xshape.patch123
5 files changed, 105 insertions, 139 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b112f6eb9ef4..1d2858679eb3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,36 @@
+# Generated by mksrcinfo v8
+# Sat Mar 14 06:49:43 UTC 2020
pkgbase = conky-mt
pkgdesc = Lightweight system monitor for X
- pkgver = 1.10.4
- pkgrel = 1
+ pkgver = 1.11.5
+ pkgrel = 2
url = https://github.com/brndnmtthws/conky
- arch = i686
arch = x86_64
license = BSD
license = GPL
makedepends = cmake
makedepends = docbook2x
- makedepends = docbook-xml
+ makedepends = docbook-xsl
makedepends = man-db
makedepends = git
depends = glib2
- depends = curl
depends = lua
depends = wireless_tools
- depends = libxml2
- depends = libxft
depends = libxdamage
+ depends = libxinerama
+ depends = libxft
depends = imlib2
+ depends = libxml2
+ depends = libpulse
+ depends = libxnvctrl
provides = conky
conflicts = conky
options = !strip
options = debug
- source = https://github.com/brndnmtthws/conky/archive/v1.10.4.tar.gz
- source = lua53.patch
+ source = https://github.com/brndnmtthws/conky/archive/v1.11.5.tar.gz
source = xshape.patch
- sha1sums = f2da0e3b8e6ff8ebc42b35f710f822e228616993
- sha1sums = a3a74542b6524e5663ad37aaba292b48e8bea3b1
- sha1sums = 4bb3ac31b61f46e57abb451df549186f455f8f8b
+ sha256sums = 4cefdd92219a90934c28297e4ac7448a3f69d6aeec5d48c5763b23f6b214ef13
+ sha256sums = e88d967ac00ffcda4bd85d7f175608246d795590007a4d0e481e8dfc13c486e6
pkgname = conky-mt
diff --git a/PKGBUILD b/PKGBUILD
index 1954c652be2f..48819dbd91c3 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,36 @@
-# Patches 'xshape.patch' and 'button_mask.patch' by Alexey Korop added.
-# Original package info:
+# 'extra' data:
# $Id: PKGBUILD 284823 2016-12-26 19:43:10Z bisson $
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: James Rayner <james@archlinux.org>
# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
+# 'AUR' data:
+# Patch 'xshape.patch' by Alexey Korop <akorop@ukr.net> added.
+# Maintainer Alexey Korop <akorop@ukr.net>.
+
pkgname=conky-mt
-pkgver=1.10.6
-pkgrel=1
+pkgver=1.11.5
+pkgrel=2
pkgdesc='Lightweight system monitor for X'
url='https://github.com/brndnmtthws/conky'
license=('BSD' 'GPL')
-arch=('i686' 'x86_64')
-makedepends=('cmake' 'docbook2x' 'docbook-xml' 'man-db' 'git')
+arch=('x86_64')
+conflicts=('conky')
+provides=('conky')
+makedepends=('cmake' 'docbook2x' 'docbook-xsl' 'man-db' 'git')
depends=('glib2' 'lua' 'wireless_tools' 'libxdamage' 'libxinerama' 'libxft'
- 'imlib2' 'libxml2' 'libpulse')
+ 'imlib2' 'libxml2' 'libpulse' 'libxnvctrl')
source=("https://github.com/brndnmtthws/conky/archive/v${pkgver}.tar.gz"
'xshape.patch'
- 'button_mask.patch'
- 'lua53.patch')
-sha1sums=('54cb3322dc3a969f1fda03383012c61d57261345'
- 'ba05be063488020bfbf0a594574ac58ed5a1eaec'
- 'b5e774b6144164091852bab0996f79853664fb6f'
- 'a3a74542b6524e5663ad37aaba292b48e8bea3b1')
-
+)
+sha256sums=('4cefdd92219a90934c28297e4ac7448a3f69d6aeec5d48c5763b23f6b214ef13'
+ 'e88d967ac00ffcda4bd85d7f175608246d795590007a4d0e481e8dfc13c486e6')
options=('!strip' 'debug')
prepare() {
mv "${srcdir}/conky-${pkgver}" "${srcdir}/${pkgname}-${pkgver}"
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 -i ../lua53.patch # lua_gettable returns an int in lua-5.3
- patch -p1 -i ../button_mask.patch
patch -p1 -i ../xshape.patch # https://github.com/brndnmtthws/conky/issues/158
}
@@ -41,14 +40,17 @@ build() {
cmake \
-D CMAKE_BUILD_TYPE=Release \
-D MAINTAINER_MODE=ON \
+ -D BUILD_DOCS=ON \
-D BUILD_WLAN=ON \
-D BUILD_XDBE=ON \
- -D BUILD_IMLIB2=ON \
-D BUILD_XSHAPE=ON \
+ -D BUILD_IMLIB2=ON \
+ -D BUILD_CURL=ON \
-D BUILD_RSS=ON \
+ -D BUILD_NVIDIA=ON \
-D BUILD_WEATHER_METAR=ON \
- -D BUILD_WEATHER_XOAP=ON \
-D BUILD_PULSEAUDIO=ON \
+ -D BUILD_JOURNAL=ON \
-D CMAKE_INSTALL_PREFIX=/usr \
.
diff --git a/button_mask.patch b/button_mask.patch
deleted file mode 100644
index f5e9d020cf00..000000000000
--- a/button_mask.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/src/x11.cc
-+++ b/src/x11.cc
-@@ -974,7 +974,7 @@
-
- XSelectInput(display, window.window, ExposureMask | PropertyChangeMask
- #ifdef OWN_WINDOW
-- | (own_window.get(l) ? (StructureNotifyMask |
-+ | (own ? (StructureNotifyMask |
- ButtonPressMask | ButtonReleaseMask) : 0)
- #endif
- );
-
diff --git a/lua53.patch b/lua53.patch
deleted file mode 100644
index daab1264649d..000000000000
--- a/lua53.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-diff -aur old/src/luamm.cc new/src/luamm.cc
---- old/src/luamm.cc 2015-06-28 16:38:47.793615922 -1000
-+++ new/src/luamm.cc 2015-06-29 09:05:44.646667638 -1000
-@@ -165,7 +165,14 @@
- }
-
- template<void (*misc)(lua_State *, int), int nresults>
-- int safe_misc_trampoline(lua_State *l)
-+ int safe_misc_trampoline_set(lua_State *l)
-+ {
-+ misc(l, 1);
-+ return nresults;
-+ }
-+
-+ template<int (*misc)(lua_State *, int), int nresults>
-+ int safe_misc_trampoline_get(lua_State *l)
- {
- misc(l, 1);
- return nresults;
-@@ -326,7 +333,7 @@
- if( rawequal(index1, index2) )
- return true;
-
-- return safe_compare(&safe_compare_trampoline<lua_equal>, index1, index2);
-+ return safe_compare(&safe_compare_trampoline<&lua_equal>, index1, index2);
- }
-
- int state::gc(int what, int data)
-@@ -367,7 +374,7 @@
- checkstack(2);
- pushvalue(index);
- insert(-2);
-- lua_pushcfunction(cobj.get(), (&safe_misc_trampoline<&lua_gettable, 1>));
-+ lua_pushcfunction(cobj.get(), (&safe_misc_trampoline_get<&lua_gettable, 1>));
- insert(-3);
- call(2, 1, 0);
- }
-@@ -492,7 +499,7 @@
- checkstack(2);
- pushvalue(index);
- insert(-3);
-- lua_pushcfunction(cobj.get(), (&safe_misc_trampoline<&lua_settable, 0>));
-+ lua_pushcfunction(cobj.get(), (&safe_misc_trampoline_set<&lua_settable, 0>));
- insert(-4);
- call(3, 0, 0);
- }
diff --git a/xshape.patch b/xshape.patch
index 48a3f54806e5..bf58f2222ab1 100644
--- a/xshape.patch
+++ b/xshape.patch
@@ -1,6 +1,17 @@
+diff --git a/conky.cc b/conky.cc
+index f099221..32b1cdb 100644
--- a/src/conky.cc
+++ b/src/conky.cc
-@@ -60,6 +60,9 @@
+@@ -10,7 +10,7 @@
+ *
+ * Copyright (c) 2004, Hannu Saransaari and Lauri Hakkarainen
+ * Copyright (c) 2005-2019 Brenden Matthews, Philip Kovacs, et. al.
+- * (see AUTHORS)
++ * (see AUTHORS)
+ * All rights reserved.
+ *
+ * This program is free software: you can redistribute it and/or modify
+@@ -66,6 +66,9 @@
#ifdef BUILD_IMLIB2
#include "imlib2.h"
#endif /* BUILD_IMLIB2 */
@@ -10,69 +21,79 @@
#endif /* BUILD_X11 */
#ifdef BUILD_NCURSES
#include <ncurses.h>
-@@ -2046,6 +2049,25 @@
+@@ -1820,6 +1823,24 @@ static void update_text() {
int inotify_fd = -1;
#endif
+#ifdef BUILD_XSHAPE
+static bool need_null_shape = true;
-+ /* allow only decorated windows to be given mouse input */
++ /* allow only decorated windows to be given mouse input */
+void set_null_shape(void){
-+ int major_version, minor_version;
-+ if (!XShapeQueryVersion(display, &major_version, &minor_version)) {
-+ NORM_ERR("Input shapes are not supported");
-+ } else {
-+ if (own_window.get(*state) &&
-+ (own_window_type.get(*state) != TYPE_NORMAL ||
-+ (TEST_HINT(own_window_hints.get(*state), HINT_UNDECORATED)))) {
-+ XShapeCombineRectangles(display, window.window, ShapeInput, 0, 0,
-+ NULL, 0, ShapeSet, Unsorted);
-+ }
-+ }
++ int major_version, minor_version;
++ if (!XShapeQueryVersion(display, &major_version, &minor_version)) {
++ NORM_ERR("Input shapes are not supported");
++ } else {
++ if (own_window.get(*state) &&
++ (own_window_type.get(*state) != TYPE_NORMAL ||
++ (TEST_HINT(own_window_hints.get(*state), HINT_UNDECORATED)))) {
++ XShapeCombineRectangles(display, window.window, ShapeInput, 0, 0,
++ NULL, 0, ShapeSet, Unsorted);
++ }
++ }
+}
+#endif /* BUILD_XSHAPE */
+
-+
- static void main_loop(void)
- {
- int terminate = 0;
-@@ -2067,6 +2089,10 @@
- sigaddset(&newmask, SIGTERM);
- sigaddset(&newmask, SIGUSR1);
+ template <typename Out>
+ void split(const std::string &s, char delim, Out result) {
+ std::stringstream ss(s);
+@@ -1868,6 +1889,10 @@ void main_loop() {
+ sigaddset(&newmask, SIGUSR1);
#endif
-+
+
+#ifdef BUILD_XSHAPE
-+ set_null_shape();
++ set_null_shape();
+#endif /* BUILD_XSHAPE */
-
- last_update_time = 0.0;
- next_update_time = get_time() - fmod(get_time(), active_update_interval());
-@@ -2335,7 +2361,12 @@
- own_window_type.get(*state) == TYPE_DESKTOP) {
- /* allow conky to hold input focus. */
- break;
-- } else {
-+ }
++
+ last_update_time = 0.0;
+ next_update_time = get_time() - fmod(get_time(), active_update_interval());
+ info.looped = 0;
+@@ -2125,6 +2150,11 @@ void main_loop() {
+ /* allow conky to hold input focus. */
+ break;
+ }
+#ifdef BUILD_XSHAPE
-+ else if (need_null_shape)
-+ set_null_shape();
++ else if (need_null_shape)
++ set_null_shape();
+#endif /* BUILD_XSHAPE */
-+ else {
- /* forward the click to the desktop window */
- XUngrabPointer(display, ev.xbutton.time);
- ev.xbutton.window = window.desktop;
-@@ -2356,7 +2387,12 @@
- not TEST_HINT(own_window_hints.get(*state), HINT_UNDECORATED)) {
- /* allow conky to hold input focus. */
- break;
-- } else {
-+ }
++ else {
+ /* forward the click to the desktop window */
+ XUngrabPointer(display, ev.xbutton.time);
+ ev.xbutton.window = window.desktop;
+@@ -2135,6 +2165,7 @@ void main_loop() {
+ XSetInputFocus(display, ev.xbutton.window, RevertToParent,
+ ev.xbutton.time);
+ }
++ }
+ break;
+
+ case ButtonRelease:
+@@ -2146,6 +2177,11 @@ void main_loop() {
+ /* allow conky to hold input focus. */
+ break;
+ }
+#ifdef BUILD_XSHAPE
-+ else if (need_null_shape)
-+ set_null_shape();
++ else if (need_null_shape)
++ set_null_shape();
+#endif /* BUILD_XSHAPE */
-+ else {
- /* forward the release to the desktop window */
- ev.xbutton.window = window.desktop;
- ev.xbutton.x = ev.xbutton.x_root;
-
++ else {
+ /* forward the release to the desktop window */
+ ev.xbutton.window = window.desktop;
+ ev.xbutton.x = ev.xbutton.x_root;
+@@ -2153,6 +2189,7 @@ void main_loop() {
+ XSendEvent(display, ev.xbutton.window, False, ButtonReleaseMask,
+ &ev);
+ }
++ }
+ break;
+
+ #endif