summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Korop2015-10-26 08:42:29 +0200
committerAlexey Korop2015-10-26 08:42:29 +0200
commit5286f9f6bf754fcef761e7ef9cc05472085445a1 (patch)
tree58cb7fac9b4997e7c36caf04de750b0e2080a160
parent906015f93b3871176e84423dbdff7b1a7bd219b2 (diff)
downloadaur-5286f9f6bf754fcef761e7ef9cc05472085445a1.tar.gz
2 bugs fixed: about mouse transparence and about execgraph
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD77
-rw-r--r--ascii.patch12
-rw-r--r--curl.patch14
-rw-r--r--execgraph.patch13
-rw-r--r--ipv6.patch28
-rw-r--r--lua53.patch46
-rw-r--r--xshape.patch84
8 files changed, 269 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e727af23a0e0..9e8dbc56d4ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = conky-mt
- pkgdesc = Mouse-through conky based on /extra/conky package
- pkgver = 1.9.0
- pkgrel = 4
+ pkgdesc = Lightweight system monitor for X
+ pkgver = 1.10.0
+ pkgrel = 5
url = http://conky.sourceforge.net/
arch = i686
arch = x86_64
license = BSD
license = GPL
+ makedepends = cmake
makedepends = docbook2x
+ makedepends = docbook-xml
+ makedepends = man-db
depends = glib2
depends = curl
depends = lua
@@ -18,13 +21,22 @@ pkgbase = conky-mt
depends = imlib2
provides = conky
conflicts = conky
- options = !emptydirs
- backup = etc/conky/conky.conf
- backup = etc/conky/conky_no_x11.conf
- source = http://downloads.sourceforge.net/project/conky/conky/1.9.0/conky-1.9.0.tar.gz
- source = conky-mt.patch
- sha1sums = a8d26d002370c9b877ae77ad3a3bbd2566b38e5d
- sha1sums = d9b97d64849f96c5b0cdc82506ddc44081f0c210
+ options = !strip
+ options = debug
+ source = https://github.com/brndnmtthws/conky/archive/v1.10.0.tar.gz
+ source = ascii.patch
+ source = lua53.patch
+ source = ipv6.patch
+ source = curl.patch
+ source = xshape.patch
+ source = execgraph.patch
+ sha1sums = d5863420150150002947180d0ee96c9ef56c43b1
+ sha1sums = 96cdbc38e8706c8a3120601983df5c7265716128
+ sha1sums = a3a74542b6524e5663ad37aaba292b48e8bea3b1
+ sha1sums = a0899973483d0ad664b60e58b3ba899ba88712af
+ sha1sums = 1c066b439a1e7166d733fb710faa9bf08b81ce4c
+ sha1sums = 930f9d0313b7e32b895b75aa92be2cb128f957ed
+ sha1sums = 7615818bc255032dc4f5eeba9a2e009b9a7c177c
pkgname = conky-mt
diff --git a/PKGBUILD b/PKGBUILD
index 750463acb128..92652ef074db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,74 @@
-# Patched by Alexey Korop. Original package info:
-# $Id: PKGBUILD 205494 2014-02-06 05:24:01Z bisson $
+# Patches 'execgraph.patch' and 'xshape.patch' by Alexey Korop added.
+# Original package info:
+# $Id: PKGBUILD 246486 2015-09-17 21:01:11Z foutrelis $
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: James Rayner <james@archlinux.org>
# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
pkgname=conky-mt
-ORIG=conky
-pkgver=1.9.0
-pkgrel=4
-pkgdesc='Mouse-through conky based on /extra/conky package'
+pkgver=1.10.0
+pkgrel=5
+pkgdesc='Lightweight system monitor for X'
url='http://conky.sourceforge.net/'
license=('BSD' 'GPL')
arch=('i686' 'x86_64')
-makedepends=('docbook2x')
+makedepends=('cmake' 'docbook2x' 'docbook-xml' 'man-db')
+depends=('glib2' 'curl' 'lua' 'wireless_tools' 'libxml2' 'libxft' 'libxdamage' 'imlib2')
conflicts=('conky')
provides=('conky')
-depends=('glib2' 'curl' 'lua' 'wireless_tools' 'libxml2' 'libxft' 'libxdamage' 'imlib2')
-source=("http://downloads.sourceforge.net/project/${ORIG}/${ORIG}/${pkgver}/${ORIG}-${pkgver}.tar.gz"
- 'conky-mt.patch')
-sha1sums=('a8d26d002370c9b877ae77ad3a3bbd2566b38e5d'
- 'd9b97d64849f96c5b0cdc82506ddc44081f0c210')
+source=("https://github.com/brndnmtthws/conky/archive/v${pkgver}.tar.gz"
+ 'ascii.patch'
+ 'lua53.patch'
+ 'ipv6.patch'
+ 'curl.patch'
+ 'xshape.patch'
+ 'execgraph.patch')
+sha1sums=('d5863420150150002947180d0ee96c9ef56c43b1'
+ '96cdbc38e8706c8a3120601983df5c7265716128'
+ 'a3a74542b6524e5663ad37aaba292b48e8bea3b1'
+ 'a0899973483d0ad664b60e58b3ba899ba88712af'
+ '1c066b439a1e7166d733fb710faa9bf08b81ce4c'
+ '930f9d0313b7e32b895b75aa92be2cb128f957ed'
+ '7615818bc255032dc4f5eeba9a2e009b9a7c177c')
-backup=('etc/conky/'conky{,_no_x11}.conf)
-options=('!emptydirs')
+options=('!strip' 'debug')
+
+prepare() {
+ mv "${srcdir}/conky-${pkgver}" "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i ../ascii.patch # db2x_manxml fails on non-ascii chars
+ patch -p1 -i ../lua53.patch # lua_gettable returns an int in lua-5.3
+ patch -p1 -i ../ipv6.patch # https://bugs.archlinux.org/task/45626
+ patch -p1 -i ../curl.patch # https://github.com/bagder/curl/issues/342
+ patch -p1 -i ../xshape.patch # https://github.com/brndnmtthws/conky/issues/158
+ patch -p1 -i ../execgraph.patch # https://github.com/brndnmtthws/conky/issues/153
+}
build() {
- cd "${srcdir}/${ORIG}-${pkgver}"
- patch -p1 < ../../conky-mt.patch
+ cd "${srcdir}/${pkgname}-${pkgver}"
- CPPFLAGS="${CXXFLAGS}" LIBS="${LDFLAGS}" ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --enable-ibm \
- --enable-curl \
- --enable-rss \
- --enable-weather-xoap \
- --enable-imlib2 \
- --enable-wlan \
+ cmake \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D MAINTAINER_MODE=ON \
+ -D BUILD_CURL=ON \
+ -D BUILD_XDBE=ON \
+ -D BUILD_IMLIB2=ON \
+ -D BUILD_XSHAPE=ON \
+ -D BUILD_RSS=ON \
+ -D BUILD_WEATHER_METAR=ON \
+ -D BUILD_WEATHER_XOAP=ON \
+ -D BUILD_WLAN=ON \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ .
make
}
package() {
- cd "${srcdir}/${ORIG}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${ORIG}/LICENSE"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
install -Dm644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
}
diff --git a/ascii.patch b/ascii.patch
new file mode 100644
index 000000000000..f04603f7d6c1
--- /dev/null
+++ b/ascii.patch
@@ -0,0 +1,12 @@
+diff -aur old/doc/config_settings.xml new/doc/config_settings.xml
+--- old/doc/config_settings.xml 2015-06-21 14:49:06.000000000 -1000
++++ new/doc/config_settings.xml 2015-06-29 10:05:00.147318479 -1000
+@@ -80,7 +80,7 @@
+ </term>
+ <listitem>A comma-separated list of strings to use as the bars of a graph output
+ to console/shell. The first list item is used for the minimum bar height and the
+- last item is used for the maximum. Example: " ,_,▁,▂,▃,▄,▅,▆,▇,█".
++ last item is used for the maximum.
+ <para /></listitem>
+ </varlistentry>
+ <varlistentry>
diff --git a/curl.patch b/curl.patch
new file mode 100644
index 000000000000..f5aad6532075
--- /dev/null
+++ b/curl.patch
@@ -0,0 +1,14 @@
+diff -Naur old/src/ccurl_thread.cc new/src/ccurl_thread.cc
+--- old/src/ccurl_thread.cc 2015-06-21 14:49:06.000000000 -1000
++++ new/src/ccurl_thread.cc 2015-07-11 09:11:49.053040998 -1000
+@@ -119,9 +119,7 @@
+ headers.h = curl_slist_append(headers.h, ("If-None-Match: " + etag).c_str());
+ etag.clear();
+ }
+- if (headers.h) {
+- curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
+- }
++ curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
+
+ res = curl_easy_perform(curl);
+ if (res == CURLE_OK) {
diff --git a/execgraph.patch b/execgraph.patch
new file mode 100644
index 000000000000..375fa6679575
--- /dev/null
+++ b/execgraph.patch
@@ -0,0 +1,13 @@
+diff --git a/src/exec.cc b/src/exec.cc
+index 10f47d8..2eaf6fd 100644
+--- a/src/exec.cc
++++ b/src/exec.cc
+@@ -220,7 +220,7 @@ void scan_execi_gauge_arg(struct text_object *obj, const char *arg)
+ return;
+ }
+ ed->cmd = buf;
+- obj->data.opaque = ed;
++ obj->data.s = strndup(arg ? arg : "", text_buffer_size.get(*state));
+ }
+ #endif /* BUILD_X11 */
+
diff --git a/ipv6.patch b/ipv6.patch
new file mode 100644
index 000000000000..7135ae708308
--- /dev/null
+++ b/ipv6.patch
@@ -0,0 +1,28 @@
+From ee08a9e1b045e8d2f4f13a0e60c2f603b66b0d69 Mon Sep 17 00:00:00 2001
+From: Marc Payne <marc321@gmail.com>
+Date: Mon, 6 Jul 2015 02:51:43 -0600
+Subject: [PATCH] Close file only if it was successfully opened
+
+If BUILD_IPV6=ON (default), but the user has disabled ipv6 support
+in the kernel using the parameter ipv6.disable=1, then conky fails
+to open /proc/net/if_inet6. This leads to a segfault when conky
+calls fclose(file) regardless. This fix simply moves the fclose call
+into the preceding if statement.
+---
+ src/linux.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/linux.cc b/src/linux.cc
+index 847acac..7977fee 100644
+--- a/src/linux.cc
++++ b/src/linux.cc
+@@ -643,8 +643,8 @@ int update_net_stats(void)
+ }
+ lastv6->next = NULL;
+ }
++ fclose(file);
+ }
+- fclose(file);
+ #endif /* BUILD_IPV6 */
+
+ first = 0;
diff --git a/lua53.patch b/lua53.patch
new file mode 100644
index 000000000000..daab1264649d
--- /dev/null
+++ b/lua53.patch
@@ -0,0 +1,46 @@
+diff -aur old/src/luamm.cc new/src/luamm.cc
+--- old/src/luamm.cc 2015-06-28 16:38:47.793615922 -1000
++++ new/src/luamm.cc 2015-06-29 09:05:44.646667638 -1000
+@@ -165,7 +165,14 @@
+ }
+
+ template<void (*misc)(lua_State *, int), int nresults>
+- int safe_misc_trampoline(lua_State *l)
++ int safe_misc_trampoline_set(lua_State *l)
++ {
++ misc(l, 1);
++ return nresults;
++ }
++
++ template<int (*misc)(lua_State *, int), int nresults>
++ int safe_misc_trampoline_get(lua_State *l)
+ {
+ misc(l, 1);
+ return nresults;
+@@ -326,7 +333,7 @@
+ if( rawequal(index1, index2) )
+ return true;
+
+- return safe_compare(&safe_compare_trampoline<lua_equal>, index1, index2);
++ return safe_compare(&safe_compare_trampoline<&lua_equal>, index1, index2);
+ }
+
+ int state::gc(int what, int data)
+@@ -367,7 +374,7 @@
+ checkstack(2);
+ pushvalue(index);
+ insert(-2);
+- lua_pushcfunction(cobj.get(), (&safe_misc_trampoline<&lua_gettable, 1>));
++ lua_pushcfunction(cobj.get(), (&safe_misc_trampoline_get<&lua_gettable, 1>));
+ insert(-3);
+ call(2, 1, 0);
+ }
+@@ -492,7 +499,7 @@
+ checkstack(2);
+ pushvalue(index);
+ insert(-3);
+- lua_pushcfunction(cobj.get(), (&safe_misc_trampoline<&lua_settable, 0>));
++ lua_pushcfunction(cobj.get(), (&safe_misc_trampoline_set<&lua_settable, 0>));
+ insert(-4);
+ call(3, 0, 0);
+ }
diff --git a/xshape.patch b/xshape.patch
new file mode 100644
index 000000000000..990c32046642
--- /dev/null
+++ b/xshape.patch
@@ -0,0 +1,84 @@
+From d8d034f24154d08dfe558feccddfbed312d727d4 Mon Sep 17 00:00:00 2001
+From: Alexey Korop <avkorop@i.ua>
+Date: Sat, 24 Oct 2015 11:55:30 +0300
+Subject: Mouse transparency fix
+
+
+diff --git a/src/conky.cc b/src/conky.cc
+index b48fd7c..025ed20 100644
+--- a/src/conky.cc
++++ b/src/conky.cc
+@@ -60,6 +60,9 @@
+ #ifdef BUILD_IMLIB2
+ #include "imlib2.h"
+ #endif /* BUILD_IMLIB2 */
++#ifdef BUILD_XSHAPE
++#include <X11/extensions/shape.h>
++#endif /* BUILD_XSHAPE */
+ #endif /* BUILD_X11 */
+ #include <sys/types.h>
+ #include <sys/stat.h>
+@@ -2042,6 +2045,21 @@ static void main_loop(void)
+ sigaddset(&newmask, SIGUSR1);
+ #endif
+
++#ifdef BUILD_XSHAPE
++ /* allow only decorated windows to be given mouse input */
++ int major_version, minor_version;
++ if (!XShapeQueryVersion(display, &major_version, &minor_version)) {
++ NORM_ERR("Input shapes are not supported");
++ } else {
++ if (own_window.get(*state) &&
++ (own_window_type.get(*state) != TYPE_NORMAL ||
++ (TEST_HINT(own_window_hints.get(*state), HINT_UNDECORATED)))) {
++ XShapeCombineRectangles(display, window.window, ShapeInput, 0, 0,
++ NULL, 0, ShapeSet, Unsorted);
++ }
++ }
++#endif /* BUILD_XSHAPE */
++
+ last_update_time = 0.0;
+ next_update_time = get_time();
+ info.looped = 0;
+diff --git a/src/x11.cc b/src/x11.cc
+index 48f5197..15db872 100644
+--- a/src/x11.cc
++++ b/src/x11.cc
+@@ -47,10 +47,6 @@
+ #ifdef BUILD_XFT
+ #include <X11/Xft/Xft.h>
+ #endif
+-#ifdef BUILD_XSHAPE
+-#include <X11/extensions/shape.h>
+-#include <X11/extensions/shapeconst.h>
+-#endif
+
+ #ifdef BUILD_ARGB
+ bool have_argb_visual;
+@@ -716,26 +712,6 @@ static void init_window(lua::state &l __attribute__((unused)), bool own)
+
+ wmHint.flags = InputHint | StateHint;
+ /* allow decorated windows to be given input focus by WM */
+- wmHint.input =
+- TEST_HINT(hints, HINT_UNDECORATED) ? False : True;
+-#ifdef BUILD_XSHAPE
+- if (!wmHint.input) {
+- int event_base, error_base;
+- if (XShapeQueryExtension(display, &event_base, &error_base)) {
+- int major_version = 0, minor_version = 0;
+- XShapeQueryVersion(display, &major_version, &minor_version);
+- if ((major_version > 1) || ((major_version == 1) && (minor_version >=1))) {
+- Region empty_region = XCreateRegion();
+- XShapeCombineRegion(display, window.window, ShapeInput, 0, 0, empty_region, ShapeSet);
+- XDestroyRegion(empty_region);
+- } else {
+- NORM_ERR("Input shapes are not supported");
+- }
+- } else {
+- NORM_ERR("No shape extension found");
+- }
+- }
+-#endif
+ if (own_window_type.get(l) == TYPE_DOCK || own_window_type.get(l) == TYPE_PANEL) {
+ wmHint.initial_state = WithdrawnState;
+ } else {