summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Korop2015-11-26 22:32:01 +0200
committerAlexey Korop2015-11-26 22:32:01 +0200
commit8ef5497575c863e3c57d3bb540db0834c60af332 (patch)
tree2d5cae3b7b3a9002f696de5eb1f5da48c55af944
parent5286f9f6bf754fcef761e7ef9cc05472085445a1 (diff)
downloadaur-8ef5497575c863e3c57d3bb540db0834c60af332.tar.gz
Update to 1.10.1-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD21
-rw-r--r--ascii.patch12
-rw-r--r--curl.patch14
-rw-r--r--ipv6.patch28
5 files changed, 12 insertions, 80 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e8dbc56d4ee..1191864f75cb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = conky-mt
pkgdesc = Lightweight system monitor for X
- pkgver = 1.10.0
- pkgrel = 5
- url = http://conky.sourceforge.net/
+ pkgver = 1.10.1
+ pkgrel = 1
+ url = https://github.com/brndnmtthws/conky
arch = i686
arch = x86_64
license = BSD
@@ -11,6 +11,7 @@ pkgbase = conky-mt
makedepends = docbook2x
makedepends = docbook-xml
makedepends = man-db
+ makedepends = git
depends = glib2
depends = curl
depends = lua
@@ -23,18 +24,12 @@ pkgbase = conky-mt
conflicts = conky
options = !strip
options = debug
- source = https://github.com/brndnmtthws/conky/archive/v1.10.0.tar.gz
- source = ascii.patch
+ source = https://github.com/brndnmtthws/conky/archive/v1.10.1.tar.gz
source = lua53.patch
- source = ipv6.patch
- source = curl.patch
source = xshape.patch
source = execgraph.patch
- sha1sums = d5863420150150002947180d0ee96c9ef56c43b1
- sha1sums = 96cdbc38e8706c8a3120601983df5c7265716128
+ sha1sums = 97b59ec1daf54126b30516e8663a9cf1f218d8ae
sha1sums = a3a74542b6524e5663ad37aaba292b48e8bea3b1
- sha1sums = a0899973483d0ad664b60e58b3ba899ba88712af
- sha1sums = 1c066b439a1e7166d733fb710faa9bf08b81ce4c
sha1sums = 930f9d0313b7e32b895b75aa92be2cb128f957ed
sha1sums = 7615818bc255032dc4f5eeba9a2e009b9a7c177c
diff --git a/PKGBUILD b/PKGBUILD
index 92652ef074db..5e7c9c3c536f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,28 @@
# Patches 'execgraph.patch' and 'xshape.patch' by Alexey Korop added.
# Original package info:
-# $Id: PKGBUILD 246486 2015-09-17 21:01:11Z foutrelis $
+# $Id: PKGBUILD 251435 2015-11-19 21:45:56Z bisson $
# Maintainer: Gaetan Bisson <bisson@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: James Rayner <james@archlinux.org>
# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
pkgname=conky-mt
-pkgver=1.10.0
-pkgrel=5
+pkgver=1.10.1
+pkgrel=1
pkgdesc='Lightweight system monitor for X'
-url='http://conky.sourceforge.net/'
+url='https://github.com/brndnmtthws/conky'
license=('BSD' 'GPL')
arch=('i686' 'x86_64')
-makedepends=('cmake' 'docbook2x' 'docbook-xml' 'man-db')
+makedepends=('cmake' 'docbook2x' 'docbook-xml' 'man-db' 'git')
depends=('glib2' 'curl' 'lua' 'wireless_tools' 'libxml2' 'libxft' 'libxdamage' 'imlib2')
conflicts=('conky')
provides=('conky')
source=("https://github.com/brndnmtthws/conky/archive/v${pkgver}.tar.gz"
- 'ascii.patch'
'lua53.patch'
- 'ipv6.patch'
- 'curl.patch'
'xshape.patch'
'execgraph.patch')
-sha1sums=('d5863420150150002947180d0ee96c9ef56c43b1'
- '96cdbc38e8706c8a3120601983df5c7265716128'
+sha1sums=('97b59ec1daf54126b30516e8663a9cf1f218d8ae'
'a3a74542b6524e5663ad37aaba292b48e8bea3b1'
- 'a0899973483d0ad664b60e58b3ba899ba88712af'
- '1c066b439a1e7166d733fb710faa9bf08b81ce4c'
'930f9d0313b7e32b895b75aa92be2cb128f957ed'
'7615818bc255032dc4f5eeba9a2e009b9a7c177c')
@@ -37,10 +31,7 @@ options=('!strip' 'debug')
prepare() {
mv "${srcdir}/conky-${pkgver}" "${srcdir}/${pkgname}-${pkgver}"
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p1 -i ../ascii.patch # db2x_manxml fails on non-ascii chars
patch -p1 -i ../lua53.patch # lua_gettable returns an int in lua-5.3
- patch -p1 -i ../ipv6.patch # https://bugs.archlinux.org/task/45626
- patch -p1 -i ../curl.patch # https://github.com/bagder/curl/issues/342
patch -p1 -i ../xshape.patch # https://github.com/brndnmtthws/conky/issues/158
patch -p1 -i ../execgraph.patch # https://github.com/brndnmtthws/conky/issues/153
}
diff --git a/ascii.patch b/ascii.patch
deleted file mode 100644
index f04603f7d6c1..000000000000
--- a/ascii.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -aur old/doc/config_settings.xml new/doc/config_settings.xml
---- old/doc/config_settings.xml 2015-06-21 14:49:06.000000000 -1000
-+++ new/doc/config_settings.xml 2015-06-29 10:05:00.147318479 -1000
-@@ -80,7 +80,7 @@
- </term>
- <listitem>A comma-separated list of strings to use as the bars of a graph output
- to console/shell. The first list item is used for the minimum bar height and the
-- last item is used for the maximum. Example: " ,_,▁,▂,▃,▄,▅,▆,▇,█".
-+ last item is used for the maximum.
- <para /></listitem>
- </varlistentry>
- <varlistentry>
diff --git a/curl.patch b/curl.patch
deleted file mode 100644
index f5aad6532075..000000000000
--- a/curl.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -Naur old/src/ccurl_thread.cc new/src/ccurl_thread.cc
---- old/src/ccurl_thread.cc 2015-06-21 14:49:06.000000000 -1000
-+++ new/src/ccurl_thread.cc 2015-07-11 09:11:49.053040998 -1000
-@@ -119,9 +119,7 @@
- headers.h = curl_slist_append(headers.h, ("If-None-Match: " + etag).c_str());
- etag.clear();
- }
-- if (headers.h) {
-- curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
-- }
-+ curl_easy_setopt(curl, CURLOPT_HTTPHEADER, headers.h);
-
- res = curl_easy_perform(curl);
- if (res == CURLE_OK) {
diff --git a/ipv6.patch b/ipv6.patch
deleted file mode 100644
index 7135ae708308..000000000000
--- a/ipv6.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ee08a9e1b045e8d2f4f13a0e60c2f603b66b0d69 Mon Sep 17 00:00:00 2001
-From: Marc Payne <marc321@gmail.com>
-Date: Mon, 6 Jul 2015 02:51:43 -0600
-Subject: [PATCH] Close file only if it was successfully opened
-
-If BUILD_IPV6=ON (default), but the user has disabled ipv6 support
-in the kernel using the parameter ipv6.disable=1, then conky fails
-to open /proc/net/if_inet6. This leads to a segfault when conky
-calls fclose(file) regardless. This fix simply moves the fclose call
-into the preceding if statement.
----
- src/linux.cc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/linux.cc b/src/linux.cc
-index 847acac..7977fee 100644
---- a/src/linux.cc
-+++ b/src/linux.cc
-@@ -643,8 +643,8 @@ int update_net_stats(void)
- }
- lastv6->next = NULL;
- }
-+ fclose(file);
- }
-- fclose(file);
- #endif /* BUILD_IPV6 */
-
- first = 0;