summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Korop2015-07-07 19:25:43 +0300
committerAlexey Korop2015-07-07 19:25:43 +0300
commit906015f93b3871176e84423dbdff7b1a7bd219b2 (patch)
tree272dbdd6bfef2eaac6eb5155c9e58efc297312b3
downloadaur-906015f93b3871176e84423dbdff7b1a7bd219b2.tar.gz
Initial import
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD51
-rw-r--r--conky-mt.patch28
3 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e727af23a0e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = conky-mt
+ pkgdesc = Mouse-through conky based on /extra/conky package
+ pkgver = 1.9.0
+ pkgrel = 4
+ url = http://conky.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = GPL
+ makedepends = docbook2x
+ depends = glib2
+ depends = curl
+ depends = lua
+ depends = wireless_tools
+ depends = libxml2
+ depends = libxft
+ depends = libxdamage
+ depends = imlib2
+ provides = conky
+ conflicts = conky
+ options = !emptydirs
+ backup = etc/conky/conky.conf
+ backup = etc/conky/conky_no_x11.conf
+ source = http://downloads.sourceforge.net/project/conky/conky/1.9.0/conky-1.9.0.tar.gz
+ source = conky-mt.patch
+ sha1sums = a8d26d002370c9b877ae77ad3a3bbd2566b38e5d
+ sha1sums = d9b97d64849f96c5b0cdc82506ddc44081f0c210
+
+pkgname = conky-mt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..750463acb128
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Patched by Alexey Korop. Original package info:
+# $Id: PKGBUILD 205494 2014-02-06 05:24:01Z bisson $
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: James Rayner <james@archlinux.org>
+# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
+
+pkgname=conky-mt
+ORIG=conky
+pkgver=1.9.0
+pkgrel=4
+pkgdesc='Mouse-through conky based on /extra/conky package'
+url='http://conky.sourceforge.net/'
+license=('BSD' 'GPL')
+arch=('i686' 'x86_64')
+makedepends=('docbook2x')
+conflicts=('conky')
+provides=('conky')
+depends=('glib2' 'curl' 'lua' 'wireless_tools' 'libxml2' 'libxft' 'libxdamage' 'imlib2')
+source=("http://downloads.sourceforge.net/project/${ORIG}/${ORIG}/${pkgver}/${ORIG}-${pkgver}.tar.gz"
+ 'conky-mt.patch')
+sha1sums=('a8d26d002370c9b877ae77ad3a3bbd2566b38e5d'
+ 'd9b97d64849f96c5b0cdc82506ddc44081f0c210')
+
+backup=('etc/conky/'conky{,_no_x11}.conf)
+options=('!emptydirs')
+
+build() {
+ cd "${srcdir}/${ORIG}-${pkgver}"
+ patch -p1 < ../../conky-mt.patch
+
+ CPPFLAGS="${CXXFLAGS}" LIBS="${LDFLAGS}" ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-ibm \
+ --enable-curl \
+ --enable-rss \
+ --enable-weather-xoap \
+ --enable-imlib2 \
+ --enable-wlan \
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${ORIG}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${ORIG}/LICENSE"
+ install -Dm644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
+ install -Dm644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
+}
diff --git a/conky-mt.patch b/conky-mt.patch
new file mode 100644
index 000000000000..1fe9cb296201
--- /dev/null
+++ b/conky-mt.patch
@@ -0,0 +1,28 @@
+--- a/src/conky.c 2012-05-04 00:22:21.000000000 +0300
++++ b/src/conky.c 2015-01-24 22:57:05.018893944 +0200
+@@ -137,6 +137,8 @@
+ #include "conf_cookie.h"
+ #endif
+
++#include <X11/extensions/shape.h>
++
+ #ifndef S_ISSOCK
+ #define S_ISSOCK(x) ((x & S_IFMT) == S_IFSOCK)
+ #endif
+@@ -3492,6 +3494,16 @@
+ last_update_time = 0.0;
+ next_update_time = get_time();
+ info.looped = 0;
++
++ if (own_window &&
++ (( window.type != TYPE_NORMAL ||
++ (TEST_HINT(window.hints, HINT_UNDECORATED))) &&
++ window.type != TYPE_DESKTOP)) {
++ /* set the empty input shape, i.e. make the window "mouse-through" */
++ XShapeCombineRectangles(display, window.window, ShapeInput, 0, 0,
++ NULL, 0, ShapeSet, Unsorted);
++ }
++
+ while (terminate == 0 && (total_run_times == 0 || info.looped < total_run_times)) {
+ if(update_interval_bat != NOBATTERY && update_interval_bat != update_interval_old) {
+ char buf[max_user_text];