summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2015-07-20 20:13:15 +0300
committerSpyros Stathopoulos2015-07-20 20:13:15 +0300
commitb5c4a384411c4557624e0d45ad783b6f41da3a6b (patch)
treed882419c8d751766fedffe2d6d5507a0f74162f8
downloadaur-b5c4a384411c4557624e0d45ad783b6f41da3a6b.tar.gz
Initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD58
-rw-r--r--conky-lua-nv.install9
4 files changed, 114 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11e9cad1d4d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = conky19-lua-nv
+ pkgdesc = An advanced system monitor for X based on torsmo with lua and nvidia enabled
+ pkgver = 1.9.0
+ pkgrel = 7
+ url = http://conky.sourceforge.net/
+ install = conky-lua-nv.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = pkgconfig
+ makedepends = tolua++
+ makedepends = libxnvctrl
+ makedepends = docbook-xml
+ makedepends = docbook-xsl
+ depends = alsa-lib
+ depends = libxml2
+ depends = curl
+ depends = cairo
+ depends = wireless_tools
+ depends = libxft
+ depends = glib2
+ depends = libxdamage
+ depends = imlib2
+ depends = lua51
+ optdepends = nvidia: for GT4xx and newer GPUs,
+ optdepends = nvidia-340xx: for G8x, G9x, GT2xx GPUS,
+ optdepends = nvidia-304xx: for GeForce 6/7 GPUs
+ provides = conky
+ provides = conky-lua
+ conflicts = conky
+ replaces = torsmo
+ replaces = conky
+ backup = etc/conky/conky.conf
+ backup = etc/conky/conky_no_x11.conf
+ source = https://github.com/brndnmtthws/conky/archive/1.9.0.tar.gz
+ md5sums = b13f2c7d52e18d94bfbfcd5157406db7
+
+pkgname = conky19-lua-nv
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e50d7f964192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!*.patch
+!*.diff
+!*.install
+!*.service
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d251d50b8d72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Jon Wilson <bugs@pandorica.net>
+# Contributor: Spyros Stathopoulos <foucault.online[at]gmail[dot]com>
+# Contributor: Andrwe Lord Weber <lord-weber-andrwe [at] andrwe [dot] org>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: James Rayner <james@archlinux.org>
+# Contributor: Partha Chowdhury <kira.laucas@gmail.com>
+
+pkgname=conky19-lua-nv
+_pkgname=conky
+pkgver=1.9.0
+pkgrel=7
+pkgdesc="An advanced system monitor for X based on torsmo with lua and nvidia enabled"
+arch=('i686' 'x86_64')
+url="http://conky.sourceforge.net/"
+license=('custom')
+replaces=('torsmo' 'conky')
+conflicts=('conky')
+provides=('conky' 'conky-lua')
+depends=('alsa-lib' 'libxml2' 'curl' 'cairo' 'wireless_tools' 'libxft' 'glib2' 'libxdamage' 'imlib2' 'lua51')
+makedepends=('pkgconfig' 'tolua++' 'libxnvctrl' 'docbook-xml' 'docbook-xsl')
+optdepends=('nvidia: for GT4xx and newer GPUs',
+ 'nvidia-340xx: for G8x, G9x, GT2xx GPUS',
+ 'nvidia-304xx: for GeForce 6/7 GPUs')
+backup=(etc/conky/conky.conf etc/conky/conky_no_x11.conf)
+source=(https://github.com/brndnmtthws/${_pkgname}/archive/${pkgver}.tar.gz)
+md5sums=('b13f2c7d52e18d94bfbfcd5157406db7')
+install="conky-lua-nv.install"
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ sed -i '/#include <curl\/types.h>/d' ${srcdir}/${_pkgname}-${pkgver}/src/ccurl_thread.c
+ ./autogen.sh
+ LUA51_LIBS='-llua5.1 -lm' LUA51_CFLAGS='-I/usr/include/lua5.1' \
+ LUA_LIBS='-llua5.1 -lm' LUA_CFLAGS="-I/usr/include/lua5.1" \
+ CPPFLAGS="${CXXFLAGS}" LIBS="${LDFLAGS}" ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-wlan \
+ --enable-rss \
+ --enable-ibm \
+ --enable-imlib2 \
+ --enable-lua \
+ --enable-lua-cairo \
+ --enable-lua-imlib2 \
+ --enable-ibm \
+ --enable-nvidia
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+ install -D -m644 COPYING ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE
+ install -D -m644 extras/vim/syntax/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/syntax/conkyrc.vim
+ install -D -m644 extras/vim/ftdetect/conkyrc.vim "${pkgdir}"/usr/share/vim/vimfiles/ftdetect/conkyrc.vim
+}
+
+# vim:ts=2:et:sw=2
diff --git a/conky-lua-nv.install b/conky-lua-nv.install
new file mode 100644
index 000000000000..51ce4095b04a
--- /dev/null
+++ b/conky-lua-nv.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "You must install one of the nvidia packages suitable"
+ echo "for your GPU for the nvidia support to properly work"
+}
+
+post_upgrade() {
+ post_install $1
+}
+