summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Manuel2015-09-07 01:39:18 -0500
committerCarlos Manuel2015-09-07 01:39:18 -0500
commit0d3b92db102d9e6d45a14048dfd116679257bacf (patch)
treeedbd07434a522f92ac53ac26d50df3be49ec2fec
downloadaur-0d3b92db102d9e6d45a14048dfd116679257bacf.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD39
-rwxr-xr-xconlie.install35
-rwxr-xr-xlie4
-rwxr-xr-xlie.127
5 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d46534dabce5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = conlie
+ pkgdesc = A Computer algebra package for Lie group computations
+ pkgver = 2.2.2
+ pkgrel = 2
+ url = http://www-math.univ-poitiers.fr/~maavl/LiE/
+ install = conlie.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = readline
+ source = http://www-math.univ-poitiers.fr/~maavl/LiE/conLiE.tar.gz
+ source = lie
+ source = lie.1
+ md5sums = 2e98f252364d43557a322ea7eb677944
+ md5sums = d4f5ad8b87479ef93734eee6d1629190
+ md5sums = a47060395617ed656eaccde1a9e9ee93
+
+pkgname = conlie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..5ed394bf516f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Dariusz 'quasi' Panchyrz <quasi@aur.archlinux.org>
+
+pkgname=conlie
+pkgver=2.2.2
+pkgrel=2
+pkgdesc="A Computer algebra package for Lie group computations"
+arch=('i686' 'x86_64')
+url="http://www-math.univ-poitiers.fr/~maavl/LiE/"
+license=('LGPL')
+depends=(readline)
+install=$pkgname.install
+source=(http://www-math.univ-poitiers.fr/~maavl/LiE/conLiE.tar.gz lie lie.1)
+md5sums=('2e98f252364d43557a322ea7eb677944'
+ 'd4f5ad8b87479ef93734eee6d1629190'
+ 'a47060395617ed656eaccde1a9e9ee93')
+
+build() {
+ cd LiE
+
+ make
+}
+
+package() {
+ cd LiE
+
+ install -D Lie.exe $pkgdir/usr/bin/Lie.exe
+ install -D $srcdir/lie $pkgdir/usr/bin/lie
+
+ mkdir -p $pkgdir/usr/lib/lie
+ for i in INFO.* LEARN.ind
+ do
+ cp $i $pkgdir/usr/lib/lie/
+ done
+
+ install -D manual/manual.dvi $pkgdir/usr/share/doc/lie/manual.dvi
+ install -D README $pkgdir/usr/share/doc/lie-2.2.2/README
+
+ install -D $srcdir/lie.1 $pkgdir/usr/share/man/man1/lie.1
+}
diff --git a/conlie.install b/conlie.install
new file mode 100755
index 000000000000..843f01a310f2
--- /dev/null
+++ b/conlie.install
@@ -0,0 +1,35 @@
+# arg 1: the new package version
+pre_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+post_install() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ /bin/true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ post_install
+}
+
+# arg 1: the old package version
+pre_remove() {
+ /bin/true
+}
+
+# arg 1: the old package version
+post_remove() {
+ /bin/true
+}
+
+op=$1
+shift
+$op $*
diff --git a/lie b/lie
new file mode 100755
index 000000000000..54fa7895ed08
--- /dev/null
+++ b/lie
@@ -0,0 +1,4 @@
+#!/bin/sh
+PTH=`which ${0} | sed -e 's/bin\/lie//'`
+
+exec ${PTH}/bin/Lie.exe initfile ${PTH}/lib/lie
diff --git a/lie.1 b/lie.1
new file mode 100755
index 000000000000..10bf50db6270
--- /dev/null
+++ b/lie.1
@@ -0,0 +1,27 @@
+.TH LIE 1 "December 12, 2006" "" ""
+
+.SH NAME
+LiE - A computer algebra package for Lie group computations
+.SH SYNOPSIS
+.BR "lie"
+.SH DESCRIPTION
+.B LiE
+LiE is a computer algebra system that is specialised in computations
+involving (reductive) Lie groups and their representations.
+
+Full documentation about the program and the underlying mathematics
+can be found in /usr/share/doc/lie/manual.dvi.
+
+Run-time help can be obtained by typing '?' for a list of help entries
+or '?help' for help information.
+
+See the web page at
+.BR "http://young.sp2mi.univ-poitiers.fr/~marc/LiE/"
+for the CWEBx source code.
+.SH AUTHORS
+LiE was written by Arjeh M. Cohen <amc@win.tue.nl>, Marc van Leeuwen
+<maavl@mathlabo.univ-poitiers.fr> and Bert Lisser.
+.PP
+This manual page was written by Kasper Peeters
+<kasper.peeters@aei.mpg.de>, for the Debian project (but may be used
+by others).