summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2018-06-13 17:01:29 -0400
committerChris Severance2018-06-13 17:01:29 -0400
commit8a18dd275b71ade2836ebd7ccff497113a6f8f68 (patch)
treecb2be61f162a71af4b5131d515396e655a4b2a93
parent6edabf53c990790156c4a0fef49661e3c1afcb81 (diff)
downloadaur-8a18dd275b71ade2836ebd7ccff497113a6f8f68.tar.gz
autu: Update to 1.42-1
-rw-r--r--.SRCINFO10
-rw-r--r--0000-Kernel-4-15-timers.patch102
-rw-r--r--PKGBUILD12
3 files changed, 6 insertions, 118 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c91b8da09cc1..4d136bc3a09d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 8 00:27:40 UTC 2018
+# Wed Jun 13 21:01:28 UTC 2018
pkgbase = connecttech-cti-serial
pkgdesc = tty UART driver for BlueStorm BlueHeat Xtreme/104-Plus Titan and Xtreme/104-Express families
- pkgver = 1.41
+ pkgver = 1.42
pkgrel = 1
url = http://connecttech.com/product/pci-express-bluestorm-express/
install = connecttech-cti-serial-install.sh
@@ -14,10 +14,8 @@ pkgbase = connecttech-cti-serial
depends = dkms
depends = linux-headers
backup = etc/cti-serial-set485.sh
- source = file://cti_serial_141.tgz
- source = 0000-Kernel-4-15-timers.patch
- sha256sums = d5e7781d518091c817624f0d7e681180ff871fa535ec70e92795e90bdd54d44c
- sha256sums = 928ac0a2e815bbfae2041b095b7eab27ff3df825b31e8108f4ac92fb1fc8379d
+ source = file://cti_serial_142.tgz
+ sha256sums = 9833dfcac4b9116c1d22dcee16bb0533e7b3ab0ae3291c4570e716e1e991f042
pkgname = connecttech-cti-serial
diff --git a/0000-Kernel-4-15-timers.patch b/0000-Kernel-4-15-timers.patch
deleted file mode 100644
index 1573a81332ee..000000000000
--- a/0000-Kernel-4-15-timers.patch
+++ /dev/null
@@ -1,102 +0,0 @@
-diff -pNaru5 cti_serial_141.orig-0000/driver/8250_core.c cti_serial_141/driver/8250_core.c
---- cti_serial_141.orig-0000/driver/8250_core.c 2018-01-05 16:13:47.000000000 -0500
-+++ cti_serial_141/driver/8250_core.c 2018-06-04 23:13:10.415314127 -0400
-@@ -2498,21 +2498,33 @@ static void serial_unlink_irq_chain(stru
- * This function is used to handle ports that do not have an
- * interrupt. This doesn't work very well for 16450's, but gives
- * barely passable results for a 16550A. (Although at the expense
- * of much CPU overhead).
- */
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(4,15,0))
- static void serial8250_timeout(unsigned long data)
- {
- struct uart_8250_port *up = (struct uart_8250_port *)data;
-+#else
-+static void serial8250_timeout(struct timer_list *tl)
-+{
-+ struct uart_8250_port *up = from_timer(up,tl,timer);
-+#endif
-
- up->port.handle_irq(&up->port);
- mod_timer(&up->timer, jiffies + uart_poll_timeout(&up->port));
- }
-
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(4,15,0))
- static void serial8250_backup_timeout(unsigned long data)
- {
- struct uart_8250_port *up = (struct uart_8250_port *)data;
-+#else
-+static void serial8250_backup_timeout(struct timer_list *tl)
-+{
-+ struct uart_8250_port *up = from_timer(up,tl,timer);
-+#endif
- unsigned int iir, ier = 0, lsr;
- unsigned long flags;
-
- spin_lock_irqsave(&up->port.lock, flags);
-
-@@ -2919,12 +2931,16 @@ static int serial8250_startup(struct uar
- /*
- * The above check will only give an accurate result the first time
- * the port is opened so this value needs to be preserved.
- */
- if (up->bugs & UART_BUG_THRE) {
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(4,15,0))
- up->timer.function = serial8250_backup_timeout;
- up->timer.data = (unsigned long)up;
-+#else
-+ timer_setup(&up->timer,serial8250_backup_timeout,0);
-+#endif
- mod_timer(&up->timer, jiffies +
- uart_poll_timeout(port) + HZ / 5);
- }
-
- if ( (up->port.type == PORT_XR17XX5X) || (up->port.type == PORT_XR17V35X) ) {
-@@ -2957,11 +2973,13 @@ static int serial8250_startup(struct uar
- * If the "interrupt" for this port doesn't correspond with any
- * hardware interrupt, we use a timer-based system. The original
- * driver used to do this with IRQ0.
- */
- if (!is_real_interrupt(up->port.irq)) {
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(4,15,0))
- up->timer.data = (unsigned long)up;
-+#endif
- mod_timer(&up->timer, jiffies + uart_poll_timeout(port));
- } else {
- retval = serial_link_irq_chain(up);
- if (retval)
- return retval;
-@@ -3120,11 +3138,15 @@ static void serial8250_shutdown(struct u
- * the IRQ chain.
- */
- serial_port_in(port, UART_RX);
-
- del_timer_sync(&up->timer);
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(4,15,0))
- up->timer.function = serial8250_timeout;
-+#else
-+ timer_setup(&up->timer,serial8250_timeout,0);
-+#endif
- if (port->irq){
- serial_unlink_irq_chain(up);
- }
- }
-
-@@ -3937,13 +3959,16 @@ static void __init serial8250_isa_init_p
- struct uart_8250_port *up = &serial8250_ports[i];
- struct uart_port *port = &up->port;
-
- port->line = i;
- spin_lock_init(&port->lock);
--
-+#if (LINUX_VERSION_CODE < KERNEL_VERSION(4,15,0))
- init_timer(&up->timer);
- up->timer.function = serial8250_timeout;
-+#else
-+ timer_setup(&up->timer,serial8250_timeout,0);
-+#endif
- up->cur_iotype = 0xFF;
-
- /*
- * ALPHA_KLUDGE_MCR needs to be killed.
- */
diff --git a/PKGBUILD b/PKGBUILD
index 9bc6f09a1d88..ef088c02b48b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,7 @@ _opt_DKMS=1 # This can be toggled between installs
set -u
pkgname='connecttech-cti-serial'
-pkgver='1.41'
+pkgver='1.42'
pkgrel='1'
pkgdesc='tty UART driver for BlueStorm BlueHeat Xtreme/104-Plus Titan and Xtreme/104-Express families'
arch=('i686' 'x86_64')
@@ -31,10 +31,8 @@ install="${pkgname}-install.sh"
_srcdir="cti_serial_${pkgver//./}"
source=(
"file://${_srcdir}.tgz"
- '0000-Kernel-4-15-timers.patch'
)
-sha256sums=('d5e7781d518091c817624f0d7e681180ff871fa535ec70e92795e90bdd54d44c'
- '928ac0a2e815bbfae2041b095b7eab27ff3df825b31e8108f4ac92fb1fc8379d')
+sha256sums=('9833dfcac4b9116c1d22dcee16bb0533e7b3ab0ae3291c4570e716e1e991f042')
if [ "${_opt_DKMS}" -ne 0 ]; then
depends+=('linux' 'dkms' 'linux-headers')
@@ -92,12 +90,6 @@ prepare() {
sed -e 's: /lib/modules: /usr/lib/modules:g' -i 'Makefile'
popd > /dev/null
-
- # Patch
- #cp -pr "${srcdir}/${_srcdir}"{,.orig-0000}
- #diff -pNaru5 cti_serial_141{.orig-0000,} > '0000-Kernel-4-15-timers.patch'
- patch -Nup1 -i "${srcdir}/0000-Kernel-4-15-timers.patch"
-
set +u
}