summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGreg2018-12-01 21:54:30 -0500
committerGreg2018-12-01 21:54:30 -0500
commit2b2c374c1e9c9f6ae311602c73e2ce037597883b (patch)
tree82e3cfc02cfd51880a9c01679ff677db0a62c176
downloadaur-2b2c374c1e9c9f6ae311602c73e2ce037597883b.tar.gz
Start
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
-rw-r--r--connman-gtk-git.install13
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cb179fc34d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = connman-gtk-git
+ pkgdesc = Tray menu and GUI for connman
+ pkgver = v1.1.1.r11.gb72c6ab
+ pkgrel = 1
+ url = https://github.com/jgke/connman-gtk
+ install = connman-gtk-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = meson
+ makedepends = git
+ makedepends = openconnect
+ depends = glib2
+ depends = gtk3
+ optdepends = openconnect: Easier authentication to AnyConnect VPNs
+ conflicts = connman-gtk
+ source = git+https://github.com/jgke/connman-gtk.git
+ sha256sums = SKIP
+
+pkgname = connman-gtk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b11df7a6e42c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gregory Petrosyan <gregory.mkv at gmail.com>
+pkgname=connman-gtk-git
+pkgver=v1.1.1.r11.gb72c6ab
+pkgrel=1
+pkgdesc="Tray menu and GUI for connman"
+arch=('i686' 'x86_64')
+url="https://github.com/jgke/connman-gtk"
+license=('GPL')
+depends=('glib2' 'gtk3')
+makedepends=('intltool' 'meson' 'git' 'openconnect')
+optdepends=('openconnect: Easier authentication to AnyConnect VPNs')
+conflicts=('connman-gtk')
+install=$pkgname.install
+source=("git+https://github.com/jgke/connman-gtk.git")
+sha256sums=('SKIP')
+
+build() {
+ mkdir build
+ meson --prefix /usr --buildtype=plain -Duse_openconnect=dynamic "${srcdir}/connman-gtk" build
+ ninja -C build
+}
+
+pkgver() {
+ cd connman-gtk
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}
+
diff --git a/connman-gtk-git.install b/connman-gtk-git.install
new file mode 100644
index 000000000000..bf6781f93005
--- /dev/null
+++ b/connman-gtk-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas/
+ gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}