summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitrij Podabed2015-11-04 20:14:09 +0700
committerDmitrij Podabed2015-11-04 20:14:09 +0700
commit3a6924af8fdbbad1c4fd9b1daa4c814625d09237 (patch)
treeee9e21a128563e39107dac3289d7f7ead1492db5
downloadaur-3a6924af8fdbbad1c4fd9b1daa4c814625d09237.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15c94dcf1b6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = connman-ncurses
+ pkgdesc = Simple ncurses UI for ConnMan
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/eurogiciel-oss/connman-json-client
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = json-c
+ depends = ncurses
+ depends = connman
+ provides = connman-ncurses=1.0
+ source = git://github.com/eurogiciel-oss/connman-json-client/commit/cb0f024e8741b9d5765a1b6fe85c755dfb1515d7.git
+ sha256sums = SKIP
+
+pkgname = connman-ncurses
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cae828e667b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Submitter: Dmitrij Podabed <dmitrij at podabed dot org>
+# Maintainer: Dmitrij Podabed <dmitrij at podabed dot org>
+pkgname=connman-ncurses
+pkgver=1.0
+pkgrel=1
+pkgdesc="Simple ncurses UI for ConnMan"
+arch=('any')
+url="https://github.com/eurogiciel-oss/connman-json-client"
+license=('GPL2')
+depends=('json-c' 'ncurses' 'connman')
+makedepends=('git')
+provides=("$pkgname=$pkgver")
+source=("git://github.com/eurogiciel-oss/connman-json-client/commit/cb0f024e8741b9d5765a1b6fe85c755dfb1515d7.git")
+sha256sums=("SKIP")
+
+_gitroot="connman-json-client"
+
+build() {
+ cd "$srcdir/$_gitroot"
+ ./run-me.sh
+}
+
+package() {
+ install -Dm733 "$srcdir/$_gitroot/connman_ncurses" "$pkgdir/usr/bin/$_pkgname"
+} \ No newline at end of file