summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDobroslaw Kijowski2015-11-23 20:07:29 +0100
committerDobroslaw Kijowski2015-11-23 20:07:29 +0100
commite367b16e3e61b274ec532b73fd0c701b6942078e (patch)
treec7c52f4e134f0623a25164d0f0a714ecf497d2b9
parent3a6924af8fdbbad1c4fd9b1daa4c814625d09237 (diff)
downloadaur-e367b16e3e61b274ec532b73fd0c701b6942078e.tar.gz
* Download tarball instead of cloning git repository.
* Remove already resolved dependencies. * Don't compile with debug symbols.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD44
2 files changed, 32 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15c94dcf1b6d..733ee9570b0f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = connman-ncurses
pkgdesc = Simple ncurses UI for ConnMan
pkgver = 1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/eurogiciel-oss/connman-json-client
- arch = any
+ arch = i686
+ arch = x86_64
license = GPL2
- makedepends = git
depends = json-c
- depends = ncurses
depends = connman
- provides = connman-ncurses=1.0
- source = git://github.com/eurogiciel-oss/connman-json-client/commit/cb0f024e8741b9d5765a1b6fe85c755dfb1515d7.git
- sha256sums = SKIP
+ conflicts = connman-ncurses-git
+ source = https://github.com/eurogiciel-oss/connman-json-client/archive/v1.0.tar.gz
+ md5sums = 26f23eaa1828e2d7a45fce94e1a06203
pkgname = connman-ncurses
diff --git a/PKGBUILD b/PKGBUILD
index cae828e667b7..64a249cc50cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# Submitter: Dmitrij Podabed <dmitrij at podabed dot org>
+# Submitter : Dobroslaw Kijowski <dobo90 at gmail dot com>
# Maintainer: Dmitrij Podabed <dmitrij at podabed dot org>
+# Maintainer: Dmitrij Podabed <dmitrij at podabed dot org>
+
pkgname=connman-ncurses
+_pkgname=connman-json-client
pkgver=1.0
-pkgrel=1
-pkgdesc="Simple ncurses UI for ConnMan"
-arch=('any')
-url="https://github.com/eurogiciel-oss/connman-json-client"
-license=('GPL2')
-depends=('json-c' 'ncurses' 'connman')
-makedepends=('git')
-provides=("$pkgname=$pkgver")
-source=("git://github.com/eurogiciel-oss/connman-json-client/commit/cb0f024e8741b9d5765a1b6fe85c755dfb1515d7.git")
-sha256sums=("SKIP")
+pkgrel=2
+pkgdesc='Simple ncurses UI for ConnMan'
+arch=(i686 x86_64)
+url='https://github.com/eurogiciel-oss/connman-json-client'
+license=(GPL2)
+depends=(json-c connman)
+conflicts=(connman-ncurses-git)
+source=("https://github.com/eurogiciel-oss/${_pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=(26f23eaa1828e2d7a45fce94e1a06203)
-_gitroot="connman-json-client"
+build()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
-build() {
- cd "$srcdir/$_gitroot"
- ./run-me.sh
+ autoreconf -i
+ # it doesn't compile without --disable-optimization flag
+ ./configure --prefix='/usr' --disable-optimization
+ make
}
-package() {
- install -Dm733 "$srcdir/$_gitroot/connman_ncurses" "$pkgdir/usr/bin/$_pkgname"
-} \ No newline at end of file
+package()
+{
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ install -D -m 755 connman_ncurses "${pkgdir}/usr/bin/${pkgname}"
+}