summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka2022-06-26 21:21:00 +0200
committerJakub Jirutka2022-06-26 21:21:00 +0200
commita016891c1429eda9e08d64c11bcd049189f36b97 (patch)
treebeee40989e2c958cc9eb9aec15adc91b2c4896b4
downloadaur-a016891c1429eda9e08d64c11bcd049189f36b97.tar.gz
Import package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a33d6869cfda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = connman-resolvconf
+ pkgdesc = ConnMan integration with resolvconf(8)
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/jirutka/connman-resolvconf
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ depends = connman
+ depends = dbus
+ depends = gcc-libs
+ depends = openresolv
+ source = https://github.com/jirutka/connman-resolvconf/archive/v0.1.0/connman-resolvconf-0.1.0.tar.gz
+ sha512sums = a07ea50e0e1d0c12c60b59dfcbdedabdaacc6d336ea72bbe608558ad79d687f641e4fa08e9efd74e1761b07b938fd202214b0c0770f8bfffda4f3daae7e93765
+
+pkgname = connman-resolvconf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e3fe8c559ee2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+
+pkgname=connman-resolvconf
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="ConnMan integration with resolvconf(8)"
+arch=('x86_64')
+url="https://github.com/jirutka/connman-resolvconf"
+license=('MIT')
+depends=('connman' 'dbus' 'gcc-libs' 'openresolv')
+makedepends=('cargo')
+source=("https://github.com/jirutka/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('a07ea50e0e1d0c12c60b59dfcbdedabdaacc6d336ea72bbe608558ad79d687f641e4fa08e9efd74e1761b07b938fd202214b0c0770f8bfffda4f3daae7e93765')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --offline
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 -t "$pkgdir"/usr/sbin target/release/connman-resolvconfd
+ install -Dm644 -t "$pkgdir"/usr/lib/systemd/system contrib/systemd/connman-resolvconf.service
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}