summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-05-01 15:26:43 +0200
committerMarcell Meszaros2022-05-01 15:26:43 +0200
commitd8f83099479ebfa8e65bbf46654bd1d27c7867f7 (patch)
treec671ac264ca912098612a0b938e7dd27f2d717da
parenteb0b6f65cedea61344d930c8cae3575bb3bd57b9 (diff)
downloadaur-conoha-iso-git.tar.gz
fix build, add provides and conflicts
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97795d0597c3..b299ce808159 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,8 @@ pkgbase = conoha-iso-git
license = MIT
makedepends = go
makedepends = git
+ provides = conoha-iso
+ conflicts = conoha-iso
source = git+https://github.com/hironobu-s/conoha-iso.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 23010b00f8af..0896d4a2c258 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,8 @@ arch=(x86_64)
url="https://github.com/hironobu-s/conoha-iso"
license=('MIT')
makedepends=(go git)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
source=("git+https://github.com/hironobu-s/conoha-iso.git")
md5sums=('SKIP')
@@ -22,6 +24,9 @@ pkgver() {
prepare() {
mkdir -p gopath/src/github.com/$_pkgname
ln -rTsf $_pkgname gopath/src/github.com/$_pkgname/$_pkgname
+
+ cd gopath/src/github.com/$_pkgname/$_pkgname
+ go get "${url#https://}" # strip https:// from canonical URL
}
build() {