summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhidenkov2016-10-24 11:34:52 +0300
committerAndrey Zhidenkov2016-10-24 11:34:52 +0300
commiteae81ae1dc780885a391a08a41e809caef4df5c0 (patch)
tree4b758de24db60f86fc8f01672ca74f28d7995369
downloadaur-eae81ae1dc780885a391a08a41e809caef4df5c0.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD16
-rw-r--r--consolas-fonts.install11
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df5825e21122
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = consolas-fonts
+ pkgdesc = Consolas fonts
+ pkgver = 1.1
+ pkgrel = 1
+ install = consolas-fonts.install
+ arch = any
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = https://github.com/pensnarik/consolas-fonts/raw/master/consolas-fonts-tts.tar.bz2
+ md5sums = 728dfa03f8d86ef82a31d145b42a32c7
+
+pkgname = consolas-fonts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35b1d7ce5588
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: Andrey Zhidenkov <pensnarik@gmail.com>
+
+pkgname=consolas-fonts
+pkgver=1.1
+pkgrel=1
+pkgdesc="Consolas fonts"
+arch=(any)
+depends=(fontconfig xorg-font-utils)
+source=("https://github.com/pensnarik/$pkgname/raw/master/consolas-fonts-tts.tar.bz2")
+install=$pkgname.install
+md5sums=('728dfa03f8d86ef82a31d145b42a32c7')
+
+package() {
+ install -dm 755 "${pkgdir}"/usr/share/fonts/TTF
+ install -Dm644 *.ttf "$pkgdir"/usr/share/fonts/TTF
+} \ No newline at end of file
diff --git a/consolas-fonts.install b/consolas-fonts.install
new file mode 100644
index 000000000000..1d8966f45ac0
--- /dev/null
+++ b/consolas-fonts.install
@@ -0,0 +1,11 @@
+post_install() {
+ fc-cache -s
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}