summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-08-13 03:09:14 +0300
committerDimitris Kiziridis2020-08-13 03:09:14 +0300
commit342a5343619bffbdb40c5faf04457950161f0174 (patch)
tree49b6ed983bface7325039822a016467dd591ebc3
downloadaur-342a5343619bffbdb40c5faf04457950161f0174.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
-rw-r--r--icon.pngbin0 -> 36745 bytes
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3640acc33ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = constellation
+ pkgdesc = A graph-focused data visualisation and interactive analysis application
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://constellation-app.com
+ arch = x86_64
+ license = Apache
+ depends = java-runtime
+ depends = libnet
+ depends = lib32-glibc
+ depends = gtk3
+ depends = gtk2
+ source = constellation-2.0.0.tar.gz::https://github.com/constellation-app/constellation/releases/download/v2.0.0/constellation-linux-v2.0.0.tar.gz
+ source = icon.png
+ sha256sums = 0ce920db6309b4418de4644aa21f4fa2ef7252ec828293f70b5fd6b10c24bb85
+ sha256sums = SKIP
+
+pkgname = constellation
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51aa269870d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=constellation
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A graph-focused data visualisation and interactive analysis application"
+arch=('x86_64')
+url='https://constellation-app.com'
+license=('Apache')
+depends=('java-runtime'
+ 'libnet'
+ 'lib32-glibc'
+ 'gtk3'
+ 'gtk2')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/constellation-app/constellation/releases/download/v${pkgver}/constellation-linux-v${pkgver}.tar.gz"
+ 'icon.png')
+sha256sums=('0ce920db6309b4418de4644aa21f4fa2ef7252ec828293f70b5fd6b10c24bb85'
+ 'SKIP')
+
+package() {
+ install -d "${pkgdir}/opt"
+ cp -avR constellation "${pkgdir}/opt"
+ install -Dm644 icon.png "${pkgdir}/usr/share/pixmaps/constellation.png"
+ gendesk -f -n --pkgname "${pkgname}" \
+ --pkgdesc "$pkgdesc" \
+ --name "Constellation" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname}" \
+ --categories 'Utility;Development;Science;Application' \
+ --icon "${pkgname}"
+ install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ echo "#!/usr/bin/env bash
+ cd /opt/constellation/bin
+ ./constellation
+ " > "${pkgname}.sh"
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/constellation"
+} \ No newline at end of file
diff --git a/icon.png b/icon.png
new file mode 100644
index 000000000000..845922d8e4b7
--- /dev/null
+++ b/icon.png
Binary files differ