summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConstantin Nickel2019-06-07 05:02:11 +0200
committerConstantin Nickel2019-06-07 05:02:11 +0200
commit64f6348a4c7df4cbfd03ca748436bd305c604bbc (patch)
tree3f61f7315be3186fce4973cbf73c9c126de72f69
parentb6cf28c3d896f778c35757da7eba64a101b88647 (diff)
downloadaur-64f6348a4c7df4cbfd03ca748436bd305c604bbc.tar.gz
use DOSBOX_CMD env var
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--constructor-gog.sh6
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cefa33ae2a3e..daf93ce0a95f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = constructor-gog
pkgdesc = Control a construction company, and aim to drive the other players out of business.
pkgver = 1.0_cs
- pkgrel = 1
+ pkgrel = 2
url = https://www.gog.com/game/constructor
install = constructor-gog.install
arch = any
@@ -22,7 +22,7 @@ pkgbase = constructor-gog
source = dosbox_ipx.conf
source = fix-permissions.sh
sha256sums = 35fcb4970635309697812a6ca9195194ed2e6d0ffa0f70669cb10b6d2845e835
- sha256sums = bce1e648feb9e15bcbc33f7dec9a290a01c224a083801d258d9db36f4314c92b
+ sha256sums = 34d7224ec640ff37dc26d894eb56a6a3f9cf83908347e7325d231a2f2fad065f
sha256sums = 7db33dbe4048286cc08f76de61c2a81eb9d06f0c8c76d532c5e8c50a7952789f
sha256sums = d793964f2d407ddf43f233b72d41571655296c8501123f07ed986e00e6a8d19e
sha256sums = c7cfa75590d3845f7c8fc05098e34f4a5a7183a755199dfbeb9c695aeef63ec1
diff --git a/PKGBUILD b/PKGBUILD
index 3662d327175a..d63ce93fb64c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=constructor-gog
pkgver=1.0_cs
-pkgrel=1
+pkgrel=2
pkgdesc="Control a construction company, and aim to drive the other players out of business."
url="https://www.gog.com/game/constructor"
license=('custom:eula')
@@ -25,7 +25,7 @@ source=("setup_constructor_${pkgver}_(28162).exe"::"gogdownloader://constructor/
"fix-permissions.sh")
sha256sums=('35fcb4970635309697812a6ca9195194ed2e6d0ffa0f70669cb10b6d2845e835'
- 'bce1e648feb9e15bcbc33f7dec9a290a01c224a083801d258d9db36f4314c92b'
+ '34d7224ec640ff37dc26d894eb56a6a3f9cf83908347e7325d231a2f2fad065f'
'7db33dbe4048286cc08f76de61c2a81eb9d06f0c8c76d532c5e8c50a7952789f'
'd793964f2d407ddf43f233b72d41571655296c8501123f07ed986e00e6a8d19e'
'c7cfa75590d3845f7c8fc05098e34f4a5a7183a755199dfbeb9c695aeef63ec1'
diff --git a/constructor-gog.sh b/constructor-gog.sh
index cc0dbb425142..2327053b9160 100644
--- a/constructor-gog.sh
+++ b/constructor-gog.sh
@@ -14,6 +14,7 @@ cat <<EOF
$script --windowed
$script --client
$script --server --windowed
+ DOSBOX_CMD=dosbox-x $script
EOF
exit 0
}
@@ -23,6 +24,7 @@ popd() { builtin popd > /dev/null; }
INSTALL_DIR=/opt/constructor
HOME_DIR="$HOME"/.gog/constructor
+DOSBOX_CMD=${DOSBOX_CMD:-dosbox}
if which unionfs &> /dev/null; then
USE_UNIONFS=1
@@ -83,9 +85,9 @@ if [ "$USE_UNIONFS" ]; then
unionfs -o cow,relaxed_permissions "$UPPER_DIR=RW:$LOWER_DIR=RO" "$UNION_DIR"
echo "Launching game within $UNION_DIR"
- pushd "$UNION_DIR" && dosbox "${configs[@]}"
+ pushd "$UNION_DIR" && "$DOSBOX_CMD" "${configs[@]}"
popd && fusermount -u "$UNION_DIR"
else
echo "Launching game within $INSTALL_DIR"
- cd $INSTALL_DIR && dosbox "${configs[@]}"
+ cd $INSTALL_DIR && "$DOSBOX_CMD" "${configs[@]}"
fi