summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasith Gunawardhana2019-05-17 14:01:05 -0700
committerDasith Gunawardhana2019-05-17 14:01:05 -0700
commite3758feb4b6f791ab09604e570541501ca22db37 (patch)
tree569f16e53cea525a6d089d824ee27cb1e2b69b11
parent9978a2327f4e1c554e37b1612ed74b2b546e63d9 (diff)
downloadaur-consul-git.tar.gz
add GOPATH/bin to PATH
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3566838ee36d..02f9461025a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = consul-git
pkgdesc = Consul is a distributed, highly available, and data center aware solution to connect and configure applications across dynamic, distributed infrastructure.
- pkgver = v1.5.0_5_g5508fd164
+ pkgver = v1.5.0_35_gf452de1c5
pkgrel = 1
url = https://www.consul.io/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d0cc3abfa688..e5fbccfc38af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=consul
pkgname=${_pkgname}-git
-pkgver=v1.5.0_5_g5508fd164
+pkgver=v1.5.0_35_gf452de1c5
pkgrel=1
pkgdesc="Consul is a distributed, highly available, and data center aware solution to connect and configure applications across dynamic, distributed infrastructure."
arch=('x86_64')
@@ -21,6 +21,10 @@ pkgver() {
}
prepare() {
+ mkdir -p gopath
+ export GOPATH="${srcdir}/gopath"
+ export PATH="$PATH:$GOPATH/bin"
+
cd ${_pkgname}
make tools
}
@@ -30,6 +34,8 @@ build() {
cd ${_pkgname}
make dev
+
+ unset GOFLAGS
}
# check() {