summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Tran2016-11-21 17:17:10 +1100
committerVictor Tran2016-11-21 17:17:10 +1100
commit2bf7b772c2193cbd981ea181cf9095c35179cd8e (patch)
treef8f15ef52ec528a5ca2f2688f52603d5203bc0e8
downloadaur-2bf7b772c2193cbd981ea181cf9095c35179cd8e.tar.gz
Initial Commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..174d8a0ef316
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = contemporary-widgets
+ pkgdesc = Contemporary Widget Theme
+ pkgver = 1.0
+ pkgrel = 0
+ url = https://github.com/vicr123/contemporary-theme
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ source = contemporary-widgets-1.0::git+https://github.com/vicr123/contemporary-theme#branch=master
+ md5sums = SKIP
+
+pkgname = contemporary-widgets
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc9bfe4a459c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+
+# Maintainer: Victor Tran <vicr12345 at gmail dot com>
+pkgname=contemporary-widgets
+pkgver=1.0
+pkgrel=0
+pkgdesc="Contemporary Widget Theme"
+arch=("x86_64")
+url="https://github.com/vicr123/contemporary-theme"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('git')
+source=("$pkgname-$pkgver"::'git+https://github.com/vicr123/contemporary-theme#branch=master')
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+ qmake
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/qt/plugins/styles/"
+ cp "$pkgname-$pkgver/libContemporary.so" "$pkgdir/usr/lib/qt/plugins/styles/contemporary.so"
+}