summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp Gesang2016-09-08 23:22:26 +0200
committerPhilipp Gesang2016-09-08 23:33:40 +0200
commit3c70ebed6ef0c508b4523da8e7ff5dbe32baa727 (patch)
tree322cf9201e3e7b1be5894965e91ec63d51a55af1
downloadaur-context-git.tar.gz
initial: import PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..317be37fa62d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = context-git
+ pkgdesc = The ConTeXt typesetting system; sources from Git
+ pkgver = 3f59c56
+ pkgrel = 1
+ url = http://pragma-ade.nl
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = luatex-svn
+ conflicts = context-minimals-git
+ source = context-mirror-git::git+https://bitbucket.org/phg/context-mirror.git#branch=beta
+ sha256sums = SKIP
+
+pkgname = context-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a269a88aead
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Context from Git mirror
+# Maintainer: Philipp Gesang <phg@phi-gamma.net>
+pkgname=context-git
+pkgver=e2902f3
+pkgrel=1
+pkgdesc="The ConTeXt typesetting system; sources from Git"
+arch=(any)
+url="http://pragma-ade.nl"
+license=('GPL2')
+makedepends=('git' 'luatex-svn')
+conflicts=(context-minimals-git)
+sha256sums=('SKIP')
+
+_git_repo=bitbucket.org/phg/context-mirror.git
+_git_branch=beta
+_git_checkout=context-mirror-git
+source=("${_git_checkout}::git+https://${_git_repo}#branch=${_git_branch}")
+
+pkgver() {
+ cd "${_git_checkout}"
+ # no tags in mirror repo
+ git describe --always
+}
+
+build() {
+ cd "${srcdir}"
+ if [[ ! -d "${_git_checkout}" ]]; then
+ msg "expected repo checkout at ${srcdir}/${_git_checkout}"
+ exit -1
+ fi
+}
+
+package() {
+ local subdirs=( bibtex colors context doc fonts metapost scripts tex web2c )
+ local dst="${pkgdir}/usr/share/${pkgname}"
+ install -dm755 "${dst}"
+
+ cd "${srcdir}"
+ for dir in ${subdirs[@]} ; do
+ cp -ra "${_git_checkout}/${dir}" "${dst}/"
+ done
+}
+
+# vim:ft=sh:et:sw=2:ts=8