summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAditya Mahajan2016-05-07 16:52:00 -0400
committerAditya Mahajan2016-05-08 11:47:05 -0400
commitb62db4b129faeed8db96e52eb26c91f9687e80f5 (patch)
treec2dfbd8cae21270b2316f7ca4aaf627f153c254e
parent220c0201fdba4c78a30a033058050e9b5e2d5386 (diff)
downloadaur-b62db4b129faeed8db96e52eb26c91f9687e80f5.tar.gz
Use rsync instead of cp
mtxrun creates the cache in $srcdir/tex/texmf-cache which gets copied to $pkgdir. The cache is created in a different directory each time. After a while, the cache directory gets big. Using rsync -d deletes the old cache directories at the destination
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c3066591427..6d8d59e955e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Aditya Mahajan <adityam at umich dot edu>
pkgname=context-minimals-git
-pkgver=2016.04.10
+pkgver=2016.05.07
pkgrel=1
pkgdesc="A standalone ConTeXt distribution"
url="http://www.contextgarden.net"
@@ -58,7 +58,7 @@ prepare() {
msg "Initializing download directory"
mkdir -p $srcdir/tex/texmf-cache || return 1
-
+
msg "Starting download or update of ConTeXt distribution"
PATH=$scrdir/tex/texmf-$platform/bin:$PATH \
$srcdir/bin/texlua $srcdir/bin/mtxrun --script $srcdir/bin/mtx-update.lua \
@@ -99,5 +99,8 @@ package()
{
install -d $pkgdir/opt || return 1
msg "Copying files"
- cp -r --preserve=links $srcdir/tex $pkgdir/$_dest || return 1
+ # cp -r does not delete old files that are present in texmf-cache from
+ # previous installation
+ # cp -r --preserve=links $srcdir/tex $pkgdir/$_dest || return 1
+ rsync -az --links --delete --info=progress2 $srcdir/tex/ $pkgdir/$_dest || return 1
}