summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoradityam2010-01-24 14:51:49 -0500
committerAditya Mahajan2016-04-02 13:08:37 -0400
commite950bb805df24aa666761b65ac038a21438b3469 (patch)
tree6f12ac3a6ad98e755b230d98278b65daa9d2811f
downloadaur-e950bb805df24aa666761b65ac038a21438b3469.tar.gz
Initial upload
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD80
-rw-r--r--README36
-rw-r--r--context-minimals-git.install27
4 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75625669b1f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = context-minimals-git
+ pkgdesc = A standalone ConTeXt distribution
+ pkgver = 2016.03.04
+ pkgrel = 1
+ url = http://www.contextgarden.net
+ install = context-minimals-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = rsync
+ optdepends = fontconfig: xetex support
+ optdepends = ruby: pdftex support
+ optdepends = ghostscript: support for PS and EPS images
+ optdepends = graphicmagic: support for GIF and TIFF images
+ optdepends = inkscape: support for SVG images
+ optdepends = pstoedit: support for metapost outlines for fonts
+ optdepends = zint: support for barcodes
+ optdepends = curl: loading remote content
+
+pkgname = context-minimals-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22d9035c1d8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Maintainer: Aditya Mahajan <adityam at umich dot edu>
+pkgname=context-minimals-git
+pkgver=20100122
+pkgrel=1
+pkgdesc="A standalone ConTeXt distribution"
+url="http://www.contextgarden.net"
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('ruby')
+makedepends=('rsync')
+optdepends=('fontconfig: xetex support')
+
+conflicts=()
+replaces=()
+backup=()
+
+install=context-minimals-git.install
+
+# ConTeXt minimals uses a different naming convention for architectures
+_platform_map['i686']='linux'
+_platform_map['x86_64']='linux-64'
+
+_platform=${_platform_map[$arch]}
+
+_rsyncurl=rsync://contextgarden.net/minimals/setup/${_platform}/bin
+_dest=/opt/context-minimals
+
+# This is the only way to get yaourt to store the files in
+# /var/abs/local/yaourtbuild so that rsyncing the next time is efficient
+
+_gitroot="http://dl.contextgarden.net/distribution/git/"
+_gitname="master"
+
+# Font directories
+_texlivefontdir="/usr/share/texmf-dist/fonts/"
+_userfontdir="\$HOME/.fonts"
+_osfontdir="/usr/share/fonts"
+
+build() {
+ msg "Downloading the latest scripts first"
+ rsync -rlptv $_rsyncurl $srcdir
+ msg "Initializing download directory"
+
+ mkdir -p $srcdir/tex/texmf-cache
+
+ msg "Starting download or update of ConTeXt distribution"
+ $srcdir/bin/texlua $srcdir/bin/mtxrun --script $srcdir/bin/mtx-update.lua \
+ --platform=$_platform --texroot=$srcdir/tex --engine=all --extras=all \
+ --context=beta --update --force --make || return 1
+
+ # The setuptex that comes with minimals does not work in a multi-user
+ # environment. So, we modify it appropriately.
+
+ echo "TEXMFOS=${_dest}/texmf-${_platform}" > $srcdir/tex/setuptex
+ echo "export TEXMFOS" >> $srcdir/tex/setuptex
+ echo "" >> $srcdir/tex/setuptex
+ echo "TEXMFCACHE=\$HOME/texmf-cache:${_dest}/texmf-cache" \
+ >> $srcdir/tex/setuptex
+ echo "export TEXMFCACHE" >> $srcdir/tex/setuptex
+ echo "" >> $srcdir/tex/setuptex
+ echo "unset TEXINPUTS MPINPUTS MFINPUTS" >> $srcdir/tex/setuptex
+ echo "" >> $srcdir/tex/setuptex
+ echo "PATH=\$TEXMFOS/bin:\$PATH" >> $srcdir/tex/setuptex
+ echo "export PATH" >> $srcdir/tex/setuptex
+ echo "" >> $srcdir/tex/setuptex
+ echo "OSFONTDIR=\"$_userfontdir;$_osfontdir;\"" \
+ >> $srcdir/tex/setuptex
+ echo "export OSFONTDIR" >> $srcdir/tex/setuptex
+ # If texlive exists, use fonts from texlive
+ if [ -d $_texlivefontdir ]
+ then
+ mkdir -p $srcdir/tex/texmf-fonts
+ ln -s -f $_texlivefontdir $srcdir/tex/texmf-fonts/fonts
+ fi
+
+
+ install -d $pkgdir/opt || return 1
+ msg "Copying files"
+ cp -r --preserve=links $srcdir/tex $pkgdir/$_dest || return 1
+}
diff --git a/README b/README
new file mode 100644
index 000000000000..73754b4dd10e
--- /dev/null
+++ b/README
@@ -0,0 +1,36 @@
+PKGBUILD for context-minimals
+=============================
+
+The ConTeXt Minimal <http://wiki.contextgarden.net/ConTeXt_Minimals> is
+a complete, up-to-date ConTeXt distribution which can be upgraded
+efficiently. It can be used to install either the stable or the beta
+version of ConTeXt. It can also be used in parallel with existing TeX
+installtions such as MikTeX, TeXLive, or older minimal installation. It
+is aimed towards ConTeXt users, so it does not include LaTeX specific
+packages and binaries.
+
+This PKGBUILD installs the ConTeXt related files at
+
+ /opt/context-minimals
+
+To use the minimals distribution, you need to run
+
+ source /opt/context-minimals/setuptex
+
+in the shell from which you want to invoke context. After sourcing
+setuptex, you can run ConTeXt mkII using
+
+ texexec filename
+
+To run mkIV for the first time, you need to run
+
+ luatools --generate
+
+a normal user (*and not as root*). You need to rerun this command as a
+normal user each time you upgrade.
+
+All bugs can be reported at the ConTeXt mailing list
+<http://wiki.contextgarden.net/ConTeXt_Mailing_Lists>
+
+
+
diff --git a/context-minimals-git.install b/context-minimals-git.install
new file mode 100644
index 000000000000..f5b041632560
--- /dev/null
+++ b/context-minimals-git.install
@@ -0,0 +1,27 @@
+post_install() {
+ echo "*************************************************************"
+ echo "To use ConTeXt minimals run"
+ echo " source /opt/context-minimals/setuptex"
+ echo "from your shell (as a normal user)"
+ echo ""
+ echo "To use MkIV run"
+ echo " luatools --generate"
+ echo "from your shell (as a normal user)"
+ echo "*************************************************************"
+}
+
+post_upgrade() {
+ echo "*************************************************************"
+ echo "To use ConTeXt minimals run"
+ echo " source /opt/context-minimals/setuptex"
+ echo "from your shell (as a normal user)"
+ echo ""
+ echo "To use MkIV run"
+ echo " luatools --generate"
+ echo "from your shell (as a normal user)"
+ echo "*************************************************************"
+}
+
+pre_remove() {
+ /bin/true
+}